LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Amarok can't read audio CD? (http://www.linuxquestions.org/questions/ubuntu-63/amarok-cant-read-audio-cd-687107/)

Mark_667 11-29-2008 02:57 PM

Amarok can't read audio CD?
 
Amarok shows 'Could not read Audio CD' in the status bar, ks CD appears to be playing it but must be sending it down the wrong channel or something because I don't hear anything. If I open any media file the sound comes through perfectly.

I eventually got it to work through Xine which worked first time (once I'd found the PLaylist>Get from>CD option - which is obviously what I'd immediately think of if I wanted to play a CD.) Also, what the **** is going on with those menus?

Anyway, I'm quite disappointed that I had to jump through this many hoops just in order to play a CD why can't Amarok just do it?

camorri 11-30-2008 07:46 PM

Amarok plays audio CD's on my system. I'm running version 1.4.8

All I do is insert the audio CD, click Engage--> Play Audio CD. It takes a few seconds to read the files on the CD, and populate the playlist. Then I click the play button.

Have a look at your Amarok configuration, under Settings. Look at the Engine tab. What is set in your Default device field?

Mark_667 12-05-2008 02:39 PM

When I go to Engage--> Play Audio CD I get 'Could not read audio CD' in the status bar. For the Engine the default device is dev/hdc, which I think is correct, I have tried changing this to /dev/cdrom and /dev/cdrom0 but it makes no difference.

tommcd 12-07-2008 05:21 AM

Quote:

Originally Posted by Mark_667 (Post 3365711)
When I go to Engage--> Play Audio CD I get 'Could not read audio CD' in the status bar. For the Engine the default device is dev/hdc, which I think is correct, I have tried changing this to /dev/cdrom and /dev/cdrom0 but it makes no difference.

In terminal run "cat /etc/fstab". There will be an entry in fstab for your cdrom device. Ubuntu Intrepid on my laptop lists the cdrom as /dev/scd0. Try setting Amarok's default device to whatever your cdrom is listed as in fstab.

Mark_667 12-07-2008 11:16 AM

Thanks tommcd that did it, /dev/cdrom0 is the mount point, the CD drive actually lives on /dev/scd0, pointing Amarok at that works.


All times are GMT -5. The time now is 07:17 PM.