LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 11-29-2008, 01:57 PM   #1
Mark_667
Member
 
Registered: Aug 2005
Location: Manchester, England
Distribution: Ubuntu 12.10
Posts: 257

Rep: Reputation: 25
Amarok can't read audio CD?


Amarok shows 'Could not read Audio CD' in the status bar, ks CD appears to be playing it but must be sending it down the wrong channel or something because I don't hear anything. If I open any media file the sound comes through perfectly.

I eventually got it to work through Xine which worked first time (once I'd found the PLaylist>Get from>CD option - which is obviously what I'd immediately think of if I wanted to play a CD.) Also, what the **** is going on with those menus?

Anyway, I'm quite disappointed that I had to jump through this many hoops just in order to play a CD why can't Amarok just do it?
 
Old 11-30-2008, 06:46 PM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,845

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Amarok plays audio CD's on my system. I'm running version 1.4.8

All I do is insert the audio CD, click Engage--> Play Audio CD. It takes a few seconds to read the files on the CD, and populate the playlist. Then I click the play button.

Have a look at your Amarok configuration, under Settings. Look at the Engine tab. What is set in your Default device field?
 
Old 12-05-2008, 01:39 PM   #3
Mark_667
Member
 
Registered: Aug 2005
Location: Manchester, England
Distribution: Ubuntu 12.10
Posts: 257

Original Poster
Rep: Reputation: 25
When I go to Engage--> Play Audio CD I get 'Could not read audio CD' in the status bar. For the Engine the default device is dev/hdc, which I think is correct, I have tried changing this to /dev/cdrom and /dev/cdrom0 but it makes no difference.
 
Old 12-07-2008, 04:21 AM   #4
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by Mark_667 View Post
When I go to Engage--> Play Audio CD I get 'Could not read audio CD' in the status bar. For the Engine the default device is dev/hdc, which I think is correct, I have tried changing this to /dev/cdrom and /dev/cdrom0 but it makes no difference.
In terminal run "cat /etc/fstab". There will be an entry in fstab for your cdrom device. Ubuntu Intrepid on my laptop lists the cdrom as /dev/scd0. Try setting Amarok's default device to whatever your cdrom is listed as in fstab.
 
Old 12-07-2008, 10:16 AM   #5
Mark_667
Member
 
Registered: Aug 2005
Location: Manchester, England
Distribution: Ubuntu 12.10
Posts: 257

Original Poster
Rep: Reputation: 25
Thanks tommcd that did it, /dev/cdrom0 is the mount point, the CD drive actually lives on /dev/scd0, pointing Amarok at that works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amarok 'Could not read AudioCD' Earl Parker II Linux - Software 2 04-13-2007 11:16 AM
Amarok 1.4.5 and some .asf audio filea raylhm Suse/Novell 3 03-25-2007 09:37 AM
Audio/Amarok(?) stuttering sound Sammael Linux - Software 5 08-26-2006 06:42 AM
Amarok audio effects librano Linux - Software 0 07-26-2005 02:31 PM
Streaming audio in Amarok wfischer Linux - Software 0 06-17-2005 03:18 PM


All times are GMT -5. The time now is 11:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration