LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-25-2009, 12:04 PM   #1
rsmereka
LQ Newbie
 
Registered: Jul 2003
Location: Southwestern Ontario, Canada
Distribution: Ubuntu 6.04LTS, Ubuntu 8.04LTS, Ubuntu 9.04
Posts: 27

Rep: Reputation: 15
9.04 Dell Vostro 420 Desktop No Audio


Hi All,

My Vostro 420 has a RealTek audio sub-system. I had the audio working at some point but now I get nothing. Realtek is no longer listed in the volume control. Output of 'aplay -l' is:
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC662 Analog [ALC662 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC662 Digital [ALC662 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Output of 'lspci' (audio sections only) is:
Code:
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
	Subsystem: Dell Device 0282
	Flags: bus master, fast devsel, latency 0, IRQ 22
	Memory at fe8f8000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [100] Virtual Channel <?>
	Capabilities: [130] Root Complex Link <?>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel

01:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
	Subsystem: Dell Device aa28
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at fe9ec000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
	Capabilities: [100] Vendor Specific Information <?>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel
Any ideas?
Rick
 
Old 08-27-2009, 06:38 AM   #2
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 286Reputation: 286Reputation: 286
There is no RealTek listed in your output of lspci. Did there used to be?
Your lspci indicates you have intel ICH10 audio.
If you run lsmod in the terminal is the snd-hda-intel module loaded?
When you run alsamixer in the terminal do you see the intel audio listed? Did you try alsamixer, and making sure everything is not muted, and turn the volume levels up?

Last edited by tommcd; 08-27-2009 at 06:39 AM.
 
Old 08-27-2009, 07:18 AM   #3
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
If your running 2 sound cards try switching the jack to the other card? (like from a SBL to onboard). I disable my onbard because of that type of problem, plus my onboard is broke... Well I could never get it to work that is. =(
 
Old 08-28-2009, 07:57 AM   #4
rsmereka
LQ Newbie
 
Registered: Jul 2003
Location: Southwestern Ontario, Canada
Distribution: Ubuntu 6.04LTS, Ubuntu 8.04LTS, Ubuntu 9.04
Posts: 27

Original Poster
Rep: Reputation: 15
Tommcd,

I don't know if the Realtek audio was listed in lspci I never looked there until it the audio stopped working. The volume control 'device' shows no Realtek present and there used to be. In native Windows, the audio device shows as Realtek (integrated).

Output of lsmod follows:
Code:
Module                  Size  Used by
nls_iso8859_1          12032  0 
nls_cp437              13696  0 
vfat                   18816  0 
fat                    58272  1 vfat
binfmt_misc            16776  1 
ppdev                  15620  0 
bridge                 56212  0 
stp                    10500  1 bridge
bnep                   20224  2 
vboxnetadp             88552  0 
vboxnetflt             95240  0 
vboxdrv               130344  1 vboxnetflt
input_polldev          11912  0 
video                  25360  0 
output                 11008  1 video
usb_storage            99648  0 
lp                     17156  0 
parport                42220  2 ppdev,lp
snd_hda_codec_atihdmi    11520  1 
snd_hda_codec_realtek   205060  1 
snd_hda_intel          34120  2 
snd_pcm_oss            45984  0 
snd_hda_codec          83584  3 snd_hda_codec_atihdmi,snd_hda_codec_realtek,snd_hda_intel
snd_mixer_oss          22912  1 snd_pcm_oss
snd_hwdep              15364  1 snd_hda_codec
snd_pcm                82948  3 snd_hda_intel,snd_pcm_oss,snd_hda_codec
snd_seq_oss            36224  0 
snd_seq_midi_event     15232  1 snd_seq_oss
snd_seq                57584  4 snd_seq_oss,snd_seq_midi_event
snd_timer              29192  2 snd_pcm,snd_seq
snd_seq_device         15372  2 snd_seq_oss,snd_seq
psmouse                61972  0 
snd                    66852  15 snd_hda_codec_realtek,snd_hda_intel,snd_pcm_oss,snd_hda_codec,snd_mixer_oss,snd_hwdep,snd_pcm,snd_seq_oss,snd_seq,snd_timer,snd_seq_device
hid_dell               10112  0 
fglrx                2081668  35 
soundcore              15200  1 snd
serio_raw              13444  0 
iTCO_wdt               19108  0 
iTCO_vendor_support    11652  1 iTCO_wdt
intel_agp              34108  0 
snd_page_alloc         17032  2 snd_hda_intel,snd_pcm
dcdbas                 15264  0 
agpgart                42696  2 fglrx,intel_agp
pcspkr                 10496  0 
usbhid                 42336  1 hid_dell
r8169                  40836  0 
mii                    13312  1 r8169
fbcon                  46112  0 
tileblit               10752  1 fbcon
font                   16384  1 fbcon
bitblit                13824  1 fbcon
softcursor              9984  1 bitblit
The interesting things here are:

1. Intel module is listed
2. Realtek is also listed

When I run alsamixer from the terminal, I get the error:
Code:
alsamixer: function snd_ctl_open failed for default: No such file or directory
There are three entries in the volume control device:

1. Playback: HDA Intel - ALC662 Analog (PulseAudio Mixer)
2. Capture: HDA Intel - ALC662 Analog (PluseAudio Mixer)
3. Capture: Monitor of HDA Intel - ALC662 Analog (PluseAudio Mixer)

mushroomboy:

Even though ATI is listed in the output of lspci as part of the video card, there are no audio jacks on the video card and there are only one set of audio jacks at the back of the machine. The lead to my speakers is plugged into the line out of the integrated audio (part of the motherboard).

Thanks for the response. Where do we go from here,
Rick
 
Old 09-02-2009, 08:39 AM   #5
rsmereka
LQ Newbie
 
Registered: Jul 2003
Location: Southwestern Ontario, Canada
Distribution: Ubuntu 6.04LTS, Ubuntu 8.04LTS, Ubuntu 9.04
Posts: 27

Original Poster
Rep: Reputation: 15
Since I was not getting any nibbles on this issue, I tried a couple of things myself. One of the experiments I did was to re-enable GDM. I disabled GDM as I always do with all Linux's because a lot of times, I don't need a GUI

As soon as I re-enabled GDM, the audio returned. I know, it sounds weird. GDM should have nothing to do with the audio, but it's presence does have an interaction.

This is not the only interaction that I noticed. When I disabled GDM and as soon as I switched from the desktop (F7) to any console and then back again, the screensaver stopped working. The screen would go black with the backlight still on and that was it.

Bottom line is that I have the choice of whether to live with these bugs in 9.04, re-enable GDM, or move back to Ubuntu 8.04 LTS and hope that these issues do not exist. So far, I have re-enabled GDM but I don't like it.

Rick

Last edited by rsmereka; 09-02-2009 at 08:45 AM.
 
Old 09-04-2009, 09:16 AM   #6
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
GDM could be loading extra gnome libs, that's why I don't like installing a desktop off the bat. I like to install xmms2 without any xserver and test sound... well mainly so I can have sound during the apt-get install stuff... haha but yeah I tell people if your used to linux enough try installing without a desktop and configure apt-get yourself and install what you want that way. You have a more customized desktop =) but I don't know if ubuntu can do that, I only work with debian.
 
Old 09-04-2009, 04:55 PM   #7
rsmereka
LQ Newbie
 
Registered: Jul 2003
Location: Southwestern Ontario, Canada
Distribution: Ubuntu 6.04LTS, Ubuntu 8.04LTS, Ubuntu 9.04
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by mushroomboy View Post
GDM could be loading extra gnome libs, that's why I don't like installing a desktop off the bat. I like to install xmms2 without any xserver and test sound... well mainly so I can have sound during the apt-get install stuff... haha but yeah I tell people if your used to linux enough try installing without a desktop and configure apt-get yourself and install what you want that way. You have a more customized desktop =) but I don't know if ubuntu can do that, I only work with debian.
I don't know what xmms2 is, ok looked it up.

FYI for you and others.

My usb automount all of a sudden started working also when I re-enabled GDM so there is also a link there between the desktop and usb automount.

I don't like 9.04 that much. I am preparing 8.04 LTS for a replacement.

Rick

Last edited by rsmereka; 09-04-2009 at 04:57 PM.
 
Old 09-05-2009, 04:18 AM   #8
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by rsmereka View Post
As soon as I re-enabled GDM, the audio returned. I know, it sounds weird. GDM should have nothing to do with the audio, but it's presence does have an interaction.
I had also tried disabling GDM in Ubuntu in the past, but I re-enabled it because I also had lost sound (and I think some other things, but I don't remember) without loading GDM. As soon as I re-enabled GDM and rebooted the sound came back.

I once noticed something similar when I was using Arch with the Gnome desktop. Without GDM automounting devices such as usb flash drives did not work. When I enabled GDM automounting worked. There was probably a way to enable automounting in Gnome on Arch without GDM, but I never tried to find out, as GDM fixed it.
I think GDM in Gnome must do other stuff besides just provide a graphical login.
 
  


Reply

Tags
audio, dell, gdm, vostro


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu on Dell Vostro nbhat Ubuntu 8 11-29-2009 01:57 AM
Dell vostro 1310-Query khaleel5000 Linux - Hardware 2 05-04-2009 02:15 AM
Dell Vostro 1310 with Slackware 12.1 mfduqued Linux - Laptop and Netbook 3 01-06-2009 05:44 PM
not installing fedora 8 on dell Vostro 200 desktop ashfaq Linux - Software 1 10-08-2008 03:47 AM
Dell Vostro 400 missluci General 4 03-16-2008 02:54 PM


All times are GMT -5. The time now is 02:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration