LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-19-2005, 02:14 AM   #1
ericthehammer
LQ Newbie
 
Registered: Aug 2005
Posts: 25

Rep: Reputation: 15
3d acceleration troube - ATI Radeon 9250


Howdy. I've been trying to get 3d acceleration going for the last 2 days, and I'm out of ideas.
I am really hoping somebody can shed some light for me.

Here is my xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "fglrx"
Driver "fglrx"
BusID "PCI:6:0:0"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "fglrx"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection



When I type fglrxinfo I get
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

I've followed the ubuntu howto install ati page. And I tried it again. And again. Please somebody help me.
 
Old 08-19-2005, 04:38 AM   #2
ankscorek
Member
 
Registered: Mar 2003
Distribution: Slackware10.2,SUSE,FC,RHL,Vector Linux,WHAX,PHLAK,bt4,ubuntu,debian,aptosid,backtrack,blackbuntu
Posts: 529

Rep: Reputation: 31
canu pl specify the RAM u r using.........
 
Old 08-19-2005, 10:58 AM   #3
ericthehammer
LQ Newbie
 
Registered: Aug 2005
Posts: 25

Original Poster
Rep: Reputation: 15
I'm using 3 sticks odd DDR pc 3200. 1 gig each.
 
Old 08-19-2005, 11:23 PM   #4
ankscorek
Member
 
Registered: Mar 2003
Distribution: Slackware10.2,SUSE,FC,RHL,Vector Linux,WHAX,PHLAK,bt4,ubuntu,debian,aptosid,backtrack,blackbuntu
Posts: 529

Rep: Reputation: 31
what is teh o/p of this

#x11perf -repeat 3 -reps 10 -subs 10 100 -circulate

before running this command remember to make a back up of your xorg.conf file....

asssuming everything went off well

we will get dri working

dri allows 3d acceleration

what is th eo/p of this command

#glxinfo | grep direct

also make sure the foll line is there in your xorg.conf file

Section "DRI"
Mode 0666

also in
Section "Device"
VideoRam=16384 or more
 
Old 08-19-2005, 11:36 PM   #5
ericthehammer
LQ Newbie
 
Registered: Aug 2005
Posts: 25

Original Poster
Rep: Reputation: 15
root@ROBOCOP:/home/bronco # x11perf -repeat 3 -reps 10 -subs 10 100 -circulate
x11perf - X11 performance program, version 1.5
The X.Org Foundation server version 60802000 on :0.0
from ROBOCOP
Fri Aug 19 21:34:41 2005

Sync time adjustment is 0.0000 msecs.

100 reps @ 0.0334 msec ( 30000.0/sec): Circulate window (10 kids)
100 reps @ 0.0619 msec ( 16100.0/sec): Circulate window (10 kids)
100 reps @ 0.0663 msec ( 15100.0/sec): Circulate window (10 kids)
300 trep @ 0.0539 msec ( 18600.0/sec): Circulate window (10 kids)

1000 reps @ 0.0425 msec ( 23500.0/sec): Circulate window (100 kids)
1000 reps @ 0.0465 msec ( 21500.0/sec): Circulate window (100 kids)
1000 reps @ 0.0451 msec ( 22200.0/sec): Circulate window (100 kids)
3000 trep @ 0.0447 msec ( 22400.0/sec): Circulate window (100 kids)


and for glxinfo | grep direct


direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
 
Old 08-20-2005, 02:46 AM   #6
ankscorek
Member
 
Registered: Mar 2003
Distribution: Slackware10.2,SUSE,FC,RHL,Vector Linux,WHAX,PHLAK,bt4,ubuntu,debian,aptosid,backtrack,blackbuntu
Posts: 529

Rep: Reputation: 31
make sure the foll line is there in your xorg.conf file

Section "DRI"
Mode 0666

also in
Section "Device"
VideoRam=16384 or more
 
Old 08-20-2005, 03:13 AM   #7
ericthehammer
LQ Newbie
 
Registered: Aug 2005
Posts: 25

Original Poster
Rep: Reputation: 15
Added
VideoRam=16384

Still no difference.
 
Old 08-20-2005, 12:33 PM   #8
ankscorek
Member
 
Registered: Mar 2003
Distribution: Slackware10.2,SUSE,FC,RHL,Vector Linux,WHAX,PHLAK,bt4,ubuntu,debian,aptosid,backtrack,blackbuntu
Posts: 529

Rep: Reputation: 31
what bat DRI?
 
Old 08-20-2005, 04:01 PM   #9
ericthehammer
LQ Newbie
 
Registered: Aug 2005
Posts: 25

Original Poster
Rep: Reputation: 15
Yes, I added what you suggested.
 
Old 08-29-2005, 11:58 PM   #10
ericthehammer
LQ Newbie
 
Registered: Aug 2005
Posts: 25

Original Poster
Rep: Reputation: 15
anybody else have suggestions?
 
Old 08-30-2005, 03:11 AM   #11
Waerner
Member
 
Registered: May 2005
Location: Írebro, Sweden
Distribution: Ubuntu 6.06
Posts: 92

Rep: Reputation: 15
I have the same problem with my 9600 SE Atlantis...

Is this a common problem with ATI?
Anyway, I guess this is atleast one reason why my X is a little bit laggy?
 
Old 08-30-2005, 09:16 AM   #12
Segovia
LQ Newbie
 
Registered: Aug 2005
Distribution: Fedora
Posts: 3

Rep: Reputation: 0
Re: 3d acceleration troube - ATI Radeon 9250

Quote:
Originally posted by ericthehammer
I've followed the ubuntu howto install ati page. And I tried it again. And again. Please somebody help me.
I assume you have the restricted modules installed for the kernel you're using, and you are also using the "xorg-driver-fglrx" in the official repositories?

Do you have an nForce2 chipset, Eric? If so, you *must* add this to the "Device" section of your xorg.conf. (This is stated in the Ubuntu wiki , but I just thought I'd double check that you have tried it.)

Code:
Option  "UseInternalAGPGART" "no"
Sometimes it helps to start fresh by using:

Code:
sudo dpkg-reconfigure xserver-xorg
Choose fglrx (naturally), and answer all the other questions. After finishing that, add the AGPGART option (noted above) to your xorg.conf and reboot.

It should go without saying to backup your xorg.conf first, before making any changes.
 
Old 08-30-2005, 01:17 PM   #13
heltreko
Member
 
Registered: Mar 2005
Location: Stockholm, Sweden
Distribution: Slackware, Zenwalk
Posts: 141

Rep: Reputation: 15
I finally managed to get my ATI 9600 working properly in ubunty by following a post in this thread "http://ubuntuforums.org/archive/index.php/t-32495.html" by the user Skylark. I suggest you follow the above link and search for "ati_install.sh".

Follow those instructions. Worked like a charm for me ever since and I've jusr rerun the script after compiling kernels etc.
 
Old 08-30-2005, 01:22 PM   #14
ericthehammer
LQ Newbie
 
Registered: Aug 2005
Posts: 25

Original Poster
Rep: Reputation: 15
Re: Re: 3d acceleration troube - ATI Radeon 9250

Quote:
Originally posted by Segovia
I assume you have the restricted modules installed for the kernel you're using, and you are also using the "xorg-driver-fglrx" in the official repositories?

Do you have an nForce2 chipset, Eric? If so, you *must* add this to the "Device" section of your xorg.conf. (This is stated in the Ubuntu wiki , but I just thought I'd double check that you have tried it.)

Code:
Option  "UseInternalAGPGART" "no"
Sometimes it helps to start fresh by using:

Code:
sudo dpkg-reconfigure xserver-xorg
Choose fglrx (naturally), and answer all the other questions. After finishing that, add the AGPGART option (noted above) to your xorg.conf and reboot.

It should go without saying to backup your xorg.conf first, before making any changes.
Yes I'm using the xorg-driver-fglrx from the official repository. I don't think I have an nForce2 chipset. How do I check? I have an intel 915gav mobo. I reconfigured xorg, again. And added the UseInernalAGPGART line. Still nothing.
 
Old 08-30-2005, 01:56 PM   #15
ericthehammer
LQ Newbie
 
Registered: Aug 2005
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by heltreko
I finally managed to get my ATI 9600 working properly in ubunty by following a post in this thread "http://ubuntuforums.org/archive/index.php/t-32495.html" by the user Skylark. I suggest you follow the above link and search for "ati_install.sh".

Follow those instructions. Worked like a charm for me ever since and I've jusr rerun the script after compiling kernels etc.
When I did that, I get this message

Unable to determine a compatible system architecture
The ATI Linux drivers only support AMD64 or X86 I386

I'm using i686
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 9250 Driver gambleDT Debian 16 12-15-2008 08:31 AM
Radeon 9250 - no 3d acceleration ericthehammer Ubuntu 38 09-10-2005 06:55 PM
Help, ati radeon 9250 rude_reality Slackware 9 06-22-2005 12:53 AM
ATI Radeon 9250 V280 Problems Hubmasterflex Linux - Hardware 1 06-03-2005 05:19 PM
How to install drivers (ATI RADEON 9250) Sfx Mandriva 2 05-04-2005 07:03 AM


All times are GMT -5. The time now is 05:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration