-   SUSE / openSUSE (
-   -   yast segmentation fault, system freezing - nvidia driver at fault? (

BaltikaTroika 12-01-2005 12:53 AM

yast segmentation fault, system freezing - nvidia driver at fault?
(running OpenSUSE 10.0 on an AMD 1200 w/ nforce2 chipset)

I've been having lots of problems lately with running yast. I can't seem to run it unless I reboot my system and try running it on a fresh boot. This tells me I've got some major problems. Most times, I'll try running it, choosing my programs to install, and then it'll just hang at the "preparing to install" dialog. I tried running it through the console and I got a segmentation fault.

I think that my problems stem, indirectly, from my video driver. I've got an nforce2 onboard chip and downloaded the nvidia driver for it. Ever since then, I've had weird problems, including lots of freezing. Everything freezes. Even my numlock and other keys won't light up when I press them, ctrl-alt-back doesn't work, nothing works. I often get graphical (onscreen) glitches, which happen minutes before my system completely rolls over and dies. This means I've got to press the reset button, which further screws stuff up.

The problem gets worse, because I'm normally in KDE when it freezes like that. So when I reboot, I've got KDE problems. I've tried deleting tmp directories and whatnot (as I found in another post), which really helps - until the next time my computer freezes!

I've tried researching this to see how I can fix the problem. I haven't found too much. There's some stuff I can delete in order to clean out KDE. I can also reiserfsck my system.

Does anybody have any suggestions? Is there a problem with the newest nvidia driver and nforce2 chipsets? Should I install an older version?

I don't really know what I should do here. I don't really want to go without my 3d acceleration (I've got another networked machine running a via chipset (without 3d acceleration) which is as solid as a rock), but I will if I have to.

Any ideas (on how to fix my problems, or do maintenance - even reiserfsck is a new concept to me!) are appreciated.


mrshadow76 12-02-2005 10:08 AM

As I posted in another thread, I finally read the "README" file that came with SuSE 10.0. It mentioned a problem with NVIDIA 6x00 chipsets and SuSE 10.0. The symptom was locking and hanging. They are aware of it, and unfortunately, I have no further information.

And now I realize, that probably doesn't answer you question at all. However, I think it confirms that you're having a problem with the driver.

I'm not a filesystem guru, but Reiser may not be your best choice. Consider ext3, or even XFS. Probably a little late now, but, you might want to reinstall and test the system again without the latest NVIDIA driver to determine if that's it.

broch 12-02-2005 10:34 AM

1) boot up to KDE
2) open terminal window and enter:
#init 3
3) login
4) su to root
5) edit /etc/X11/xorg.conf
and change
nvidia driver to "nv"

init 5

if the above works, then you may delete nvidia drivers completely:
in the terminal window run (assuming that you are using nv driver)
#5) run:
nvidia-installer --uninstall

If you can't get to KDE, boot to failsafe mode and follow the above instruction from step 3)

There is too many reasons why nvidia (if this is in fact nvidia) kills your system.
To diagnose nvidia set
Option "NvAGP" "1"
and disable
#Option "RenderAccel"
in /etc/X11/xorg.conf

If system now will run stable, you can diagnose it further.

All times are GMT -5. The time now is 07:22 PM.