-   SUSE / openSUSE (
-   -   Undecided rpm package backward compatibility between 10.* & 11.* (

pointo1d 12-22-2009 07:27 AM

Undecided rpm package backward compatibility between 10.* & 11.*
Hi all,

Due to circumstances beyond my control, I'm stuck with a server installed with 10.3, but have a requirement to install an new (to the server) application that requires a newer version i.e. utilising LZMA compression, of the rpm package.

I'd like to think that the newer rpm tools could manage both bz2 and lzma compressed packages but, what I can't find anywhere is a statement of the backward compatibility, if any, of the newer package i.e. I'm worried that, if I upgrade the rpm package, I will no longer be able to install 'old', bz2 based packages containing the legacy application.

Any help &/or advice greatly appreciated.


kbp 12-23-2009 05:19 PM

I'm just guessing that you're talking about OpenSuSE, judging by the changes, bzip2 is still supported but not the default compression method:


+- switch payload default to lzma -2
-Requires: popt-devel zlib-devel bzip2 libbz2-devel
+Requires: popt-devel zlib-devel bzip2 libbz2-devel lzma-alpha-devel


knudfl 12-25-2009 02:19 PM

The choices you have, are the two "lzma backported"
rpm 4.4.x SRC.RPMS for Suse 11 or 11.1

The src.rpm 4.7.1 from Suse 11.2 cannot be used :
( my opinion .. ( it compiles OK )) but too many
applications / inter dependencies depends on 4.4 .

I have tried for two days to rebuild the SRC Rpm's
.. or just compile 4.4's against (lib)lzma :
.. No luck on Suse 10.3 .

All times are GMT -5. The time now is 05:42 PM.