Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 07-29-2005, 06:24 PM   #1
LQ Newbie
Registered: Jul 2005
Location: Cleveland, OH
Posts: 1

Rep: Reputation: 0
Trying to get new ATI OpenGL drivers to work

Hi All, I recently installed SUSE Linux 9.0. The first thing that I tried to do was get the current ATI driver software for my Radeon 9600XT card. Here is my system info:

SUSE 9.0(clean install, no automatic updates applied yet)
KDE 3.1.4
XFree86 Version is installed.
Kernel Version: 2.4.21 -99 -Athlon

The driver seemed to install properly, and my KDE desktop seems to be working perfectly other than the fact that the OpenGL drivers seem to be wrong. The ATI drivers install an 'ATI Desktop' utility. When I view the information tab, I see the following OpenGL info:
OpenGL vendor string: Mesa Project
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.04

Here is the result of running the 3Ddiag command:
3Ddiag version 0.703
Verifying 3D configuration:
Using 3dinfo

No 3D capable graphic chipset found!

Checking GL/GLU/glut runtime configuration:
GL/GLU ... done (package XFree86-Mesa)
glut ... done (package mesaglut)

Is there any additional configuration required to get the XWindows to point to the ATI OpenGL driver rather than Mesa?


Joe Patton
Old 07-31-2005, 03:31 AM   #2
LQ Newbie
Registered: Feb 2005
Posts: 5

Rep: Reputation: 0
Mate, I've had huge problems with the exact same issue. I'm running a Radeon X600 (PCI-e which has confused the issue a little also). The way I managed to get my 3D accel running was this:

(1) I ensured my boot arguments (Edit boot.config file using Yast) include "vga=normal" NOT "vga=00x30A" or similar
(2) As root, without X running (CTRL-ALT-BKSP, su, init 3) go thru the steps as outlined in the README on ATI's site.
(3) Before running the line with the SAX2 configuration, I ran FGLRXConfig.
(4) When running the Sax configuration line, the display went blank - I hit Enter, and Ctrl-C.
(5) I ensured the xorg.conf settings generated by flgrxconfig had the correct monitor refresh rates.

It worked!

Old 07-31-2005, 07:51 PM   #3
LQ Newbie
Registered: Feb 2005
Posts: 5

Rep: Reputation: 0
BTW, that reference I have in there to SAX2 is the following command:

sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl -i


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL problem with ATI Drivers Crube Linux - Software 5 08-21-2005 03:42 PM
ATI Drivers will not enable OpenGL? flapinux Linux - Hardware 2 07-02-2005 08:38 AM
OpenGL problems when I updated my ATi Drivers Axi0n Slackware 3 11-03-2004 09:37 PM
yet another FC1, ATI drivers and OpenGL thread :/ Talan Fedora 4 05-18-2004 03:02 AM
OpenGL Lockups with ATI 3.7.6 Drivers anti_trend Linux - Hardware 0 04-04-2004 01:01 AM

All times are GMT -5. The time now is 01:44 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration