-   SUSE / openSUSE (
-   -   Transparent Windows. Not window-decorator (

Score 12-18-2006 11:00 AM

Transparent Windows. Not window-decorator
I got my terminal to have transparent background, how can I do this with all my windows? Any ideas?


broch 12-18-2006 11:59 AM

KDE uses exactly the same mechanism (fake alpha blending). You will need two pre-requisites:

add to /etc/X11/xorg.conf
Section "Extensions"
Option "Composite" "Enable"

now go to
Control Center -> Desktop -> Window behavior -> "Translucency" tab
activate transparency (ignore warning): check "Use translucency/shadows box" and next configure settings

No idea about Gnome

obviously transparency 3D acceleration

Score 12-18-2006 12:11 PM


Did what you said, but my windows are not transparent now. The background is still colored. I added that line to xorg.conf and restarted X, but still no effect.

What could I've done wrong?

broch 12-18-2006 02:17 PM

first time after you activate transparency, you will have to log out/log in before you will see transparency.

Score 12-18-2006 02:45 PM

Yes, I noticed that. But it wasn't exactly my cup of tea.

First of all, when I open a sub-menu above another menu, I can see the other menu through the current menu. Makes it confusing and messy.

And then, I could not get my active windows to be transparent, only the inactive ones.

Maybe I just lack a bit of knowledge about this feature, or it just isn't possible to do what I thought of.

broch 12-18-2006 03:27 PM

that is why you have sliders to set transparency at th e level you wish

In the window decoration section there are options for menu transparency.

In general I dound that all transparency/and-or+xgl/Beryl stuff is fine for one day, later it simply gets in your way.

All times are GMT -5. The time now is 12:15 AM.