Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 10-25-2007, 01:09 PM   #1
LQ Newbie
Registered: Jul 2006
Posts: 28

Rep: Reputation: 15
SuSE 10.3 Need WiFi how 2

I have installed 10.3.
Works great, all the 1 Click software stuff.
DVD plays, MP3 & 4, 3d on Nvidia FX 5200, etc.
Except wireless.

MN-730 54G wifi PCI card [broadcom 43XX] detected.
configured but Wont work.

I have to original windows drivers.
Ndiswrapper doesnt work, or at least I cant get it to work.

Rebooted, formated and reinstalled 10.3 to get rid of any mess from trying.

Can someone post a step by step on how to get this going at 54G?

Old 10-25-2007, 09:37 PM   #2
LQ Newbie
Registered: Sep 2006
Posts: 1

Rep: Reputation: 0
same problem

I have suse10.3 and am unable to connect to internet. I did an lspci on the terminal and it shows an intel ethernet controller 82801CAM(ich3)pro/100ve.
I used the yast to configure and it still does not work. I need a step by step.
Old 10-25-2007, 11:12 PM   #3
Registered: May 2007
Location: FL
Posts: 58

Rep: Reputation: 17
Try these links they will help.
Old 10-26-2007, 08:03 AM   #4
LQ Newbie
Registered: Jul 2006
Posts: 28

Original Poster
Rep: Reputation: 15
Thumbs up Mocrosoft MN-730 PCI Working!!!!

I used several other folks trial and error reports to get this working.

1.Removed bcm43xx driver
Su mode rmmod bcm43xx

2.Blacklist bcm433xx driver
[has to be done in SU ## gedit /etc/modprobe.d/blacklist
add "blacklist bcm43xx" to the bottom of the list. then save.
3 Edited SU mode gedit /etc/sysconfig/hardware/hwcfg-bus-pci-xxx change bcm43xx to your card, if it is listed. If not leave.
4 Editied /etc/udev/rules.d/70-persistent-net.rules
locate the following lines:

# PCI device 0x14e4:0x4318 (bcm43xx)
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:14:a5:27:2b:2f", NAME="eth1"

and change it to

# PCI device 0x14e4:0x4318 (ndiswrapper)
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:14:a5:27:2b:2f", NAME="wlan0"

Save file & exit.

Configure your card. Modual name is ndiswrapper.
I have my card set for external mode, you may need to use another setting?
Turn net manager on.

If you still have no wifi enter SU mode and type modprobe ndiswrapper

That is how I got on line....

For now anyway
Old 10-26-2007, 09:38 PM   #5
Registered: Oct 2006
Location: Scottsdale, Arizona
Distribution: openSUSE 10.2
Posts: 197

Rep: Reputation: 30
I have Broadcom bcm4311 (Dell 1390 WLAN) and I followed this to the letter:

It worked.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No WiFi with Suse 9.3 mikeCanada SUSE / openSUSE 2 10-22-2005 01:16 PM
SuSE 9.3 wifi on boot metamaverick Linux - Wireless Networking 4 08-01-2005 06:00 PM
WiFi Suse 9.0 or 9.2 sergiocampa Linux - Wireless Networking 2 02-11-2005 11:08 AM
Wifi on SuSE 9.1 BGM Linux - Laptop and Netbook 2 08-14-2004 10:13 AM
Help with WiFi and SuSE.... Powerlifter Linux - Wireless Networking 7 02-20-2004 11:45 PM

All times are GMT -5. The time now is 04:16 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration