-   SUSE / openSUSE (
-   -   Sound players don't work (

stevesk 07-31-2005 07:29 PM

Sound players don't work
Hello guys! I've installed SuSe Linux 9.3 with Gnome today. First, here is my sound config:

Intel 82801EB - AC97 Audio Controller

It is the on board sound of the Intel 865GBF motherboard. My CD player works. Also works the system sound when I use yast or alsaconf to configure my sound and test it, the sound plays perfectly. Gnome default sounds also play with no problem. But when I try to play ANY mp3 file as root or as any other user, I receive errors in all of the players. I've set the permission of the mp3 file to 777 so I suppose it is not a permission problem. I've started all the known players from a console to see what error message each one gives me:



"QObject::connect: Cannot connect QSignal::signal(const QVariant&) to (null)::(null)
Guessed format: mpeg
Could not load mpeg-decoder"



"The following files could not be played. Please check that:
1. they are accessible.
2. you have enabled the media plugins required."

(this one wasn't from a console, it has opened a dialog box)



"Gtk-WARNING **: invalid class type `(unknown)' in cast to `GtkObject'

Gtk-CRITICAL **: file gtkobject.c: line 1034 (gtk_object_set_data): assertion `GTK_IS_OBJECT (object)' failed."



dialog box:

"The stram 'home/gaio/abcd.mp3' use an unsupported codec:

Audio Coded: MPEG 1 Layer 3 CBR (0x0)

Start playback anyway?"

I click yes but it doesn't play the file.


I also tryed another file, and another, with no sucess. Could anyone help me please???

Thanks for your attention.

fenderman11111 08-01-2005 12:12 AM

you don't have the mp3 decoders installed.

I don't run suse so i'm not exactly sure how you would go about getting the proper libs, but perhaps this will be of help to you?

hope that helps.


stevesk 08-01-2005 05:35 PM

Thanks so much man! It solved my problem. I found on the forum you passed me a link for this site:

So I followed the instructions and bingo! :)

Thanks again!

All times are GMT -5. The time now is 05:28 AM.