LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 11-11-2005, 03:21 PM   #1
LQ Newbie
Registered: May 2003
Posts: 16

Rep: Reputation: 0
Non-existent network shares won't disappear

Using openSUSE 10.0 w/ gnome.

Everything is running great (except for a GRUB problem, but I'm working on that... may see another post on that soon. ) except for one annoying thing.

I got to playing around as soon as I was done installing and tried to connect to a hidden c$ share on the other computer in the place. Didn't work the first time, so I tried again.

Now I have, on my desktop, 2 network shares. None of them work. But I can't get rid of them. If I try and trash them I get "You cannot move the volume "cshare" to the trash. If you want to unmount the volume, please use 'Unmount Volume' in the popup menu of the volume."

If I right-click, the 'Unmount Volume' option isn't there. So I figured I'd try moving it to a folder out of the way until I figured it out. But then when I tried that I got that the files didn't exist. They're not visible in my folder, they don't appear when I do a locate on them. But they're still sitting on my desktop annoying the hell out of me.
Old 11-11-2005, 04:13 PM   #2
LQ Newbie
Registered: May 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Okay... so I have been mucking around. I see the two shares inside ~/.nautilus/metafiles/x-nautilus-desktop:%2F%2F%2F.xml

It's just an XML file with all of my icons on it. I deleted the entries for the two shares. Logged out. Logged in and they were still there. I tried the same thing but logged in as root. Same thing.

If I solve it... I'll post the solution. If anyone has any suggestions, I'm all eyes.
Old 11-11-2005, 04:40 PM   #3
LQ Newbie
Registered: May 2003
Posts: 16

Original Poster
Rep: Reputation: 0
Fixed it.

Inside ~/.gconf/desktop/gnome/connected_servers there were numbered ('1','2',etc) folders. In each folder was an xml file that held the connection info. I simply deleted those folders in there and logged out/back in and all was right in the world.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing network shares brianread SUSE / openSUSE 8 05-25-2005 02:30 AM
mounted samba shares disappear jsmarshall85 SUSE / openSUSE 4 02-02-2005 03:49 PM
Searching shares on a network Brian1 Linux - Networking 2 10-24-2004 03:23 PM
Samba shares on Win XP disappear regorbro Linux - Software 4 02-23-2004 07:45 AM
Browsing network shares Phaethar Mandriva 4 12-18-2003 01:35 AM

All times are GMT -5. The time now is 01:20 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration