Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 07-16-2009, 11:32 AM   #1
Registered: Sep 2005
Distribution: fedora core 9
Posts: 324

Rep: Reputation: 33
No root device found, exiting to /bin/sh sles9 (after mkinitrd)


I was trying to add a driver/modules(qla2xxx). I used mkinitrd.
After that server wont boot.

1-It prints "No root device found, exiting to /bin/sh" error message.
2-I have root FS on vg(lvm) setup.
3-I have booted server with Opensuse-11 live cd.

Now where should I look to fix this issue.

Old 07-17-2009, 05:25 AM   #2
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 658Reputation: 658Reputation: 658Reputation: 658Reputation: 658Reputation: 658
Did you add qla2xxx in a line in /etc/sysconfig/kernel and then run mkinitrd?


Or alternately run the YaST2 -> System -> /etc/sysconfig Editor, and add to the System -> Kernel -> Initrd Modules dialog?

See if the lvm volume is still OK. I doubt the problem is in the lvm volume itself.

Do you have a separate /boot partition that contains the initrd file, and do you have the old one in a backup.
If /boot/grub is on a separate partition, look at your menu.lst file. Do you have the vg device nodes? If not, look at the "vgmknodes" program to create them.

If the lvm volume is OK, and you can mount them manually, my guess is that adding the qla2xxx driver, causes a new disk device to be added when you boot. The line in /boot/grub/menu.lst for the root device is now wrong. E.G. was "root (hd0,1)" but now should be "(hd1,1)".
If you can create the LVM nodes, mount the volumes manually (under /mnt/) and then "chroot" to the old system, you can start running your system, fix menu.lst and maybe the /etc/fstab file, run grub-install and reboot.

Another option is to restore your old initrd file from a backup. ( Or if you have an older kernel/initrd entry in the grub menu, select it when you boot. )

Another option is to re-install grub from the grub shell after editing any changes needed in menu.lst and /etc/fstab.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 10 install-no root user found/offered; and no Device-Modem search KFL Linux - Newbie 3 12-09-2008 11:07 PM
No root device found on boot up treydock Linux - Software 6 03-18-2007 02:34 AM
/bin/bash: root: command not found pridefc Red Hat 5 12-12-2006 08:09 PM
No root device found; exiting to /bin/sh Indian_bee Linux - Software 6 07-09-2004 06:20 AM
mkinitrd: Can't create temp dir, exiting...?? tfricke Linux - General 4 11-01-2003 06:53 PM

All times are GMT -5. The time now is 10:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration