Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 05-15-2005, 07:45 AM   #1
LQ Newbie
Registered: May 2005
Distribution: SuSe 9.3 Pro
Posts: 4

Rep: Reputation: 0
No internet connection, ethernet card id ok

Hello Folks,

I've just installed Suse 9.3 without a glitch, until I ran into problems with the network.

The network card is recognized, it gets its ip from my 3com officeconnect ADSL router/modem but I can't get to the internet. Booting with XP will get me to it.

If I run IFCONFIG I get my ip on eth0, RX packets OK, and errors on TX packets.

If I ping my router I get host unreachable.

If I try to open any website by their ip, I get connection refused on Mozilla.

With route -n I get:

Destination Gateway Genmask Flags Metric Ref Use Iface U 0 0 0 eth0 U 0 0 0 eth0 U 0 0 0 lo UG 0 0 0 eth0

I've already tried with DHCP, and then I've tried static IP.

I've read quite a few posts, and I've disabled ipv6 and nscd

Firewall on XP, router and Suse are disabled

My private network runs on
My gateway is the router
My DNS are (these are already my NameServers)

Question 1: In Yast -> Network Services -> DNS and Host name ; what do I enter in Domain search? I have the DNS IPs but no name

Question 2: What's this showing up on route -n?
My network set-up clearly shows it's on (out of the router's DHCP range)

Any help, tips, suggestions are most welcome,

Old 05-18-2005, 11:58 AM   #2
LQ Newbie
Registered: Mar 2005
Distribution: Debian GNU/Linux
Posts: 9

Rep: Reputation: 0
Answer 1:
Put nothing in search name, and use any host name that you like ;-)

In general:
How is configured your router? Is it configured to use DHCP?

Try to use in linux DHCP.
Ev. you can install "pump" and try to
pump -i eth0
. This command use DHCP to set relevant internet settings.
Old 05-28-2005, 05:53 PM   #3
LQ Newbie
Registered: May 2005
Distribution: SuSe 9.3 Pro
Posts: 4

Original Poster
Rep: Reputation: 0
must be a wrong NIC driver

With ifconfig I get the following:

eth0 Link encap:Ethernet HWaddr 00:0B:6A:A4:4C:2D
inet addr: Bcast: Mask:
RX packets:351 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:63 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21435 (20.9 Kb) TX bytes: 0 (0.0 b)
Interrupt:217 Base address:0xd400

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:207 errors:0 dropped:0 overruns:0 frame:0
TX packets:207 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14935 (14.5 Kb) TX bytes: 14935 (14.5 Kb)

The card is not faulty as I use the same computer in windows, all firewalls are off, router has DHCP.

I get the feeling that either the NIC driver is not working, or I should configure it manually with the interrupt and base address. Can I use the values I have in windows?

The motherboard is ASRock K8upgrade-1689 with onboard LAN.

Maybe I should install a new ethernet card, any brand that works?

I've also tried deleting and reinstalling the network device, no changes.

I get home only on some weekends, by this rate I'll have internet by January...

Old 06-03-2005, 04:27 PM   #4
LQ Newbie
Registered: May 2005
Distribution: SuSe 9.3 Pro
Posts: 4

Original Poster
Rep: Reputation: 0
I'm writing this from Suse!

Slid in a new 3com network card, bought a new ethernet cable. Didn't work.

I almost gave up, faced returning to windows. Tried with old ethernet crossed cable, voila!

Now I'll move on to Samba forums...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting an internet connection... Ethernet Card problem.. Tony Empire Linux - Hardware 3 11-30-2004 06:57 PM
Routing between a wired ethernet (internet connection) and a wireless card (home net) ner0 Linux - Wireless Networking 8 11-29-2004 02:12 AM
Help: Configuring Ethernet Internet Connection anonymous555 Linux - Networking 8 07-24-2004 03:43 PM
Internet-connection on Mandrake 9.1 on Ethernet pprms Linux - Networking 1 12-21-2003 11:12 PM
ethernet and internet connection zokter Slackware 2 10-25-2003 10:19 AM

All times are GMT -5. The time now is 08:11 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration