View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 05-26-2005, 12:34 PM   #1
Stack Overflow
LQ Newbie
Registered: Jan 2004
Location: USA
Distribution: SuSE 9.3 Pro
Posts: 13

Rep: Reputation: 0
KDE Session missing [9.3 Upgrade]


I am experiencing an odd issue. I upgraded my SuSE 9.1 Pro installation to 9.3 yesterday. All went well. When I booted the machine for the first time, it said that the 'kde' session was no longer available. But during the upgrade, I installed KDE and Gnome.

If I start another window manager and enter 'startkde' in a terminal, KDE actually starts. But looks a bit funny since the other Window Manager is the default. I can't run 'startkde' from outside a Window Manager, as it says it can't open my display. I had even set my DISPLAY to ":0" and ":0.0".

Is there an easy way I can add KDE and Gnome back to my Session list when I boot to SuSE? I successfully get the login screen where I can choose my window manager—and enter my username and password—but KDE nor Gnome show up in the list.


Stack Overflow
Old 05-30-2005, 04:33 PM   #2
Registered: Jul 2003
Location: indiana,usa
Distribution: SuSE 11,Slack,Mint
Posts: 425

Rep: Reputation: 30
for GNOME:
in consol as root:
rm -f /opt/kde3/share/apps/kdm/sessions/gnome.desktop
cp /opt/gnome/share/xsessions/gnome.destop /opt/kde/share/apps/kdm/sessions/

for KDE:
try to reinstall kdebase3-SuSE from your install disk.i'm still looking into it,but it seems as if the YOU update is at fault again


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Control Center missing all entries after upgrade ChemBot Linux - Software 3 08-06-2005 08:28 AM
KDE styles missing after upgrade mdarby Slackware 13 04-26-2005 01:09 AM
gnome session option missing after upgrading to kde 3.4 jerry424 SUSE / openSUSE 4 03-05-2005 03:41 PM
KDE 3.1 upgrade to 3.3.1 - missing icons? decavolt SUSE / openSUSE 4 11-03-2004 01:51 PM
KDE 3.2.1 upgrade: LIBSMBCLIENT IS MISSING windus Linux - Newbie 1 04-11-2004 12:25 AM

All times are GMT -5. The time now is 01:09 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration