-   SUSE / openSUSE (
-   -   gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' (

TdlSnare 11-29-2004 12:36 AM

gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41'
i tried to install the gcc RPM file, however i got an error message that says
'failed dependencies: glibc-devel is needed by gcc-3.3.3-41'
what is this and where can get it?

monroetech 11-29-2004 02:18 AM

I don't mean to kick a dead horse in the mouth... but google it... one of the first sites to show up will prolly be

glibc-devel contains the files needed to make gcc run... I'm being very non technical here.....

BTW - What version of suse are you using? 9.x? and is it pro or personal?

I can't believe that your suse cd's don't have this software for you already..... but then again, I've never used Personal.......

Another place you can find these will it'self... Go to downloads and search for the package....

Hope you figure it out..... your having one hell of a time trying to get things installed....

jonespg 11-29-2004 02:01 PM

It sounds like you're installing this because it's a dependency for something else? Anyhow, One solution to those types of situations is to use apt or apt-get. There a lot of packages available, and it will resolve dependency issues automatically for you.

It does take a while to install and configure, but it's worth it.

abisko00 11-29-2004 02:13 PM

My tip is that you have SuSE 9.1 Personal and you downloaded the gcc rpm from the web. So you get the dependency issue. Have a look where you got gcc from, there you should find glibc as well as all the other stuff that you are missing (e.g. make).

To solve the dependencies, you may use apt, but on SuSE yast does the job also. Just add a FTP server to your yast sources ('Change Source of Installation') and use the normal 'Install and Remove Software' module of yast. All dependencies will be solved automatically.

All times are GMT -5. The time now is 06:06 PM.