Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 01-20-2013, 11:03 AM   #1
Registered: Jun 2011
Posts: 69

Rep: Reputation: 12
Epson EPL-5900L printer not working

I'm trying to get Epson EPL-5900L to work on openSuse 12.2 (64bit, kernel 3.4.11-2.16-desktop). I once got it to work on Mandriva but I don't remember how.

I followed the steps explained here and installed epsonepl driver from Sourceforge and now the printer is recognized in YaST, but I can't get a working PPD file for it.

I tried to manually assign each of the three PPD files provided in the epsonepl package but they all seem to be invalid. YaST complains about too long lines in the file etc.

Ghostscript version information (gs -v):

GPL Ghostscript 9.05 (2012-02-08)
Copyright (C) 2010 Artifex Software, Inc. All rights reserved.
CUPS error log:

E [20/Jan/2013:09:59:06 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
E [20/Jan/2013:10:14:15 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
E [20/Jan/2013:16:16:01 +0200] Browsing=1
E [20/Jan/2013:16:16:01 +0200] BrowseLocalProtocols=0
E [20/Jan/2013:16:16:01 +0200] BrowseRemoteProtocols=1
E [20/Jan/2013:16:16:01 +0200] BROWSE_CUPS=1
E [20/Jan/2013:16:16:01 +0200] Unable to bind socket for address [v1.::1]:631 - Address already in use.
E [20/Jan/2013:16:39:20 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:49:56 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
E [20/Jan/2013:16:49:56 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:51:09 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
E [20/Jan/2013:16:51:09 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:53:37 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
W [20/Jan/2013:16:53:37 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/epl5900l.ppd!
E [20/Jan/2013:16:53:37 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:55:27 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
W [20/Jan/2013:16:55:27 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/epl5900l.ppd!
E [20/Jan/2013:16:55:27 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:58:52 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
W [20/Jan/2013:16:58:52 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/epl5900l.ppd!
E [20/Jan/2013:16:58:52 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!

I also installed manufacturer-PPDs package which contains a file for EPL-5900 but as I expected it doesn't work (see below).

Information about the printer on Linux:
Old 02-02-2013, 06:34 PM   #2
John VV
LQ Muse
Registered: Aug 2005
Posts: 15,659

Rep: Reputation: Disabled
I take it you have tried the cups web interface ?

OS gui's have never been good for me
but the cups localhost page has always done what i need
Old 02-08-2013, 04:29 PM   #3
Registered: Jun 2011
Posts: 69

Original Poster
Rep: Reputation: 12
Same problem. The printer is recognized but this model is not listed in the model list. Only EPL-5900 is but it does not work. Printing doesn't even start.

When I try to manually assign a PPD file (any of the three) provided with the epsonepl driver package it gives an error:

Set Printer Options EPSON_EPL-5900L Error

Unable to open PPD file:

    Line longer than the maximum allowed (255 characters)



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
EPSON Laser Printer EPL-6200L/ SUSE- is there a way to install it riba43 SUSE / openSUSE 4 11-17-2009 04:50 AM
How to install Epson EPL-6200L laser printer in SuSE 10.0 riba43 SUSE / openSUSE 3 09-21-2007 07:31 AM
Slackware 12 and problems with Epson EPL-5900L printer scorpion77 Slackware 3 09-12-2007 08:20 AM
Installation of Epson EPL-5900L on Slackware 9.0 scorpion77 Linux - Hardware 1 10-25-2004 02:31 PM
EPSON EPL-6200L and Mandrake 10 esteeven Linux - Hardware 5 09-15-2004 12:42 PM

All times are GMT -5. The time now is 02:55 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration