View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 10-20-2008, 12:21 AM   #1
Registered: Apr 2004
Location: Baltimore, MD
Posts: 681

Rep: Reputation: Disabled
[OpenSUSE 10.3] SAMBA Active Directory authentication

Has anyone ever implemented this on OpenSUSE 10.3 successfully? I have various directories (eg. /srv/www/vhost/hr, /srv/www/vhost/acct etc.) that I want to give access to people based on where they are located in the Active Directory tree.

Thanks for any guide.
Old 10-24-2008, 01:42 AM   #2
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 658Reputation: 658Reputation: 658Reputation: 658Reputation: 658Reputation: 658
If the system already uses AD for authentication, then you should be able to use normal access controls such as acl's.

SuSE has a wizard for what kind of authentication to use. "kdesu yast2 users" -> Authentication Tab. Also read the latest "Using Samba" book. It has a section on Open Directory. I'm not a Windows sys admin so I can't speak from experience, but another user on this board was able to use AD authentication after I pointed out the wizard. There are other samba books "Samba 3 by Example" and "Samba 3 HOWTO & Reference Guide" that are available by installing SuSE's samba-doc package. LDAP integration is covered. If you don't currently use AD authentication for this SuSE host, then you may have a lot of work ahead, but the wizard may do most of the configuration for you. You may still need to configure the LDAP server to populate it with your Linux users.

Last edited by jschiwal; 10-24-2008 at 03:15 AM. Reason: rant at end removed
Old 01-29-2009, 11:45 AM   #3
LQ Newbie
Registered: Jan 2009
Posts: 5

Rep: Reputation: 0
AD authentication using the wizard has been broken in Opensuse from 10.3 onwards. It worked perfectly in 10.2... don't really know why no-one has fixed it yet (don't ask me, i'm no linux coder).


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another Samba authentication problem with Windows 2003 Active Directory StAlphonzo Linux - Server 0 05-23-2008 01:36 PM
Getting pam working with samba (with active directory authentication) kcorupe Linux - Server 3 05-02-2008 11:04 AM
Samba with Active Directory authentication Ziggie Linux - Enterprise 5 02-02-2006 08:43 AM
Samba Active Directory Authentication zenix Linux - Networking 1 09-17-2005 05:26 AM
samba-authentication with Active Directory sanjeevsagoo Linux - Networking 2 05-07-2004 04:09 AM

All times are GMT -5. The time now is 11:40 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration