LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-07-2007, 03:09 PM   #1
rrrssssss
Member
 
Registered: Mar 2005
Posts: 266

Rep: Reputation: 32
Yast - Disable Auto-Update Of Package Headers When Launched


Hello forum,

I am running openSUSE 10.2 and everything is working the way it is supposed to but that is exactly my problem.

Whenever I use Yast2 (GUI) to open up Software Management, 8 times out of 10 Yast will automatically start downloading updated package headers from all of the repositories I have configured. It appears the repository maintainers update the headers several times a day.

Normally this would be a good thing, but I have a dial-up connection with speeds never over 28 kBps average and I have to wait sometimes hours for the header download to complete. Many times I want to simply browse the packages to see what is available, not wanting to wait for the header download to complete each time.

High speed Internet is not available where I live and I can't afford satellite Internet.

Is there a way to configure Yast to simply use the cache where these package headers reside, thus illiminating the lengthy download time? I would like to be able to manually check for the header updates when I feel like it might need them.

I am using Zenworks Management instead of libzypp.


Help would be much appreciated,
Roy

Last edited by rrrssssss; 08-07-2007 at 03:30 PM.
 
Old 08-08-2007, 07:05 PM   #2
jdmcdaniel3
Member
 
Registered: Jan 2006
Location: Austin
Distribution: openSUSE 11.2
Posts: 167

Rep: Reputation: 31
Exclamation YaST/Software/Installation Source/Refresh On-Off

I think that if you go into YaST/Software/Installation Source and Turn Refresh off for any source, it no longer downloads information, but uses what it received when the source was created. You can always go in later, do an edit of each one you want to refresh, but don't change anything and it should refresh to the new point in time.

Thank You,
 
Old 08-09-2007, 07:30 AM   #3
rrrssssss
Member
 
Registered: Mar 2005
Posts: 266

Original Poster
Rep: Reputation: 32
Thank You

Thank you jdmcdaniel3,

That fixed my problem perfectly. But it only worked until I rebooted. So I disabled the autoyast service, so it would not force updates with each bootup.

Thank you,
Roy

Last edited by rrrssssss; 08-09-2007 at 03:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: New Open-source Time and Attendance Web-based Package Launched LXer Syndicated Linux News 2 07-03-2011 08:30 AM
How can I permanently disable an individual Yast Online Update patch? PerfectStranger Suse/Novell 5 09-08-2006 03:27 PM
How YOU (Yast Online Update) verifies package integrity before installation? tux_addicted Suse/Novell 2 09-16-2005 04:25 AM
something is wrong when apt-get update is launched lsj Linux - Newbie 2 05-21-2004 01:14 AM
how to disable auto update at startup? mane.x Fedora 1 02-09-2004 07:03 AM


All times are GMT -5. The time now is 12:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration