LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Yast - Disable Auto-Update Of Package Headers When Launched (http://www.linuxquestions.org/questions/suse-novell-60/yast-disable-auto-update-of-package-headers-when-launched-575426/)

rrrssssss 08-07-2007 04:09 PM

Yast - Disable Auto-Update Of Package Headers When Launched
 
Hello forum,

I am running openSUSE 10.2 and everything is working the way it is supposed to but that is exactly my problem.

Whenever I use Yast2 (GUI) to open up Software Management, 8 times out of 10 Yast will automatically start downloading updated package headers from all of the repositories I have configured. It appears the repository maintainers update the headers several times a day.

Normally this would be a good thing, but I have a dial-up connection with speeds never over 28 kBps average and I have to wait sometimes hours for the header download to complete. Many times I want to simply browse the packages to see what is available, not wanting to wait for the header download to complete each time.

High speed Internet is not available where I live and I can't afford satellite Internet.

Is there a way to configure Yast to simply use the cache where these package headers reside, thus illiminating the lengthy download time? I would like to be able to manually check for the header updates when I feel like it might need them.

I am using Zenworks Management instead of libzypp.


Help would be much appreciated,
Roy

jdmcdaniel3 08-08-2007 08:05 PM

YaST/Software/Installation Source/Refresh On-Off
 
I think that if you go into YaST/Software/Installation Source and Turn Refresh off for any source, it no longer downloads information, but uses what it received when the source was created. You can always go in later, do an edit of each one you want to refresh, but don't change anything and it should refresh to the new point in time.

Thank You,

rrrssssss 08-09-2007 08:30 AM

Thank You
 
Thank you jdmcdaniel3,

That fixed my problem perfectly. But it only worked until I rebooted. So I disabled the autoyast service, so it would not force updates with each bootup.

Thank you,
Roy


All times are GMT -5. The time now is 03:49 AM.