LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-22-2004, 04:07 PM   #1
Judah
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 8.2
Posts: 14

Rep: Reputation: 0
Yahoo DSL with SuSE 8.2


Greetings!
This is my first post here!

I'm having problems getting an established
connection. The account is already setup.

I learned about the speedstream 5100 from this thread..

linuxquestions.org/questions/showthread.php?s=&threadid=211327&highlight=yahoo+dsl

I do have the newer modem that is supposed to have the PPP client in the modem.
I tried setting it up through the modem.

It looks like my eth0 is working, when I boot up, it grabs an IP
through DCHP.

A firewall *is* started upon bootup, I'm assuming it's "on", but don't
know for sure.

from the modem setup screen, I had it check the connection.
These are the items that failed..

ATM
PPPOE

When I clicked on PPPoE it said this...

PPPoE connection to ethernet FAIL
PPP connection to PPPoE FAIL
PPPoE server connectivity FAIL
PPPoE server session FAIL

Seeing that, I thought maybe I had to install Roaring Penguin.
So I did that. I then tried setting the connection through R.P.
and then tried adsl-start .. it timesout.

However, I thought PPPoE was in the kernel and you didn't
need roaring penguin?

Do i need to setup the information is YAST under DSL?
I tried that as well. It sets up dsl0, but I don't know how
to activate that.

Also, will Kinternet interfere with this? ppp0 ?
I have it set for a dial-up account?

Any help would be *greatly* appreciated.

Judah

p.s. - I don't have a router or a network. It's just a workstation
hooked through eth0 to the modem...

Last edited by Judah; 10-22-2004 at 05:59 PM.
 
Old 10-22-2004, 07:27 PM   #2
SiegeX
Member
 
Registered: Jul 2004
Location: Silicon Valley, CA
Distribution: Slackware
Posts: 171

Rep: Reputation: 38
It looks like the modem is failing talking to the ISP not your box.

Make sure that you dont have any blinking red lights. Make sure that you didnt accidentally filter the data line instead of the phone line. And also if you just got this service make sure that your connection is actually enabled by your ISP. Just because you get the equipment in the mail doesnt mean you can then use it yet. I would give your ISP a call if you dont get a solid green DSL light.
 
Old 10-22-2004, 08:14 PM   #3
Judah
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 8.2
Posts: 14

Original Poster
Rep: Reputation: 0
First off,
Thanks Siegex for taking the time to look at this thread..

The lights are green. Except for the internet light sometimes.
The service has been turned on and I setup the account over
the phone. I used dialup to login into the sbcyahoo site and
it worked. So, the account is up and running..

Yes, the cables are correctly hooked up through the filters as well..
 
Old 10-22-2004, 09:15 PM   #4
Judah
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 8.2
Posts: 14

Original Poster
Rep: Reputation: 0
Hmm..

Still trying.

It seems it might be something with PADI and PADO.

When I tried issuing "pppoe" under Roaring Penguin
it said timeout waiting for PADO.

When I tried setting up the connection under YAST
and using Kinternet to connect, looking at the log, it
seems it is doing the same thing..
"Timeout waiting for PADO - Check your configuration".

Could this be the firewall interfering??

When I set up the firewall, it says to use ppp0 instead
of eth0 if using a dsl modem with pppoe..
 
Old 10-22-2004, 11:19 PM   #5
rsheridan6
Member
 
Registered: Mar 2003
Location: Kansas City
Distribution: Debian unstable
Posts: 57

Rep: Reputation: 21
I don't know how much I can help you, but I can tell you that with my identical (except I'm using Debian, not Suse) setup, I was using eth0, not ppp0 (which was necessary with older modems that didn't do ppp0 for you). Now I'm using a linksys wireless router which takes care of all of that.

Anyway, you don't need roaring penguin or any other pppoe software on your machine. The 5100 takes care of that for you. If I'm correct in understanding that you're able to connect to the browser based interface in the DSL modem, and it's saying things like "PPPoe connection fail", the problem is somewhere between your DSL modem and whatever the hell that thing connects to on their end (if the problem were on your side, you wouldn't be able to connect to the modem).

There are two possibilities:
1) Something is wrong on their end which a mere mortal like me wouldn't understand. If that's the case, you're sort of screwed because SBC tech support won't help you when you tell them you're running linux.

2) Your account is not really setup - they just told you some misleading bullshit to get you off the phone (that's what tech support does). As I recall, they wouldn't set up my account over the phone, they insisted that you had to use the Windows only cd that comes with the modem, so I'm kind of doubtful that you really are set up. Despite what tech support told me, there is a way to set up your account without the windows cd: http://www.dslreports.com/faq/8346

Good luck.
 
Old 10-23-2004, 01:21 AM   #6
Judah
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 8.2
Posts: 14

Original Poster
Rep: Reputation: 0
I'm pretty sure the account is setup.
I can goto their website through dialup, log in,
check mail, setup sub accounts, etc..
 
Old 10-23-2004, 01:58 AM   #7
SiegeX
Member
 
Registered: Jul 2004
Location: Silicon Valley, CA
Distribution: Slackware
Posts: 171

Rep: Reputation: 38
As rsheridan6 said, you shouldnt need roaring penguin/adsl-setup with the 5100 model. As long as you configure it to do 'ppp on the modem' then all you have to worry about are ethernet interfaces ie. eth0/eth1.

Here is the 'connection information' on the web interface for my modem

Code:
DSL UP 
Connection UP 
User ID sean.X@sbcglobal.net 
Connected at 1536 Kbps (downstream)
256 Kbps (upstream) 
IP Address 67.125.84.X
IP Gateway 67.125.87.X
DNS Servers 206.13.28.12  dns1.snfcca.sbcglobal.net
206.13.29.12  dns1.lsanca.sbcglobal.net 
Mode PPP on the modem (Public IP for LAN device) 
Timeout Never 
Modem Information 
Modem Name SpeedStream 
Model 5100 
Serial Number 2000B23686XXX
Software Version 1.0.0.36 
MAC Address 00:0B:23:68:XX:XX
First Use Date 2004/06/19 16:22:58 GMT 
Local Network 
Modem IP Address 192.168.0.1 
Ethernet Status Connected
Ive highlighted the important line in bold above. Note that there are really two options in that line, one is ppp on the modem and the other is that its passing a public IP to the LAN interface which basically puts the modem in bridged mode. Having a public IP inst really necessary but it makes it much easier to configure iptables rules.

Also as mentioned tech support will just tell you to go F yourself if you mention the word linux. So what I would do is see if you can get a windows box temporarly and see if that works. If not then you can run through all the BS with tech support until they have no choice but to send your ticket to one of the field techs to see whats really going on.

By the way, if you go to the check information section on the modem and you dont get all PASS's then that is something your ISP needs to resolve for you. If they dont just threaten them to go elsewhere and if they threaten you with cancelation fees tell them they will find themselves in small claims court for breech of contract since they didnt provide the service you are paying for.

Last edited by SiegeX; 10-23-2004 at 02:01 AM.
 
Old 10-23-2004, 04:14 PM   #8
Judah
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 8.2
Posts: 14

Original Poster
Rep: Reputation: 0
Well,
So you should be able to login through the interface
on the modem, right?

I tried my first call to tech support, tier one.
Basically the guy told me to reset the modem on the
bottom. And that he can't help me because I'm using linux.
Any suggestions on how to get to tier two to talk to
a real tech?

I tried explaining to him that it couldn't establish a pppoe
connection on their end, but he just kept ignoring me.
I told him my eth0 was working to the modem, etc.

If I get to a higher tier, do you think the techs would be willing
to help me out?

If I set it up for PUBLIC IP FOR LAN SERVICE, does that
mean I have to have the pppoe client software set up,
like R.P. ?

I have 30 days to try the service without any obligation.
So, I thought I'd give it a shot..


Last edited by Judah; 10-23-2004 at 04:18 PM.
 
Old 10-23-2004, 05:36 PM   #9
SiegeX
Member
 
Registered: Jul 2004
Location: Silicon Valley, CA
Distribution: Slackware
Posts: 171

Rep: Reputation: 38
Your first mistake was telling them you are using linux, rsheridan6 clearly warned you above NOT to do this. For your sake I hope they didnt note that you are using linux on your account.

I would call them up again, and this time say you are on windows. If they ask you to do some windows specific task, just go along with it like you are doing it. Keep relating the fact that the modem is faling to talk to THEM not you (assuming the Ethernet gives you a PASS).

And no, you DO NOT need any RP software at all to do both ppp on the modem and WAN or LAN ip on the interface.

Last edited by SiegeX; 10-23-2004 at 05:38 PM.
 
Old 10-23-2004, 06:32 PM   #10
Judah
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 8.2
Posts: 14

Original Poster
Rep: Reputation: 0
Yeah, the ethernet light is green.

I was gonna go along with the windows thing,
but then decided against it because I thought they
would be asking me like what's on the screen, etc.

I guess I'll try again.

On a positive note, I found another forum where
an ACTUAL tier 2 tech from Yahoo Dsl was helping
people out, so I sent an email to him.
Hopefully, he will respond.

Thanks again for the help..

I'll feel really stupid If I can't get this to work!
 
Old 10-23-2004, 07:43 PM   #11
Judah
LQ Newbie
 
Registered: Oct 2004
Distribution: SuSE 8.2
Posts: 14

Original Poster
Rep: Reputation: 0
Good news!

I'M NOT INSANE !

Called tech support and they ran an ATM ping on my line
and it failed, even though my DSL light is green!
So it's a problem with a line somewhere.
So THEY are working on the problem.

You were right SiegeX, they did note in my account
that I was using Linux!! But I told them, no, I am using
windows 98.

I thought the networking was hosed in 98, so I moved to
linux. But got the networking up and running under 98.

This is my moms computer and I'm setting this all up for
her. Good to know that it will probably work under linux
as well, once the line is fixed..

Once again, thank you all for your suggestions and patience!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE Doesn't Connect to Internet with SBC Yahoo! DSL Ninurta Suse/Novell 14 10-08-2005 12:24 AM
set up of Yahoo DSL zadox Linux - Newbie 5 05-08-2005 12:44 AM
Cant connect to Yahoo DSL with linux 3NaN0 Linux - Networking 9 10-24-2004 05:05 AM
Yahoo DSL? linux? tricky_linux Linux - Software 9 08-25-2004 04:18 PM
sbc yahoo dsl on redhat 8 joghee Linux - General 6 10-31-2003 12:49 AM


All times are GMT -5. The time now is 12:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration