LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 04-06-2006, 03:19 PM   #1
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
XP - My Documents Folder


I put this folder on a FAT32 drive so I could access it from Windows and Linux. I can read files from that directory and the rest of the partition. Interestingly I cannot write to that directory (even as root) but can write to other directories in that partition.

What would cause that?
 
Old 04-06-2006, 03:26 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Check your /etc/fstab and make sure that you have umask=000 which should give you rwx access. Also, make sure the drive was mounted with rw instead of ro.
 
Old 04-07-2006, 02:29 AM   #3
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
So you are saying that there are umask options that will give you partial write access on a partition? How would Linux know to exclude this particular directory on the partition and not any others?
 
Old 04-07-2006, 02:42 AM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Are you sure that what you transfered to the FAT32 partition is the actual folder or maybe a Windows system link?

The 'real' path to this folder on my system is C:\Documents and Settings\<username>\My Documents. Maybe Linux isn't able to follow the link properly, or the actual data is located on NTFS. It could also be that Linux has trouble with the character encoding of the path (iso8859-1 vs. utf8).
 
Old 04-07-2006, 03:55 AM   #5
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Yo will see that in XP you can change the Target Location that My Document points to. The actual folder (called My Stuff) was created on the FAT32 drive (E: in XP). Then I changed XP from pointing to the folder similar to the one you cite to E:\My Stuff (D: being the XP NTFS system drive).

And I see the folder (My Stuff) not as a link in Konqueror but as an actual directory.

Code:
It could also be that Linux has trouble with the character encoding of the path (iso8859-1 vs. utf8).
I have no idea what that means
 
Old 04-07-2006, 04:27 AM   #6
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Quote:
I have no idea what that means
I am not completely sure about this, but AFAIK Windows uses iso8859-1 to encode its characters, while SUSE used utf8. You may have noticed a webpage displaying strange characters. This is usually due to a wrong character encoding (the code that produces a space may be different in iso8859-1 than in utf8). So it you type "My Documents" on a SUSE utf8 system, it may look different than the actual encoding on the windows drive. If you mount the FAT32 partition with iocharset=iso8859-1, you can force SUSE to use this encoding. But I am not a specialist here and it doesn't work properly on my system (garbled characters).

Try this: copy a file from Linux to FAT32 using the command line and preceding every space with a backslash, e.g.

cp file /windows/E/My\ Stuff/

or this way: cp file /windows/E/"My Stuff"/

It may also be helpful if you post the respective line from your /etc/fstab.
 
Old 04-07-2006, 09:50 PM   #7
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
Its possible it is character encoding, but I use Suse 10 and I have a fat32 partition and it uses utf8 no problem.

I would go with what you suggested abisko..

Jongi can you please post the contents of the file "/etc/fstab" ?

You can do this by going to a command prompt and typing "cat /etc/fstab". Also can you post the output of the command "mount". The mount command displays the drives that are available to access on your Suse system.

Thanks!
 
Old 04-08-2006, 01:45 AM   #8
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Code:
/dev/hdc12           /mnt/Dual            vfat       users,gid=users,umask=0002,utf8=true 0 0
 
Old 04-08-2006, 01:58 PM   #9
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
Well your fstab looks correct. I'm not sure why you're mounting to "/mnt/Dual". Suse 10 defaults to "/windows/.. <drive letter>". This is what I have in my fstab:

Code:
/dev/hda5            /windows/D           vfat       users,gid=users,umask=0002,utf8=true 0 0
If you do a "ls -l" on your /mnt/Dual directory, what permissions show up?

Mine show up as:
Code:
drwxrwxr-x   7 root users     8192 1969-12-31 16:00 ./
Yours should be very similar.
 
Old 04-08-2006, 02:09 PM   #10
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
I just noticed that in XP, when I clicked the Folder properties, the Read-Only was selected. It was a square and not a tick. I was able to move and create files there in XP. I suspect that the square means that only the Windows user can write to that file. I will load SUSE and check if I can write to it now that I have left the read only box empty.

crazibri: I got used to mounting at /mnt some time back and I always have it the same no matter which distro I install.
 
Old 04-08-2006, 03:08 PM   #11
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Code:
# ls -l /mnt/Dual/
drwxrwxr-x  12 root users    8192 1970-01-01 02:00 .
drwxr-xr-x   7 root root      168 2005-09-09 18:27 ..
drwxrwxr-x   5 root users   16384 2006-04-08 08:18 Downloads
drwxrwxr-x   2 root users   16384 2006-02-11 22:38 Incomplete
drwxrwxr-x   7 root users    8192 2006-04-05 23:23 Linux
drwxrwxr-x   8 root users    8192 2006-04-05 22:47 Mail
dr-xr-xr-x  27 root users   24576 2005-12-28 20:20 My Stuff
drwxrwxr-x   2 root users    8192 2006-01-21 01:34 Recycled
drwxrwxr-x   3 root users    8192 2005-12-28 18:22 System Volume Information
dr-xr-xr-x   2 root users    8192 2006-03-21 22:08 $vault$.avg
 
Old 04-09-2006, 08:17 AM   #12
delta_9
Member
 
Registered: Feb 2006
Location: Athens
Distribution: opensuse 11/kubuntu 8.04
Posts: 99

Rep: Reputation: 15
If i understand correctly u took My documents from an ntfs partition to a fat32 partition so that u can modify this folder.If this is the case then this folder has still read-only attributes(since it was on an ntfs file system).Just uncheck read-only.
 
Old 04-09-2006, 01:18 PM   #13
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
delta_9: Windows automatically assigns the My Documents folder to the Windows System drive. I created a Folder on a FAT32 partition, called My Stuff. I then re-pointed the My Documents folder to the My Stuff folder. After noticing I could not write to this folder from SUSE, I then went into XP. I noticed that the folder had a square in the Read Only attribute. I made that field clear (ie no tick or square). I then went into SUSE to see if I could write to this folder. No go.

I can still write to all other folders on this partition. What I will do is point the My Documents to a folder on the system drive and see whether this then allows me to write to the My Stuff folder on the FAT32 partition.

Last edited by Jongi; 04-09-2006 at 01:19 PM.
 
Old 04-09-2006, 02:28 PM   #14
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
It seems that XP is very jealous of the folder designated as the My Documents folder.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Documents Folder Mounted BarfBag Ubuntu 0 03-09-2006 12:44 PM
Folder Max Size and Limiting SSH access to home folder. Mefistofeles Linux - General 4 11-26-2005 02:09 PM
permissions difference between /home/..../folder and /root/folder darkleaf Linux - General 3 07-21-2005 05:23 PM
how can i default the max folder file size when it create inside a folder antony_csf Linux - Software 1 06-17-2004 02:26 AM


All times are GMT -5. The time now is 09:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration