LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   XMMS Works for root, not for user (http://www.linuxquestions.org/questions/suse-novell-60/xmms-works-for-root-not-for-user-254436/)

JazzMastaJim 11-13-2004 03:31 PM

XMMS Works for root, not for user
 
Running SuSE 8.1; XMMS 1.2.7:

Just within the past week or so, XMMS won't play when I'm logged in as user, but it works fine if I log in as root. As user, I get the following error message:

Couldn't open audio

Please check that:
1. You have the correct output plugin selected
(I do: OSS Driver [libOSS.so])
2. No other programs [sic] is blocking the soundcard (none are, that I can see)
3. Your soundcard is configured properly (it seems to be)

I tried replacing my user XMMS config file (~/.xmms/config) with the root config file -- changing ownership & permissions -- and it still didn't work.

I'd appreciate any suggestions anyone might have. :scratch:

Andrew Benton 11-13-2004 04:30 PM

If you're using KDE, the arts sound server may be blocking the soundcard. Try using a different desktop and see if Xmms works.

JazzMastaJim 11-14-2004 01:44 PM

Quote:

Originally posted by Andrew Benton
If you're using KDE, the arts sound server may be blocking the soundcard. Try using a different desktop and see if Xmms works.
I am using KDE. Due to space limitations, the only other window manager I have installed is Window Maker. I'll try it in that.

I forgot to mention that sound works in every other application -- including system sounds -- except XMMS. If I play an audio file in Kaboodle, for instance, it plays normally.

Harryc 11-15-2004 06:54 AM

Try uninstalling/reinstalling xmms, removing any ~/.xmms/config files and folders prior to reinstall.

JazzMastaJim 11-15-2004 09:18 AM

Quote:

Originally posted by Harryc
Try uninstalling/reinstalling xmms, removing any ~/.xmms/config files and folders prior to reinstall.
I've been thinking about doing that: just downloading and installing the latest version, since mine is a couple years old.

Also, could there be an un-deleted lock file which might be blocking access to the sound server or card, and if so, where would it be?

BTW, I couldn't test XMMS with Window Maker, since I never bothered to install sound support in it (and am not going to, since it's just there as a backup, in case something goes wrong with KDE).

Nobber 11-15-2004 09:47 AM

I had problems with XMMS (and other non-KDE soundcard-using apps) and KDE a while back too. I solved them by going to the KDE Control Centre and turning off the sound server (aRts). I recommend you do the same!

If you don't like the, er, sound of that, you can supposedly make aRts-unaware apps work with aRts by using artsdsp. Haven't tried that myself, though.

kt_leohart 11-20-2004 09:59 PM

Whoa, thanks a lot, finally one more problem solved for my SuSE box. I disable arts and the sound is working correctly now.

Again, thanks a lot. /me appreciates it.


All times are GMT -5. The time now is 06:35 AM.