LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-20-2009, 11:45 PM   #1
darkstar01
Member
 
Registered: Nov 2008
Distribution: Slackware 12.1 and Ubuntu 8.04
Posts: 38

Rep: Reputation: 15
X11 xorg.conf issue


Hi. I'm relatively new to openSuSe and for some odd reason my on board VGA isn't recognized by openSuSe but is by Gobuntu 8.10.

I'm curious as to how to get my X11 up and running again. I've already installed lynx so I can read simple websites, but I need a full GUI for IDE programming work for university. I'll post my lspci results as soon as I get a free moment.

Thanks in advance
 
Old 02-21-2009, 12:16 AM   #2
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
actually, its better to post your xorg.conf.
 
Old 02-21-2009, 02:55 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,924

Rep: Reputation: 2587Reputation: 2587Reputation: 2587Reputation: 2587Reputation: 2587Reputation: 2587Reputation: 2587Reputation: 2587Reputation: 2587Reputation: 2587Reputation: 2587
*
'lspci | grep VGA' and 'cat /etc/X11/xorg.conf' will be fine.
 
Old 02-21-2009, 11:04 AM   #4
darkstar01
Member
 
Registered: Nov 2008
Distribution: Slackware 12.1 and Ubuntu 8.04
Posts: 38

Original Poster
Rep: Reputation: 15
my cat /etc/X11/xorg.conf as shown by Backtrack 3
Code:
cat /etc/X11/xorg.conf
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/share/X11/rgb"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/TTF"
FontPath     "/usr/share/fonts/OTF"
FontPath     "/usr/share/fonts/Type1"
FontPath     "/usr/share/fonts/misc"
FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
Load  "GLcore"
Load  "dbe"
Load  "dri"
Load  "extmod"
Load  "glx"
Load  "record"
Load  "xtrap"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option      "Protocol" "auto"
Option      "Device" "/dev/input/mice"
Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
Identifier  "Card0"
Driver      "via"
VendorName  "Unknown Vendor"
BoardName   "Unknown Board"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection
and my lspci
Code:
VGA: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter
Hope this will give some insight.
 
Old 02-21-2009, 01:29 PM   #5
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
eh, just under Device change "via" to "vesa". That should get you X11.


Just sudo nano xorg.conf (/etc/X11) or run it as root (su)

change that, hit ctrl+o, ctrl+x, reboot. You may have to startx when you login.

Last edited by cheftec; 02-21-2009 at 01:30 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mouse doesn't show up in /etc/x11/xorg.conf ~zoey~ Linux - Newbie 1 01-19-2009 02:01 PM
Remote access to X11 - What do i need in my xorg.conf Boffy Linux - Server 2 05-04-2008 11:13 AM
/etc/X11/xorg.conf and KDE display don't match garyozzy Slackware 14 01-02-2006 02:59 PM
X11 Resolution - not read from xorg.conf felixc Linux - Newbie 3 10-24-2005 04:27 PM
modelines for /etc/X11/xorg.conf TranceDude Linux - Hardware 3 09-30-2005 09:59 AM


All times are GMT -5. The time now is 03:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration