LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2007, 01:10 PM   #1
kasperbs
LQ Newbie
 
Registered: Mar 2007
Distribution: openSUSE 10.2
Posts: 11

Rep: Reputation: 0
Unhappy X does not start, and the bootloader is messed up


Hi,
I have just recently installed a lot of packages from the yast software installer plus installed about 21 updates on my SUSE 10.2. And that seems to have messed most of my system up. My video card driver was set back to default in the xorg.config file and when I boot i get a command line interface and have to login and type startx to get that running.

Furthermore when grub loads it does not say openSUSE 10.2 any more, it says something like: Kernel 2.6.?.??.??-??-default.

I have managed to change my driver back so thtas working but X still don't start as normal an SUSE 10.2 don't show up in GRUB

Any help appreciated

:: Kasper
 
Old 03-18-2007, 01:49 PM   #2
gotian
LQ Newbie
 
Registered: Dec 2006
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by kasperbs
Furthermore when grub loads it does not say openSUSE 10.2 any more, it says something like: Kernel 2.6.?.??.??-??-default.
:: Kasper
Look on Grub configuration file /boot/grub/grub.conf.
You should have something like:

title GNU/Hurd
root (hd0,0)
kernel /boot/gnumach.gz root=hd0s1
module /boot/serverboot.gz

simply change 'GNU/Hurd' to 'openSUSE 10.2' and leave rest as it is.
 
Old 03-18-2007, 03:12 PM   #3
kasperbs
LQ Newbie
 
Registered: Mar 2007
Distribution: openSUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
I dont have a file called grub.config. But i have a file called menu.lst that looks much like it:
Quote:
# Modified by YaST2. Last modification on lÝr mar 17 20:18:50 GMT 2007
default 1
timeout 8
gfxmenu (hd0,5)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Diskette
rootnoverify (hd0,0)
chainloader (fd0)+1

title Kernel-2.6.18.8-0.1-default
root (hd0,5)
kernel /boot/vmlinuz-2.6.18.8-0.1-default root=/dev/hda6 vga=0x317 resume=/dev/hda2 splash=silent showopts
initrd /boot/initrd-2.6.18.8-0.1-default
If I change that will it then start X and all that when i log on. Its not because I have a problem by starting X manually but its my parents computer and they dont like that
 
Old 03-18-2007, 05:33 PM   #4
tytower
Member
 
Registered: Jun 2006
Location: Oz
Distribution: Mandriva 10.0,10.1,10.2,2006,Mepis 6.0,Opensuse10.2,Puppy 2.14
Posts: 250

Rep: Reputation: 30
reinstall from your source disk
get back to what worked and don't update anything or do it selectively.
Save your important stuuf of course but format the whole lot user root and swap
 
Old 03-19-2007, 10:59 AM   #5
kasperbs
LQ Newbie
 
Registered: Mar 2007
Distribution: openSUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
Is there no other way around! I really don't want to reformat everything I have had enough hassle over thelast couple of month getting everything set up with drivers and all that. I just want X to start automatically and have the user logged in on start up
 
Old 03-19-2007, 09:46 PM   #6
jdmcdaniel3
Member
 
Registered: Jan 2006
Location: Austin
Distribution: openSUSE 11.2
Posts: 167

Rep: Reputation: 31
Video Driver May need to be reloaded

If you were using a proprietary video driver, you will need to reload that driver anytime you have updated your kernel software. This very much sucks, but it is very true. I use the nVidia externally loaded video driver downloaded from the nVidia web site. It works great, but kernel updates kill it most every time! What kind of video driver are you using and how did you load the video driver in the first place?

Thank You,

James D. McDaniel - Austin
 
Old 03-20-2007, 05:41 PM   #7
tytower
Member
 
Registered: Jun 2006
Location: Oz
Distribution: Mandriva 10.0,10.1,10.2,2006,Mepis 6.0,Opensuse10.2,Puppy 2.14
Posts: 250

Rep: Reputation: 30
You could reinstall and only format the root partition hda1 and not format the user partition hda3 which is where your personal settings are kept .

The easiest way is to change the grub boot line I suppose but I don't know how offhand . You would start by learning how grub works and changing the appropriate line .

Just guessing from above I would play with
kernel /boot/vmlinuz-2.6.18.8-0.1-default root=/dev/hda6 vga=0x317 resume=/dev/hda2 splash=silent showopts

notice that it is addressed to hda6 does hda1/etc/grub have boot up files too?
if so try a change back to that. Probably got a Windows partition there though but just check its going to where it should be going

Also it can be changed by Yast so find out how and try that

It would worry me what changed it in the first place to cause the problem

Here is ny setup
# Modified by YaST2. Last modification on Sat Mar 3 13:43:30 EST 2007
default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,0)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.2
root (hd0,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/hda1 vga=0x314 resume=/dev/hda2 splash=silent showopts elevator=
initrd /boot/initrd-2.6.18.2-34-default

###Don't change this comment - YaST2 identifier: Original name: MEPIS at hda4, kernel 2.6.15-26-386 (/dev/hda4)###
title MEPIS at hda4, kernel 2.6.15-26-386 (/dev/hda4)
kernel (hd0,3)/boot/vmlinuz-2.6.15-26-386 root=/dev/hda4 vga=normal nomce quiet

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.2
root (hd0,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/hda1 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.18.2-34-default

Last edited by tytower; 03-20-2007 at 06:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fake start-stop-daemon, messed up install tripmix Linux - Software 2 02-23-2007 11:11 PM
messed with net settings, now X won't start mgyamada Linux - Newbie 2 01-18-2005 11:27 AM
How to start GNU/Linux Installation from NT bootloader? zero79 Linux - Software 4 12-27-2004 04:02 AM
how to configure GRUB to start a bootloader on a cd? zero79 Debian 2 07-23-2004 06:27 PM
how to configure GRUB to start bootloader on a CD? zero79 Linux - Software 2 07-20-2004 07:17 PM


All times are GMT -5. The time now is 09:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration