LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 03-08-2005, 01:54 PM   #1
retiem
Member
 
Registered: Jul 2003
Location: Frankfurt, Germany
Distribution: Mint, Ubuntu, Knoppix, RHEL
Posts: 65

Rep: Reputation: 15
wrong keyboard layout (Latin America) - SuSE 9.2


Hi folks,

I thought I'd give SuSE 9.2 a try. Look what I just ran into at a very early stage of instalation: Keyboard Configuration

My keyboard has a Latin America layout. However, none of the three choices Yast offers me during instalation works. These choices are
Spanish
Spanish (CP 850)
Spanish (Latin America)

Some keys on my keyboard are totally misconfigured, particularly the "accent" key, which is crucial in Spanish writings.

It is not well seen that a distro like SuSE runs into this kind of trouble at this point.

Hope anyone of you knows a work around for this. I do want to try SuSE! I'd hate to be put off by such a silly thing... I do need my keyboard to be properly configured.

Can anyone tell me what would be the most expedite way of letting Novell know about this? They ought to fix it!

Thanks.
 
Old 03-08-2005, 11:06 PM   #2
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Edit the file /etc/X11/xorg.conf and edit the lines according to your config:

Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "fr"

Then restart X.
 
Old 03-14-2005, 08:15 AM   #3
retiem
Member
 
Registered: Jul 2003
Location: Frankfurt, Germany
Distribution: Mint, Ubuntu, Knoppix, RHEL
Posts: 65

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Linux.tar.gz
Edit the file /etc/X11/xorg.conf and edit the lines according to your config:

Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "fr"

Then restart X.
Yes, this would be a quick way to solve the issue as long as one already knows that the right keyboard model to use in this case is "pc105", and the right layout "la"
BTW, there is a workaround during installation. Under Hardware Configuration, Graphics Cards... once Sax2 is launched, one of the menu options allows one to select the appropiate keyboard layout. Selecting "latin america" does work now!
This is not good. Especially for newbies who will not be exploring expert configuration options during installation!
Later, a postinstallation solution would be to lauch Sax2 while running X, and make the changes from there.

Hope it helps future users with a "latin america" keyboard layout...

Hope Novell fixes this little detail in SuSE 9.3... someone please let them know about it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard mapping to be-latin stuf *BSD 2 01-29-2005 05:53 AM
Can't use the alt key on SUSE (personal) with a French Keyboard layout Red Alastor Linux - Newbie 2 05-22-2004 02:25 PM
Wrong keyboard layout in XFree86 on Compaq Evo n1005v anotherlimey Linux - Laptop and Netbook 0 03-15-2004 01:04 AM
Free Software Congress in Latin America Claus Linux - General 1 10-17-2003 05:49 PM
Keyboard layout wrong at Mandrake 9.1 depailler Mandriva 1 09-02-2003 06:49 AM


All times are GMT -5. The time now is 12:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration