LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 02-06-2006, 12:24 PM   #1
57210788
LQ Newbie
 
Registered: Jan 2006
Distribution: Suse 10.0 with KDE
Posts: 9

Rep: Reputation: 0
wireless enabling problems


I think I have properly installed me wireless card on my Toshiba A70 satellite laptop. It is an Askey AR5212 802.11 abg NIC. When I go to YaSt and go to my network card configuration it recognizes the card and runs through a checklist as if it has worked properly. However on the bottom of my takbar there is an "x" which if I clik on it says "disconnected" . From there it gives me 3 options 1-connection information, 2 configure network settings and 3 remove from panel.

If I click on connection information it gives me an error message saying "no active connection"

If i click on the second one it just takes me back into yast and runs through the same list as before.

I ran a search on wireless problems and have already tried installing the WPA supplicant package. I now have the "administration" option on my internet menu but when I click it, it does nothing. I have also installed netapplet, but could not find an application called knemo.

Is there anyone who can help. I love linux so far but feel like fish out of Windows.
 
Old 02-06-2006, 12:49 PM   #2
BinFarteen
LQ Newbie
 
Registered: Jan 2006
Location: Indiana, USA
Distribution: FC4, Smoothwall, Asterisk@Home, SuSE 10.0
Posts: 22

Rep: Reputation: 15
Have you temporarily turned off security to make sure it works, turned on broadcast SSID, put "ANY" in the field for SSID?
 
Old 02-06-2006, 02:29 PM   #3
57210788
LQ Newbie
 
Registered: Jan 2006
Distribution: Suse 10.0 with KDE
Posts: 9

Original Poster
Rep: Reputation: 0
sorry to be a pain and a but i have no idea what you mean. I shut off the firewall, but the rest I don't understand.
 
Old 02-06-2006, 11:24 PM   #4
BinFarteen
LQ Newbie
 
Registered: Jan 2006
Location: Indiana, USA
Distribution: FC4, Smoothwall, Asterisk@Home, SuSE 10.0
Posts: 22

Rep: Reputation: 15
Quote:
Originally Posted by 57210788
sorry to be a pain and a but i have no idea what you mean. I shut off the firewall, but the rest I don't understand.
In your wireless access point, temporarily turn off whatever security you're using, turn on SSID broadcast, then in linux change your network card config's SSID to ANY, and see if it can connect.

It helps to have a DHCP server somewhere on your lan, either in the wireless access point, or some other router/computer. That way, if your wireless card is talking at all to your access point, it will get an IP address in the range you've designated.
 
Old 02-07-2006, 12:42 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You may want to look at the output of:
/sbin/ifconfig
/usr/sbin/iwconfig
/usr/sbin/iflist <wireless-interface-name> scan

Also, if you also have a NIC card, run as root
/usr/rcnetwork stop eth0
/usr/rcnetwork restart <wireless-device-name> # often wlan0, sometimes eth1

The ifconfig command will list each network device. If the wireless device has an IP address, it will be listed.
The iwconfig command is similar, but lists statistics for wireless devices. It doesn't list the IP address of the wireless interface, but if you have negociated correctly with the AP, the AP's MAC address will be listed. Otherwise 00:00:00:00:00:00 will be listed
The iwlist command can be used to list various things about the wireless device, but not set them. The scanning argument will perform a wireless scan and tell you if it has found any wireless networks, what the ESSID of the network is and the channel (frequency) that the network uses.

If you use DHCP, then you need WEP or WPA-PSK properly configured before you will get an IP address assigned. However, you will be able to use the iwlist command to determine if the network interface itself is working. Also, look at the output of /sbin/lsmod to see if there is a kernel module loaded for the network device.

I am using a Linksys card, so I use ndiswrapper rather than madwifi, so I don't know what module you should be looking for. There should be a directory matching your drivers name in /proc/net/. If not, then the driver isn't installed or wasn't loaded into the kernel.

Last edited by jschiwal; 02-08-2006 at 04:16 PM.
 
Old 02-08-2006, 01:59 AM   #6
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
Basically those commands he gave you are root commands for networking in your Konsole.

ifconfig shows you up network devices
ifup <name of device> will turn a device on (i.e. wlan0, or eth0)
ifdown
iwconfig shows you Wireless settings like essid (aka wireless network name)
If your router doesnt have WPA set on its gateway settings then you dont have to worry about it.

My suggestion, try those commands jschiwal and I posted and if you dont get a response, it might be a driver or configuration issue and you'll have to let us know to troubleshoot that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enabling wireless (Kubuntu) coldsalmon Ubuntu 5 06-27-2005 11:21 AM
problem enabling wireless on Mandrake 10 ekanathanpn Linux - Wireless Networking 10 03-24-2005 10:30 PM
enabling wireless extensions? arunsri Slackware 1 03-19-2005 06:42 AM
Enabling DMA Problems. ShoCkwave Slackware 7 02-07-2005 12:29 PM
linux hangs when enabling wireless card knight-rider Linux - Wireless Networking 1 01-16-2005 12:06 PM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration