LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-02-2005, 09:45 AM   #1
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Rep: Reputation: 15
Question window unbootable after suse


after i install suse
the boot loader give me the alternative to boot on windows 1 or windows 2
both does not work. citing command.com error.

i had a fat32/ntfs parition on my hard drive before suse installation, win xp was on the fat32.
its a asus m5r 740 notebook.

the version of suse is a 9.3

i tried to recover windows on the fat32 partition, it did not work because of partition problem.

can anyone help me with my problm?

i want to have a winxp/suse dual boot system.
and i dont want to loss what i have on the ntsf partition
 
Old 09-02-2005, 10:20 AM   #2
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
You need to let people know the partition scheme of your hard disk which is obtainable in Suse by typing

fdisk -l

at command prompt after log in as root first (or type su followed by root password)

Then to repair the booting copy and paste your

/boot/grub/menu.lst

here. It is the menu for Grub to control your booting.

If you did not have a partition scheme before Sue installation then you could have instruct Suse to overwrite the FAT and NTFS partitions. However if Suse has picked out Windows 1 and 2 that means it had left these two partitions alone.

No command.com means Suse was booting a unbootable drive, a D holding data only. That is all.

You must know what partitions and space in your hard disks before doing any multi-boot. Suse can be made to boot 50 systems if you wish but it you who must arrange which system to go to which partition.

Have an idea about what inside the hard disk is a necessary start.
 
Old 09-02-2005, 11:14 AM   #3
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Original Poster
Rep: Reputation: 15
thanks for helping a newb like me.

after su and root password and fdisk -l

the following is what i got.
"
Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 243 1951866 1b Hidden W95 FAT32
/dev/hda2 * 244 3345 24912896+ c W95 FAT32 (LBA)
/dev/hda3 5942 9729 30427110 f W95 Ext'd (LBA)
/dev/hda4 3346 5941 20852370 83 Linux
/dev/hda5 5942 9729 30427078+ 7 HPFS/NTFS

Partition table entries are not in disk order
linux:/home/neouto #
"
when i enter

/boot/grub/menu.lst

it told me "Permission denied"

thanks for you help saikee.
 
Old 09-02-2005, 11:51 AM   #4
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
OK we are getting somewhere.

You have hda1 marked hidden. This is OK possibly left by Grub since the last booting attempt. Grub hides hda1 in order to boot your hda2 into a "C" drive. That is all.

Since you have 2 Windows my guess is that you may be using XP to dual boot the other. If this is the case then it may make one of the Windows more difficult to boot.

I know you are using a notebook. Can't you confirm if it has a bootable floppy drive before I give you the instructions?

It is important for you to understand that

(1) All your data is safe as long as you donot format any of the partitions.

(2) Your original Windows booting system can be reinstated by unhiding hda1 and restore the MBR. The former is achieved by using Suse's cfdisk command at terminal mode as root and the latter is achieved by a bootable DOS floppy (with fdisk.exe inside) or XP's installation CD.

(3) Suse can be booted up any time if you have a floppy drive to make a bootable Grub floppy. No floppy then you need to get hold of a copy of Linux rescue CD or just use Suse's installation CD.

Let us know if there is a floppy drive that boots in your notebook.

Regarding the access to /boot/grub/menu.lst you need to log in as root in order to have the privilege to change the system files. /boot/grub/menu.lst is just a text file containing the instructions for Grub to boot your system. It would have the following entries for your hda1 and hda2

title windows 1
rootnoverify (hd0,0)
makeactive
chainloader +1

title windows 2
hide (hd0,0)
rootnoverify (hd0,1)
makeactive
chainloader +1

The hide instruction prevents the BIOS from booting hda1 when you want hda2. Makeactive is to make your root directory bootable. Grub counts from 0 and so hda1=(hd0,0) and hda2=(hd0,1)

Your booting problem lies most likely with the XP dualing boot if you do have two Windows operating.

Last edited by saikee; 09-03-2005 at 04:06 AM.
 
Old 09-02-2005, 12:51 PM   #5
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Original Poster
Rep: Reputation: 15
i don t have a floppy drive but i think i can boot with my usb drive.

i am using a notebook and i only have one windows which is XP
i do not know why suse think i have two windows.
btw chosing winddos 1 will see win 98s start up logo for one sec befor that command.com error messeage comes up in DOS.

i had a look at this, will this solve my problem?
i notice that it is for ver.9.1 not ver.9.3
portal.suse.com/sdb/en/2004/05/fhassel_windows_not_booting91.html

i will stay put before your next instruction.

thanks
 
Old 09-02-2005, 05:57 PM   #6
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I think I might know the root cause of your problem. If you claim you have only one Windows then the first partition hda1 could have been left there by someone else or youself in the past. It sounds like a dual boot system to me because of the short Win98 display.

What could have happened is Suse did not know it and tried to boot either. It does this by hiding hda1 when boot hda2 and vice versa. Windows own dual-boot method requires both hda1 and hda2 to be unhided. Therefore Suse fails to boot your Windows because one of the partition is always hidden in order to allow the booting your Windows into a "C" drive.

Now the fix

List your /boot/grub/menu.lst and /boot/grub/device.map here

You can try to takout one of the Window booting options and concentrate on having the following lines in the remaining booting choice for Windows


unhide (hd0,0)
unhide (hd0,1)
rootnoverify (hd0,0)
makeactive
chainloader +1

The above lines mean unhide both hda1 and hda2, regard hda1 as the root partition (for mounting the filing system) no need to verify if it is a Linux partition or not, chain-load its boot loader into memory starting from the 2nd sector (+1 position).
 
Old 09-02-2005, 09:43 PM   #7
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Original Poster
Rep: Reputation: 15
who do i sign in to my system as a root user?

i can access /boot/grub/menu.lst and /boot/grub/device.map
 
Old 09-02-2005, 09:45 PM   #8
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Original Poster
Rep: Reputation: 15
how do i sign in to my system as a root user?

i cant access /boot/grub/menu.lst and /boot/grub/device.map
 
Old 09-03-2005, 04:21 AM   #9
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Yes, I forgot Ubuntu is one of the few distros that has no root log in.

Here is how you get in

click the smelly foot next the Application at the top left corner
the system tools
and then root terminal. It will ask you for the password.

Thereafter you can open the files in the desktop with gedit.
 
Old 09-03-2005, 01:10 PM   #10
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Original Poster
Rep: Reputation: 15
i dont see the foot,

but i was able to find "terminal programe- super user mode"
but even than i am still denied access

thanks

i am use KDE not gnome btw.

Last edited by neouto; 09-03-2005 at 02:12 PM.
 
Old 09-03-2005, 02:14 PM   #11
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Ah, I was thinking Ubuntu when you said you can't log in as root user.

Yes it is a pain the the arxe but for Suse you should be able to log in as root before starting the desktop. However it is also possible in different distributions the un-paid versions may have less root access to the desktop. You can certainly view and edit the files in terminal mode.

So just click terminal mode at the desktop, type su and then the password for root. To edit file /boot/grub/menu.lst you type

kwrite /boot/grub/menu.lst

and will be able to do whatever you want. I just tried it myself in Suse 10.

good luck
 
Old 09-03-2005, 02:17 PM   #12
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Original Poster
Rep: Reputation: 15
i tried "kwrite /boot/grub/menu.lst"
but came back as
"bash: kwrite: command not found"

Last edited by neouto; 09-03-2005 at 02:19 PM.
 
Old 09-03-2005, 04:22 PM   #13
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Strange as I did a trial run myself with Suse 10.

Did you switch to super user mode by typing "su" as indicated above?

Try gedit or vi.

The last one is a line editor requiring a manual if you haven't used it before. Type i to insert and Esc after completion, :w to write and save the file, :q to quit.
 
Old 09-03-2005, 06:25 PM   #14
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Original Poster
Rep: Reputation: 15
i think i got what u wanted (yeah!!!!)

after root shell

"
Password:
linux:~ # kwrite /boot/grub/menu.lst
WARNING: please edit ~/.scim/global and change /DefaultConfigModule to kconfig
"

i got the following in kwrite

"
# Modified by YaST2. Last modification on Sun Sep 4 03:59:31 EST 2005

color white/blue black/light-gray
default 3
timeout 8
gfxmenu (hd0,3)/boot/message

###Don't change this comment - YaST2 identifier: Original name: windows 1###

title windows 1
root (hd0,0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: windows 2###

title windows 2
root (hd0,1)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE LINUX 9.3
kernel (hd0,3)/boot/vmlinuz root=/dev/hda4 showopts ide=nodma apm=off acpi=off vga=normal noresume selinux=0 barrier=off nosmp noapic maxcpus=0 3
initrd (hd0,3)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX 9.3
kernel (hd0,3)/boot/vmlinuz root=/dev/hda4 vga=0x317 selinux=0 splash=silent apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare showopts
initrd (hd0,3)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: xen###
title XEN
kernel (hd0,3)/boot/xen.gz dom0_mem=327680
module (hd0,3)/boot/vmlinuz-xen root=/dev/hda4 vga=0x317 selinux=0 splash=silent apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare showopts
module (hd0,3)/boot/initrd-xen
"
 
Old 09-03-2005, 06:28 PM   #15
neouto
Member
 
Registered: Aug 2005
Location: australia
Posts: 49

Original Poster
Rep: Reputation: 15
just one more

in root shell

"
linux:~ # kwrite /boot/grub/device.map
kbuildsycoca running...
WARNING: please edit ~/.scim/global and change /DefaultConfigModule to kconfig
Loading -d Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
"

and just the following in blue highlight in kwrite

"
(hd0) /dev/hda
"
i think we aere getting some where
thanks you soooooooooooooooooooo much for putin up with a newb
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Now that my system is Unbootable........can someone help me! matthewa Linux From Scratch 1 06-06-2005 09:18 PM
Windows XP is unBootable after installing SuSE 9.1 Personal !! Help :( kal_q Linux - Laptop and Netbook 3 11-26-2004 04:49 PM
SuSE Live CD made Windows unbootable spaaarky21 Linux - General 4 09-29-2004 12:03 PM
unbootable old computer lilamrta Linux - General 5 08-17-2004 08:24 PM
My RH9 is unbootable after ... novkhan Linux - Newbie 2 01-20-2004 02:09 AM


All times are GMT -5. The time now is 02:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration