LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   window 7 open suse dual boot problem .. grub does not find window7 (http://www.linuxquestions.org/questions/suse-novell-60/window-7-open-suse-dual-boot-problem-grub-does-not-find-window7-893194/)

nik100 07-22-2011 01:13 PM

window 7 open suse dual boot problem .. grub does not find window7
 
hello linux friends.. here nikhil..
i install window 7 .. first and after that open suse on that... after installation grub can't find the window 7
but open suse start well

when i click on windows on grub menu .. it just display these error

undefined video mode number 31 a
after inter a valid video mode .. it start yast for installation open suse
pls help



there is my menu.lst file

Code:

# Modified by YaST2. Last modification on Thu Jul 21 09:01:06 IST 2011
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 30
##YaST - generic_mbr
gfxmenu (hd0,6)/boot/message
##YaST - activate


title openSUSE 11.3
    root (hd0,6)
    kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part7    resume=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part4 splash=silent quiet showopts
    initrd /boot/initrd-2.6.34-12-desktop


title XEN
    root (hd0,6)
    kernel /boot/xen.gz
    module /boot/vmlinuz-xen root=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part7    resume=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part4 splash=silent quiet showopts
    module /boot/initrd-xen


title Windows
    rootnoverify (hd0,0)
    makeactive

    chainloader +1


title Failsafe -- openSUSE 11.3
    root (hd0,6)
    kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part7 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset  x11failsafe
    initrd /boot/initrd-2.6.34-12-desktop

###Don't change this comment - YaST2 identifier: Original name: linux###
title Kernel-xen
    root (hd0,6)
    kernel /boot/vmlinuz-xen root=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part7    resume=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part4 splash=silent quiet showopts
    initrd /boot/initrd-xen

###Don't change this comment - YaST2 identifier: Original name: linux###
title Kernel-2.6.34-12-desktop
    root (hd0,6)
    kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part7    resume=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part4 splash=silent quiet showopts
    initrd /boot/initrd-2.6.34-12-desktop

###Don't change this comment - YaST2 identifier: Original name: linux###
title Kernel-2.6.34-12-xen
    root (hd0,6)
    kernel /boot/vmlinuz-2.6.34-12-xen root=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part7    resume=/dev/disk/by-id/ata-Hitachi_HTS542516K9SA00_080802BB6C005GG1UPGG-part4 splash=silent quiet showopts
    initrd /boot/initrd-2.6.34-12-xen

and this is the out put of my fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x66666666

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3916 31455238+ 7 HPFS/NTFS
/dev/sda2 7833 19456 93369780 f W95 Ext'd (LBA)
/dev/sda3 4403 7832 27550720 83 Linux
/dev/sda4 3917 4402 3903795 82 Linux swap / Solaris
/dev/sda5 7833 11748 31455238+ 7 HPFS/NTFS
/dev/sda6 11749 16529 38395350 7 HPFS/NTFS
/dev/sda7 16529 19140 20972544 83 Linux


pls help

alfredo10 07-22-2011 01:28 PM

Hi!
My multiboot with openSUSE 11.4,... and Windows7:
menu.lst of Suse:
Code:

title windows
    rootnoverify (hd0,1)
    chainloader +1

That means: no "makeactive" and no blank line after "makeactive"
To edit the menu.lst: If you have KDE:
ALT + F2 >
Code:

kdesu kwrite /boot/grub/menu.lst
or kate instaed of kwrite.
Gnome:
Code:

gksudo gedit /boot/grub/menu.lst
alfredo

nik100 07-23-2011 02:04 PM

hey linux friend.. tehre is something new happened.. today when i start and check window 7 .. there is error

bootmgr is missing press ctl+alt+delete

i think my boot,gr file of window is deleted .. how i recover.. i don't wnt to mess up with my suse

please help.. thanks in advance

John VV 07-23-2011 03:06 PM

did you take int account the VERY well documented issues with the win7 "recovery" partition that the oems put on the front of the drive ( too cheep for a real install dvd)
sda1 is that "recovery" partition

you do have a install dvd you got from MS ? right? they will snail mail it to you
if so fix the windows bootloader

andrewthomas 07-23-2011 03:40 PM

If you don't have the win7 DVD, then you can get a recovery disk here:

http://neosmart.net/blog/2009/window...-repair-discs/

Peverel 07-24-2011 03:13 PM

I am puzzled by the output from your fdisk. When you set up Grub in your Opensuse install, your assumption was that Windows7 was on /dev/sda1, which Grub knows as (hd0,0). Alfredo10 suggested that it was on (hd0,1), which is /dev/sda2. But on your system, /dev/sda2 is an extended partition which comprises /dev/sda5, /dev/sda6 and /dev/sda7, but not /dev/sda3 and /dev/sda4, which are Linux, presumably /home, and Linux swap; physically, these are where Alfredo10 expects Windows7 to be. On the other hand, /dev/sda5 and /dev/sda6 are NTFS (Windows7) partitions.

So, two possibilities: you mistook the partitions when you set up OpenSuse and overwrote your Windows7 partition, or Windows7 is actually on /dev/sda5 (more likely than /dev/sda6), which is in Grub speak, (hd0,4). You could try that in the bootloader. In OpenSuse, the best way of modifying the bootloader is by use of Yast. Click on the green disc at bottom left, hover the mouse over the computer symbol, then click Yast. You then give the root password and the Yast window appears. in the fifth line you will see Bootloader. Click on this and edit the windows line to:

windows Other /dev/sda5

then save the configuration. Note that it really is /dev/sda5, not (hd0,4). And the best of luck.

alfredo10 07-25-2011 07:07 AM

Hi!
1.
That's a misunderstanding: As I wrote: "My multiboot" -> my menu.lst, not the list of the OP!
2.
I would try to find out where Grub is installed:
Commands in a Terminal of a Linux as root:
Code:

fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 or higher ;; *) echo X: No GRUB Y ;; esac\""
alfredo

Peverel 07-25-2011 10:31 AM

Reply to Alfredo:
1. Yes, I realized that: the question was, where Windows7 installs itself; if in the second partition, as yours, then it has been overwritten, if in the third (or fourth) then there is a chance.
2. Since there is only one Linux boot partition, Grub must have been installed from there, and Yast is the easiest way to examine it.

alfredo10 07-25-2011 02:47 PM

Hi!
With the command in answer #7, which I found here:
http://wiki.ubuntuusers.de/GRUB_Umge...0Zgrub%20Zfind
we would have one important answer.
And there are more useful commands!
alfredo


All times are GMT -5. The time now is 11:58 PM.