LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 07-07-2008, 01:28 AM   #1
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Rep: Reputation: 31
Question Why I have to reboot my comp each and every day, after switch on SUSE 11.0


Hi.
A very strange behaviour of my comp I noticed, after installing SUSE 11.0. Each day, after cold boot, my comp stopped after login screen, with a black screen and a cursor blinking. I have to Ctrl+Alt+F2 (F4) and enter the command as root "Shutdown -r now". Only then the comp boot into SUSE 11.0. After that, everything works normally. But next day, I have to repeat the procedure again. Any suggestion??
 
Old 07-07-2008, 01:46 AM   #2
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 57
What happens if you press ctrl-alt-backspace?
 
Old 07-07-2008, 02:06 AM   #3
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by AceofSpades19 View Post
What happens if you press ctrl-alt-backspace?
Never tried that. Next time i will try and report. Thanks for help.
 
Old 07-08-2008, 01:06 AM   #4
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Hi AceofSpades19,

Nothing happened when ctrl-Alt-backspace.
 
Old 07-08-2008, 01:22 AM   #5
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,739

Rep: Reputation: 298Reputation: 298Reputation: 298
Run this command in a terminal:
Code:
grep default /etc/inittab
Do you see this?
Code:
# The default runlevel is defined here
id:5:initdefault:
The line *id:5:initdefault:* sets the default runlevel at runlevel 5. If your /etc/inittab shows a different number, change it to 5.

Save the file, then test it by re-booting? You should be able to boot to GUI mode (runlevel 5).
 
Old 07-08-2008, 02:08 AM   #6
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by bigrigdriver View Post
Run this command in a terminal:
Code:
grep default /etc/inittab
Do you see this?
Code:
# The default runlevel is defined here
id:5:initdefault:
The line *id:5:initdefault:* sets the default runlevel at runlevel 5. If your /etc/inittab shows a different number, change it to 5.

Save the file, then test it by re-booting? You should be able to boot to GUI mode (runlevel 5).
Hi,
this is what I get:


bogomir@linux-58xe:~> grep default /etc/inittab
# The default runlevel is defined here
id:5:initdefault:
# runlevel 0 is System halt (Do not use this for initdefault!)
# runlevel 6 is System reboot (Do not use this for initdefault!)
bogomir@linux-58xe:~>




Seems to be O.K.
 
Old 08-05-2008, 02:29 AM   #7
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Hi everybody,

Still no solution for that. This is very annoying. Every day when I switch my computer on, I have to reboot it to get SUSE desktop back. Do you have any idea how to correct this???
 
Old 08-07-2008, 06:24 PM   #8
garyg007
Member
 
Registered: Aug 2008
Location: north-east ohio
Distribution: Debian-squeeze/stable;
Posts: 279
Blog Entries: 1

Rep: Reputation: 31
ctl+alt+backspace works a little different in suse 11.0;
While holding down ctl+alt, hit backspace twice
within two seconds - What happens then?
 
Old 08-08-2008, 12:14 AM   #9
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by garyg007 View Post
ctl+alt+backspace works a little different in suse 11.0;
While holding down ctl+alt, hit backspace twice
within two seconds - What happens then?
Well, nothing. I just get a login screen. When I enter my name &password, the same thing happened - a black screen with mouse pointer. I must reboot and then everything works.
 
Old 08-08-2008, 05:32 AM   #10
Sjonnie48
Member
 
Registered: Jun 2005
Location: Earth
Distribution: Ubuntu10.04
Posts: 308

Rep: Reputation: 43
So, after hitting Ctrl+Alt+F2 (F4) you have an active shell.
Did you try startx?
 
Old 08-08-2008, 08:24 AM   #11
garyg007
Member
 
Registered: Aug 2008
Location: north-east ohio
Distribution: Debian-squeeze/stable;
Posts: 279
Blog Entries: 1

Rep: Reputation: 31
Quote:
Originally Posted by riba43 View Post
Well, nothing. I just get a login screen. When I enter my name &password, the same thing happened - a black screen with mouse pointer. I must reboot and then everything works.
Lower left of the screen, click on "session type" what does it show? Can you tell what it shows as the default?

After you get the blank screen and reboot, when you get the sign on screen, does the "session type" show anything different from the first time?

If the list under "session type" has kde4 as current, try selecting kde3 and sign in.
 
Old 08-08-2008, 10:04 AM   #12
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Hi,
There is only KDE4, no KDE3
 
Old 08-08-2008, 10:58 AM   #13
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
If you think that the problem could be kde4 , it possible to install kde3.5
Easy way of course when the system is up
Startup yast>filter>choice patterns> kde3. in the window below filter
After install restart at login screen goto session type choice kde3

Last edited by ronlau9; 08-08-2008 at 11:00 AM. Reason: ad information
 
Old 08-08-2008, 02:11 PM   #14
garyg007
Member
 
Registered: Aug 2008
Location: north-east ohio
Distribution: Debian-squeeze/stable;
Posts: 279
Blog Entries: 1

Rep: Reputation: 31
I agree with ronlau9, that there is a good possibility the problem is with KDE4.0, which has been quit buggy; 4.1 is better, but it is still buggy. KDE 3.5.9 is the best bet.

Where I was headed was to try and find what worked and what made it different from what did not work.

Shut the computer down - to power off.
Then power it on and let it boot (make note of anything that may be on the grub command line before it boots).

before doing anything with the sign-on screen look at the "session type" tell us what the default is.

then let it fail, and do what you do to get it started; again, when you get the signon screen, check the session type and tell us what the default is this time.
 
Old 08-25-2008, 02:00 PM   #15
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Hi garyg007 & ronlau9 ,
Sorry for beeing so late but I was on holidays for the last 18 days. Now I wabnted to try what you suggested, but I got another error message and I cant enter anything in YAST2. The Xmessage is:
"Error while creating client module sw_single"

I do not know what that means and when it happened.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
is there a way to an xp home comp see a linux suse comp in a network rayclnz Suse/Novell 1 01-03-2007 02:30 AM
SAN Volumes Go away with switch reboot nitrohuffer2001 Linux - Hardware 3 12-16-2006 08:07 PM
eth0 and eth1 switch places on reboot? slayer17 Linux - Networking 8 12-14-2005 08:33 PM
2 video modes, can i switch without reboot? true_atlantis Linux - Hardware 4 05-30-2004 02:00 PM
Can I switch from Windows to linux in one day? paragon Linux - General 19 06-09-2003 12:36 PM


All times are GMT -5. The time now is 10:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration