LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 06-01-2007, 03:47 PM   #1
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Rep: Reputation: 64
Question Why I have some protected packages


Hi,

I am using openSuse 10.2.
In the YaST2 sw_single, the installation tool, some packages are marked as a yellow lock and the tool-tip says the package is protected.

Why it is marked as protected ?
How to I got those protected packages ?
How to get a listing of all rpm packages marked as protected ?

The rpm tools say nothing about protected packages. I think this is a opensuse specific thing ?

How to control the protected status of a package ? I mean, what command line tool I must use to set/unset a package as protected ?

Protected packages will not upgrade even if a newer version is available, unless I manually un-protect them, in the YaST2 installation tool.

any info will be nice.
 
Old 06-02-2007, 12:50 PM   #2
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
From yast2 help menu:
Quote:
Locked: This package is installed and should not be modified, especially not because of unresolved dependencies that other packages might have or get. Use this status for third-party packages that should not be overwritten by newer versions that may come with the distribution.
This has nothing to do with RPM, it's a setting of the package manager (yast) and can only be set through it. You can see the locked files when you select "installation summary" as a filter in software management.
 
Old 06-03-2007, 09:23 PM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
That will happen if you install a package using the rpm command instead of using yast.

If you downloaded media related packages from a packman site, the package versions don't match the SuSE versions of the same packages. So they are locked to prevent a SuSE update from replacing these packages during an update.

If you have a packman repo added as an installation source, you can use "Installation Source" as the filter list, then in the right hand side pane, right click and select "all in this list..." -> update if newer available.

That allows you to update the xine, mplayer, audacity, etc. packages from another repo, such as packman.

If you simply installed a SuSE package using rpm, you could unlock it if you wanted.

---

If you select installation summary, you can list just the locked packages.
 
Old 06-04-2007, 02:32 PM   #4
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Original Poster
Rep: Reputation: 64
Thanks for the enlightenment, fellows !

I was in doubt if there are something new in the rpm, but looks like it is a YaST thing.
I was in doubt too if locked packages means something bad or at least, an undesirable status.

Looks like packages installed from rpm cmd tool and from YaST via suse-guru and non-oss sources are marked are locked.

see'ya,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Protected PDF Schopy Linux - Software 3 04-13-2005 07:03 PM
"protected" packages in YaST? lnebrown Suse/Novell 1 02-21-2005 12:26 PM
protected folders tommytomato Linux - Security 6 09-22-2004 12:23 AM
protected directories tommytomato Linux - Security 2 01-11-2004 11:34 PM
creating packages (.tgz/.deb/.rpm) How from the source packages? l_9_l Linux - General 1 03-06-2002 07:03 PM


All times are GMT -5. The time now is 02:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration