LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   webcam fine, mic? no sound! (http://www.linuxquestions.org/questions/suse-novell-60/webcam-fine-mic-no-sound-517184/)

linux_junky 01-07-2007 12:45 PM

webcam fine, mic? no sound!
 
I've been setting up a new laptop (HP Pavilion dv2000z) and there are a few 'loose ends'.

The latest is, I find the built-in mic does not work--the WebCam works ok now after installing the uvcvideo module. Specifically, I am using Ekiga 2.x in which the druid sound test indicates that the mic isn't working. Again, the webcam is working ok.

In researching why the mic (and phone mic jack input) don't work, someone in a thread mentioned trying to update to the newest ALSA driver.

Well, being that I am on SUSE 10.2 it is using the latest--1.0.13.

Here's the lsusb for the audio device, currently using driver snd-hda-intel:

/***

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
Subsystem: Hewlett-Packard Company Unknown device 30b5
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 209
Memory at c0000000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [44] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
Capabilities: [6c] HyperTransport: MSI Mapping

***/

Anyone figure out how to fix this?
If so, suggestions appreciated!

Thanks Much!

GrueMaster 01-08-2007 12:01 PM

Actually, you are not using the "latest" alsa. There have been many changes since 1.0.13. In particular is an audio driver that I have written for your specific system. It is still a work in progress, but now that Conexant has provided me with datasheets on their audio chip, I am working on fixing those issues. If you want to try the latest patch, download alsa-driver-1.0.14rc1. I will be sending out a patch soon against that version (the driver there is prior to my actually having documentation). Email me with any issues you find, along with dmesg output from after loading the driver (please don't send the entire boot log), along withthe output from "cat /proc/asound/card0/codec#0".

Tobin

linux_junky 01-08-2007 12:45 PM

OK, I'll give 1.0.14rc1 a shot--thanks for all of your efforts!!

linux_junky 01-08-2007 02:28 PM

Still a 'no-go' with 1.0.14rc1--here's the codec:

/***
linux:/proc/asound/card0/codec97#0 # cat ac97#0-0
0-0/0: ESS Technology ESS1988

PCI Subsys Vendor: 0x0000
PCI Subsys Device: 0x0000

Capabilities :
DAC resolution : 20-bit
ADC resolution : 20-bit
3D enhancement : ESS Technology Stereo Enhancement

Current setup
Mic gain : +0dB [+0dB]
POP path : pre 3D
Sim. stereo : off
3D enhancement : off
Loudness : off
Mono output : MIX
Mic select : Mic1
ADC/DAC loopback : off
Double rate slots: 10/11
Extended ID : codec=0 rev=0 DSA=0 DRA
Extended status :
linux:/proc/asound/card0/codec97#0 #
***/


dmesg--what part(s) do you want me to send you?

Thanks again

linux_junky 01-08-2007 10:23 PM

Gruemaster:
A follow-up,
I've noticed since having installed 1.0.14rc1 that the speakers 'mute' touch button is now lit 'red'.

Previously, not lit AT ALL--so this is an improvement!
Also, I've tried setting the device to ALSA and /dev/dsp in Skype and the mic doesn't work there either.

So, this definitely appears to be a sound driver problem.

Let me know if you need anything else.
Hope to hear back from you soon!

ShadowHywind 01-22-2007 11:51 AM

same audio card, but with an hp dv6040 updated to 1.0.14rc1 i have the same (mute light stays on) but no mic. However i sort of downgraded back to 1.0.12 because i liked having the options of separate controls for headphones and speakers(allways have the speakers on mute). But I was able to get my microphone semi-working in 1.0.12. There was no mic booster option (in eather 1.0.12/14rc1), But if you played something into the mic jack at an exteremly high volume, it did record it. Hopefully that might help.

linux_junky 01-22-2007 11:58 AM

GrueMaster has offered to finish developing a driver for the dv2000z sound device--I think I'll hold off in preference to that.

(Good things come to those who wait....)

Thanks for your fyi!!
Best
LJ


All times are GMT -5. The time now is 10:45 AM.