LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-12-2005, 02:10 PM   #1
Cogvos
Member
 
Registered: Feb 2005
Distribution: Suse 9.3 also Redhat 9, Umbuto, Mandriva 2005
Posts: 31

Rep: Reputation: 15
waiting for device to appear boot problem


Dear all,

Sorry if this is an obvious question, but I have the following appearing in the detail console when trying to boot suse 9.3 from an external usb drive.

waiting for device /dev/sda3 to appear ... resume device /dev/sda3 not found (ignoring)
loading kernel/fs/jbd/jbd.ko
loading kernel/fs/ext3/ext3.ko
waiting for device /dev/sda2 to appear ... not found -- exiting to /bin/sh
sh: can't access ttys job control turned off
$

I am guessing that the initrd is missing something relating to usb, but am not sure what.
The drive is set up as sda1 = /boot
sda2 = /
sda3 = swap
grub loads initrd from sda1, enters stage 2, and all appears fine untill the above.
I can't understand why the init can apparently see the first partion, to load initrd but not the others. The bootloader is on sda's MRB.

Any thoughts?
I can boot the system via the install cd, though I have to wait untill the point where it asks if I want to install/repair or boot. Clicking boot works fine

Please let me know what other info might be of help. I am well and truly stuck

John.
 
Old 10-14-2005, 05:43 PM   #2
Cogvos
Member
 
Registered: Feb 2005
Distribution: Suse 9.3 also Redhat 9, Umbuto, Mandriva 2005
Posts: 31

Original Poster
Rep: Reputation: 15
Waiting for device to appear - solved!

Dear all,

Anyone who has this problem, please refer to my thread in the newbie forum 'Problems installing linux onto a USB drive' , where the solution (for me at least) has been posted.

John.
 
Old 10-17-2005, 07:37 PM   #3
thegsusfreek
Member
 
Registered: Jul 2004
Posts: 34

Rep: Reputation: 15
Link:

http://www.linuxquestions.org/questi...hreadid=372201

Last edited by thegsusfreek; 10-17-2005 at 07:39 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Drive Problems: timeout waiting for DMA; error waiting for DMA mintee Linux - Hardware 10 09-21-2007 05:06 AM
Waiting for device /dev/hde2 to appear... Not found dan1268 Linux - Hardware 2 09-14-2005 11:15 AM
waiting for device to become free, usage count=1 tunasashimi Suse/Novell 0 07-04-2005 04:23 AM
TC + PPP0 waiting for device to become free, usage count bla bla bla tunasashimi Linux - Networking 0 06-13-2005 06:17 PM
waiting for checking for initramfs, SLOW boot Rocker Linux - General 1 09-25-2004 07:47 AM


All times are GMT -5. The time now is 05:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration