LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-11-2004, 08:43 PM   #1
maelstrom209
Member
 
Registered: Sep 2004
Location: The Imagination
Distribution: Suse 9.3 Professional
Posts: 176

Rep: Reputation: 30
Wacom tablet for Suse Pro 9.2


I managed to get my Wacom Graphire tablet to be pretty much working for a couple days now. I thought it was all good but wasn't aware of a minor problem. For Windows, the tablet is pressure sensitive and is very accurate in terms of matching my hand pressure. With the tablet on Suse though, its able to used and all but there's no pressure sensitivity. I was wondering if there's a way to configure that because if there is, I have yet to find it. If anyone has already done this, please let me know because I'd like to get the tablet working correctly.
 
Old 11-17-2004, 11:57 AM   #2
maelstrom209
Member
 
Registered: Sep 2004
Location: The Imagination
Distribution: Suse 9.3 Professional
Posts: 176

Original Poster
Rep: Reputation: 30
In Suse 9.2 Pro there's an option for me to go configure the tablet. I configured it before but apparently the settings were not saved. So i went back and changed them again so now my tablet works better. The tablet is now able to detect pressure but I'm coming across another problem. The ratio of the tablet's active area is different than the screen that I have. I tried to configure the numbers so that it was stay in proportion but I find that the tablet's active area shifts around as I move the pen. The active area is supposed to remain static so it'd directly correspond to the screen. Does anyone have any idea about why the active area is shifting around?
 
Old 12-26-2004, 12:24 AM   #3
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Rep: Reputation: 15
sorry i dont have an answer for you. But i was wondering what setting you set and where it is for the pressure sensitivity. ill try to help you out with your question but im not sure what your asking. My pad is a 4x6 and seems to have to behaviour you are looking for. That is when i put the pen top right it moves the cursor to the top right on the screen. same with all other positions. Is that what your going for? Mine did that on the default from sax2. thanks and sorry i cant help you much.
 
Old 12-26-2004, 12:29 AM   #4
tardigrade
Member
 
Registered: Jun 2004
Distribution: SuSE 9.1
Posts: 150

Rep: Reputation: 15
i just looked up my XF86Config
Code:
Section "InputDevice"
  Driver       "wacom"
  Identifier   "Mouse[5]"
  Option       "AlwaysCore" "on"
  Option       "Device" "/dev/input/event3"
  Option       "InputFashion" "Tablet"
  Option       "Mode" "Absolute"
  Option       "Name" "GRAPHIRE / INTUOS (USB)"
  Option       "SendCoreEvents" "on"
  Option       "Tilt" "on"
  Option       "Type" "cursor"
  Option       "USB" "on"
  Option       "Vendor" "WACOM"
EndSection

Section "InputDevice"
  Driver       "wacom"
  Identifier   "Mouse[7]"
  Option       "Device" "/dev/input/event3"
  Option       "InputFashion" "Pen"
  Option       "Mode" "Absolute"
  Option       "Name" "GRAPHIRE / INTUOS Stylus (USB)"
  Option       "Protocol" "Auto"
  Option       "SendCoreEvents" "on"
  Option       "Tilt" "on"
  Option       "Type" "stylus"
  Option       "USB" "on"
  Option       "Vendor" "WACOM"
EndSection

Section "InputDevice"
  Driver       "wacom"
  Identifier   "Mouse[9]"
  Option       "Device" "/dev/input/event3"
  Option       "InputFashion" "Eraser"
  Option       "Mode" "Absolute"
  Option       "Name" "GRAPHIRE / INTUOS Eraser (USB)"
  Option       "Protocol" "Auto"
  Option       "SendCoreEvents" "on"
  Option       "Tilt" "on"
  Option       "Type" "eraser"
  Option       "USB" "on"
  Option       "Vendor" "WACOM"
EndSection
maybe the mode "absolute" line is what your looking for?
 
Old 12-26-2004, 12:32 AM   #5
jdblick
Member
 
Registered: Sep 2004
Distribution: SUSE 10.0 OSS
Posts: 261

Rep: Reputation: 30
In the sax2 screen it shows an input item. It had a mouse and keyboard as input devices and properties/configuration for them. I would definately look there.
 
Old 12-26-2004, 01:00 AM   #6
maelstrom209
Member
 
Registered: Sep 2004
Location: The Imagination
Distribution: Suse 9.3 Professional
Posts: 176

Original Poster
Rep: Reputation: 30
Thanks for your help. I thought this thread has been forgotten and lost amongst the numerous other threads out there. I managed to solve the problem but totally forgot to post how I did it. What I did in Yast was configure the input devices. For the Wacom tablet there are 2 settings that caught my eye, "Relative" and "Absolute." The correct choice is absolute. Mine was on "Relative" and everything was pretty much jacked up. On "Absolute" the active area stayed put and the pressure sensitive was working. I guess it was just a matter of setting the correct config settings. Thanks for all of your help though. I really appreciate it.
 
Old 06-22-2006, 08:18 AM   #7
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Rep: Reputation: 30
Pressure sensitivity

What are you configuration settings, maelstrom209?
I have SuSE 10.0 and my tablet does not have pressure sensitivity. It's one of the older Graphire 5X3.

Also, I have a new Intuos3 Tablet on my Windows computer that I would love to use for my SuSE computer but I'm not so sure of the settings. That one is 6X8
 
Old 06-25-2006, 01:22 AM   #8
maelstrom209
Member
 
Registered: Sep 2004
Location: The Imagination
Distribution: Suse 9.3 Professional
Posts: 176

Original Poster
Rep: Reputation: 30
I haven't gotten 10.0 but I think that they setup is generally the same. In YaST, there's a option to edit your peripherals. Within there there's settings for the tablet. From there you can setup the active area for your tablet. I did this for Graphire 3. I have since upgraded to Graphire 4 but haven't been using my tablet with a linux OS.

I hope that you is of some help for you. I'll be updating one of my boxes to Suse 10 and will be using a tablet on it. I'll let you know if what I try works.
 
Old 06-25-2006, 10:10 AM   #9
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Rep: Reputation: 30
Thanks very much, Yes! Let me know how it goes with you.
 
  


Reply

Tags
tablet, wacom


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WACOM Intuos.3 A5 tablet kxs Linux - Hardware 6 02-06-2007 02:49 PM
Configuring a Wacom Graphire Tablet to track like a tablet (not like a mouse) anlace Debian 2 11-07-2006 05:20 AM
wacom tablet and slackware 10 arubin Slackware 0 07-01-2004 05:23 PM
Wacom Tablet felicehome Linux - Hardware 2 06-21-2004 04:59 PM
Wacom Tablet and wacom drivers Mallow005 Linux - General 1 12-27-2002 02:26 AM


All times are GMT -5. The time now is 09:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration