LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   VNC Session (http://www.linuxquestions.org/questions/suse-novell-60/vnc-session-414109/)

mindjet 02-11-2006 06:34 AM

VNC Session
 
Hi,

I re-installed my OS and since this, the VNC remote desktop connections are very slow.

I am on a local LAN so it should be quick, and before i re-installed it was running much faster.

What have i done to make it slow down?

Thanks for your help.

bobbens 02-11-2006 07:22 AM

there was a real nice article on FSM a while back.

VNC makes it so you have to send less packets to get it working, if you also tunnel it through ssh ("ssh -C -x" iirc) youll then compress and decompress the packets on the fly and this can also speed it up more. Try looking for a guide on ssh tunneling a vnc server, or look for the FSM, i think it was last issue or the one before...

yapp 02-11-2006 09:25 AM

For a local lan, try disabling/lowerring the compression/encodings of your vnc client. When the network-link is really fast, the cpu-time is the next bottleneck.

Alternatively:
- try to look for X11-tunneling over SSH (ssh -C -X linux-host, then start the app from the command line),
- try to enable XDMCP and access your X11 server directly over the lan, run XNest -query linux-box to open the XDMCP login screen.
- try to use FreeNX to access the remote desktop.

mindjet 02-11-2006 10:25 AM

hi guys, thanks for the tips :)

Do you know how i can make the VNC server start "on boot" so i can connect for the logon?

At the moment SUSE only accepts the connection after i log in.
I want this box to only have 2 cables; Power & Ethernet.

Thanks again.

yapp 02-11-2006 10:49 AM

SuSE already has an option for that.. It's called "Remote administration" and it can be found in YaST->networking. This will run an Xvnc server "on-demand"; when you connect the the port, the vnc server will be stared. Note that you need to enable XDMCP for KDM too to make this work.


All times are GMT -5. The time now is 04:46 AM.