LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-14-2012, 09:43 PM   #1
Billgatus of Borg
Member
 
Registered: Sep 2005
Distribution: Open SUSE 12.2 x 64 KDE 4.8
Posts: 34

Rep: Reputation: 15
video resolution mode selection with Grub2 in OpenSUSE 12.2


i have just upgraded OpenSUSE from version 12.1 to 12.2. The only real issue is trying to set the resolution and color attributes for the system. Apparently Grub2 has very limited selection.

i use an old nVidia GeForce2 mx400 card. It is still sufficient for my use.

i've installed the legacy driver for that card

The attributes that i need are 1600 x 900 x 32 at 60 hz

However, that selection is not available in Grub2. Grub2 has set the attributes at 1280 x 1024 x 16 at 76 hz

Is there any way to get back my old resolution and still maintain Grub2?

i did notice that the kernal sets the command line parameter as:

Quote:
video=1600x900 resume=/dev/disk/by-id/ata-ST3120026A_4JT0ELZD-part2 splash=silent quiet showopts
i'm at a complete loss as to how i can possibly get my original resolution back. Frankly, i'm NOT really familiar with editing Grub and certainly not the Kernel.
 
Old 10-15-2012, 11:16 PM   #2
dru8274
Member
 
Registered: Oct 2011
Location: New Zealand
Distribution: Debian
Posts: 105

Rep: Reputation: 36
Quote:
Originally Posted by Billgatus of Borg View Post
The only real issue is trying to set the resolution and color attributes for the system. Apparently Grub2 has very limited selection.
The resolution used by Grub is set separately to the resolution used by your desktop. But if you're asking how to change your Grub resolution, then this answer may help.

Happy with ur solution... then tick "yes" and mark as Solved!

Last edited by dru8274; 10-15-2012 at 11:21 PM.
 
1 members found this post helpful.
Old 10-16-2012, 08:50 PM   #3
Billgatus of Borg
Member
 
Registered: Sep 2005
Distribution: Open SUSE 12.2 x 64 KDE 4.8
Posts: 34

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by dru8274 View Post
The resolution used by Grub is set separately to the resolution used by your desktop. But if you're asking how to change your Grub resolution, then this answer may help.

Happy with ur solution... then tick "yes" and mark as Solved!
Thank you for your response. The post was helpful. Apparently my OP was inaccurate. What i want to do is to change the resolution of my desktop back to 1600 x 900 with 32 bit color as it was with OpenSUSE 12.1. That mode is supported by both my monitor (Acer 20" LCD) and my graphics card. It is NOT supported by Grub2 according to the output of the vbeinfo command.

Is there any way i can configure that resolution and bypass Grub2's settings? It would probably have to be done by terminal.
 
Old 10-18-2012, 05:59 AM   #4
Billgatus of Borg
Member
 
Registered: Sep 2005
Distribution: Open SUSE 12.2 x 64 KDE 4.8
Posts: 34

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by dru8274 View Post
The resolution used by Grub is set separately to the resolution used by your desktop. But if you're asking how to change your Grub resolution, then this answer may help.

Happy with ur solution... then tick "yes" and mark as Solved!
It turns out that my problem wasn't with Grub2 at all.

It appears that i installed two different nVidia drivers for my card when i only needed one. There must have been some kind of conflict between the two drivers, and it caused the system to default to NV11 instead of NV15.

After removing the 'desktop' driver, and rebooting the system, my resolution, color attributes and monitor frequency returned to the original attributes.

Stay tuned to see if it continues to work.

Still, your post was very informative, and i can use that information in the future.
 
Old 10-18-2012, 08:00 PM   #5
dru8274
Member
 
Registered: Oct 2011
Location: New Zealand
Distribution: Debian
Posts: 105

Rep: Reputation: 36
Quote:
Originally Posted by Billgatus of Borg View Post
After removing the 'desktop' driver, and rebooting the system, my resolution, color attributes and monitor frequency returned to the original attributes.
Good to hear its worked out for you. But because you were using nvidia, I was loath to offer up further advice. But I did look up that video=1600x900 boot-code, and read from this here...
Quote:
video --> For KMS enabled cards. Applies to intel and ati cards (the radeon driver), where DVI-X/LVDS-X is the video output as shown by xrandr.
where KMS is kernel mode setting, some kernel feature that your old nvidia card may or may not support anyway.

Anyway, I'm glad its working now :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to solve “cannot display this video mode optimum resolution 1280 * 1024 60 Hz” allu john sudhakar Linux - Newbie 1 05-13-2011 07:25 AM
2: Digital input cannot display this video mode optimum resolution 1280x 1024 60HZ ConfigMan_08 Linux - Newbie 0 09-16-2009 02:50 PM
changing video resolution from text mode boogiebogdy Suse/Novell 1 10-18-2006 06:32 AM
Can't include video mode selection support into kernel push Slackware 1 05-06-2006 01:33 AM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration