LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 04-23-2005, 09:13 AM   #1
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Rep: Reputation: 30
Very huge problem...need help


When after selecting Linux from the GRUB menu, it loads up and I get the follwoing error on the lower-left hand side of the login screen:

Code:
Linux kernel: ACPI-0484: Warning: **Error getting cpuindex for acpiid 0X2
linux ifup: No configuration found for sit0
linux kernel: end_request: I/O error, dev fd0, sector 0
I cant boot into the KDE desktop. Yesterday is was going smoothly but this morning something went south. What could be the problem here.

The installation went smoothly, except I have this error message and I cant load the KDE desktop.... What do you think it might be?

OH!!!! and it seemed to automatically partitioned for me.....No manual intervention from my part...

I need a quick reply before I reinstall from scratch!!!

Last edited by wardialer; 04-23-2005 at 09:23 AM.
 
Old 04-23-2005, 10:17 AM   #2
linuxLuser
Member
 
Registered: Jan 2005
Distribution: Gentoo
Posts: 111

Rep: Reputation: 16
For now, we'll forget about the "warning" part of things (the first line).

sit0 device is a ipv4 --> ipv6 translation device of some sort. I don't use it and don't know much about it.
Because you're using suse, you should be able to use the yast command, navigate to the network configuration and set things up there. You should just use eth0 instead and see how that works (assuming you have a regular network configuration).

The fd0 error is for your floppy disk drive. Did you have a disk inserted at bootup?

To get your computer to boot up into KDE, you need to check the /etc/inittab file.
Search for the line that says
id:3:initdefault:
and change it to say
id:5:initdefault:
The 3 changes to a 5. If it's already 5, you have a different issue.

I suspect that your problems may run deeper than what I've told you. Since it's a fresh install, you might save yourself some time in reinstalling. If you get the same raw deal, check your CD/DVD image(s). If you downloaded an iso file, run an MD5 check on them. Make sure it's clean media. If it is, maybe you should start viewing the Suse forums. Maybe you're not the only one with the problem.
Hope that helps a little.

-- the dudeman
 
Old 04-23-2005, 10:47 AM   #3
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
I have reinstalled already.... Then I shut the PC off for like 15 seconds and powered it back on. No more issues. This all of a sudden happened overnight and I when I woke up this morning.. here is my output of inittab:

/etc/inittab
#
# Copyright (c) 1996-2002 SuSE Linux AG, Nuernberg, Germany. All rights reserved.
#
# Author: Florian La Roche, 1996
# Please send feedback to http://www.suse.de/feedback
#
# This is the main configuration file of /sbin/init, which
# is executed by the kernel on startup. It describes what
# scripts are used for the different run-levels.
#
# All scripts for runlevel changes are in /etc/init.d/.
#
# This file may be modified by SuSEconfig unless CHECK_INITTAB
# in /etc/sysconfig/suseconfig is set to "no"
#

# The default runlevel is defined here
id:5:initdefault:

# First script to be executed, if not booting in emergency (-b) mode
si::bootwait:/etc/init.d/boot

# /etc/init.d/rc takes care of runlevel handling
#
# runlevel 0 is System halt (Do not use this for initdefault!)
# runlevel 1 is Single user mode
# runlevel 2 is Local multiuser without remote network (e.g. NFS)
# runlevel 3 is Full multiuser with network
# runlevel 4 is Not used
# runlevel 5 is Full multiuser with network and xdm
# runlevel 6 is System reboot (Do not use this for initdefault!)
#
l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
#l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6

# what to do in single-user mode
ls:S:wait:/etc/init.d/rc S
~~:S:respawn:/sbin/sulogin

# what to do when CTRL-ALT-DEL is pressed
ca::ctrlaltdel:/sbin/shutdown -r -t 4 now

# special keyboard request (Alt-UpArrow)
# look into the kbd-0.90 docs for this
kb::kbrequest:/bin/echo "Keyboard Request -- edit /etc/inittab to let this work."

# what to do when power fails/returns
pf:owerwait:/etc/init.d/powerfail start
pn:owerfailnow:/etc/init.d/powerfail now
#pn:owerfail:/etc/init.d/powerfail now
po:owerokwait:/etc/init.d/powerfail stop

# for ARGO UPS
sh:12345owerfail:/sbin/shutdown -h now THE POWER IS FAILING

# getty-programs for the normal runlevels
# <id>:<runlevels>:<action>:<process>
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
1:2345:respawn:/sbin/mingetty --noclear tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6
#
#S0:12345:respawn:/sbin/agetty -L 9600 ttyS0 vt102

#
# Note: Do not use tty7 in runlevel 3, this virtual line
# is occupied by the programm xdm.
#

# This is for the package xdmsc, after installing and
# and configuration you should remove the comment character
# from the following line:
#7:3:respawn:+/etc/init.d/rx tty7


# modem getty.
# mo:235:respawn:/usr/sbin/mgetty -s 38400 modem

# fax getty (hylafax)
# mo:35:respawn:/usr/lib/fax/faxgetty /dev/modem

# vbox (voice box) getty
# I6:35:respawn:/usr/sbin/vboxgetty -d /dev/ttyI6
# I7:35:respawn:/usr/sbin/vboxgetty -d /dev/ttyI7

# end of /etc/inittab


Last edited by wardialer; 04-23-2005 at 10:51 AM.
 
Old 04-23-2005, 10:54 AM   #4
linuxLuser
Member
 
Registered: Jan 2005
Distribution: Gentoo
Posts: 111

Rep: Reputation: 16
Your inittab looks fine.

Good to hear it's all good "in da hood"

-- the real dave
 
Old 04-23-2005, 10:55 AM   #5
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Now wait!!!!! I will shut the system down for like 1 minute now and see what happens...

What do you think was the cause? Maybe I fiddled around with the services??
 
Old 04-23-2005, 11:31 AM   #6
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Ok, it seems to be fine now, but lets wait till next morning....shall we????

Maybe I did something in the Services list. I just DISABLED the Firewall and the NFS, thats all.

But one question here, in order to start KDE to load up much faster, how can I? I want to disable some Services the SAFER WAY....

Next, How can I make SUSE much more UNIX-like?
 
Old 04-24-2005, 02:29 PM   #7
youngtom
Member
 
Registered: Feb 2005
Location: Rio de Janerio
Distribution: suse 9.1, suse 9.2, redhat enterprise, ubuntu, kubuntu
Posts: 104

Rep: Reputation: 15
Quote:
Originally posted by wardialer
Next, How can I make SUSE much more UNIX-like?
You'll have to explain what UNIX-like means in order to get help on that one.
 
Old 04-24-2005, 02:47 PM   #8
linuxLuser
Member
 
Registered: Jan 2005
Distribution: Gentoo
Posts: 111

Rep: Reputation: 16
wardialer, about the KDE startup thing, it's very easy (as any KDE-integrated thing usually is).

Go to the "Control Center" (usually right under the K-Menu). Go to "KDE Components", and then "Service Manager". It should have listed KDE components that startup.

I hope that's what you mean

As far as the "more UNIX-like" thing, I guess a good ole' console workspace is about all I could recommend If you don't know this yet, you can hold down CTRL + ALT and press F1, F2, ..., F6 to get into a console (no GUI, just text). Log in and start using UNIX-like commands (use CTRL+ALT+F7 to get back to the GUI)
If you're talking about a GUI, well, you're probably talking about a different window manager than KDE (which is technically more than a window manager, it's a desktop environment, which includes a window manager).

You could also change the shell you use on the console to csh or something like that That would be more UNIX-like.

The only other thing I can think of is to maybe install a different UNIX-like kernel other than the Linux kernel, like HP-UX or Darwin or BSD...but then, it wouldn't be Linux anymore. Oh well. There's always fun to be had in Linux-Land!

-- the dudeman

Last edited by linuxLuser; 04-24-2005 at 02:59 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
a HUGE problem! please help... :( phead Linux - Newbie 3 09-30-2005 06:41 PM
Huge GRUB Problem TurboDan Linux - Newbie 6 08-25-2005 06:26 PM
Huge font problem jjswick Linux - Newbie 3 07-05-2005 08:24 AM
Huge Huge Problem With Forums!!! The_Insomniac Linux - General 1 06-07-2004 08:15 AM
Huge login problem!!! madhacker Linux - Newbie 2 07-20-2003 05:40 PM


All times are GMT -5. The time now is 10:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration