LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2011, 11:36 AM   #1
cbjhawks
Member
 
Registered: Oct 2001
Location: Overland Park, KS
Distribution: OpenSuSE 11.4
Posts: 363

Rep: Reputation: 30
Using OpenSuSE 11.3...how do I auto-mount my two optical drives?


I have a dvd-rom and dvdrw...within /etc/fstab there is no entry for either...the /mnt directory is empty. When I insert an audio disc a box pops up and I can choose to play with KSCD and all is well but when I put in a data disk (ie...Linux Format data) it shows up in My Computer/sysinfo but I get the error when I try to open it in a new window. (1) see below.

With previous versions of OpenSuSE once I inserted the Linux Format disk FireFox would open

(1) There is no app installed that can open file of this type block device(inode/block device)

Do I just have to create a directory/folder for each... /mnt/dvdrom /mnt/dvdrw ???


my /etc/fstab:

/dev/disk/by-id/ata-WDC_WD800AAJB-00J3A0_WD-WCAV33921011-part1 swap swap defaults 0 0
/dev/disk/by-id/ata-WDC_WD800AAJB-00J3A0_WD-WCAV33921011-part2 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-WDC_WD800AAJB-00J3A0_WD-WCAV33921011-part3 /home ext3 defaults 1 2
/dev/disk/by-id/ata-WDC_WD2000JB-00GVA0_WD-WCALL1072060-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD2500JB-00REA0_WD-WMANK1721192-part5 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
 
Old 03-21-2011, 09:21 AM   #2
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,677

Rep: Reputation: Disabled
SuSE mounts removable disks under /media. And that only after they are registered by the system (I don't like that either, but it can be changed).

Fastest it either clicking on the appropriate label in the dolphin "places" TAB -- or you activate a hardware supervisor (?) (or something called like that, I don't remember the exact name) as widget in the menu bar. It will pop up when you put in a disk and ask what you want to do (e.g. open with dolphin or K3b). Click anything and the disk will be mounted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with auto mount external hdd-drives. LuxLuv Linux - Server 4 03-18-2010 04:46 AM
How does OpenSuse 10.2 handle hot/auto mounting memory sticks/hard drives. mguiddy Suse/Novell 0 09-15-2007 02:33 AM
auto mount removable drives mallyooh Slackware 6 05-09-2006 10:39 PM
removable drives don't auto mount paintitmatt Ubuntu 2 04-15-2005 02:14 PM
using autofs to auto mount my usb drives DesertWolf0132 Slackware 8 07-30-2004 11:27 AM


All times are GMT -5. The time now is 01:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration