LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 05-21-2006, 03:27 AM   #1
baryonyx
LQ Newbie
 
Registered: Nov 2005
Posts: 8

Rep: Reputation: 0
USB thumb drive mounting as Read Only


Hi

I did a fresh install of Suse 10.1 today and it seems that any USB device I mount (ipod, thumb drive) gets mounted read only for me. As root I can read/write to the devices with no problem.

There aren't any entries in the fstab file for these devices so I'm at a loss of where to look to fix this problem. I checked the available groups and there is no usb group.

Any advice would be appreciated.
 
Old 05-22-2006, 01:17 AM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
Well, add an entry to fstab.. Something like
/dev/sda1 /mnt/flash vfat noexec,fmask=133,dmask=022,user,noauto 0 0
(my entry)
 
Old 05-24-2006, 10:54 PM   #3
baryonyx
LQ Newbie
 
Registered: Nov 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for the suggestion but when I add line to the fstab file and plug the drive in I get the following error:

Operation Failed:
/dev/sdb1 found in fstab

Incidently, when the device is mounted it shows like this:

/dev/sdb1 on /media/disk type vfat (rw,nosuid,nodev)

Any other suggestions would be appreciated.
 
Old 05-25-2006, 01:57 AM   #4
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
And if you mount it as user? Does it belong to you? Also try fmask=111,dmask=000 , though this is unsafe.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting a thumb drive lucky6969b Linux - General 10 02-16-2006 11:52 PM
USB thumb drive detected by usb but not by scsi ashlock Linux - Hardware 6 06-02-2005 03:58 PM
USB drive using different partitions (usb key thumb drive) Arodef Linux - Hardware 0 08-04-2004 07:36 PM
USB thumb drive works great, but I still can't get my USB mouse to work. blk96gt Slackware 8 06-22-2004 02:52 AM
Mounting USB Thumb Drive Issues xm0b31 Linux - Hardware 2 04-27-2004 07:04 PM


All times are GMT -5. The time now is 04:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration