LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-24-2006, 03:57 PM   #1
litlmary
Member
 
Registered: May 2005
Location: Texas, somewhere near Houston (I think)
Distribution: See my sig
Posts: 301

Rep: Reputation: 30
USB Pen Drive no automount in Suse 10.0


My Lexar Jumpdrive will not automount like it used to. I'm not sure exactly when it stopped working because I haven't been using the pen drive much lately, but I need to start using it again. FWIW, it is a dual boot machine and the pen drive still works fine in XP.

I can connect a Canon digital camera to the same port (the only port on my IBM TP A22m) and I get 2 windows pop up:

"USB Imaging Interface - KDE Daemon" with options to open in a new window, browse with gwenview, open in digikam, or do nothing. Its very reminiscent of XP, actually. If I select open in a new window, it mounts the camera to system:/media/camera and I can browse it with konqueror. It works perfectly.

"SUSE Hardware Detection" gives me the option to open the camera at the path camera://USB PTP Class Camera@[usb:001,004]/ .

Either way, the camera gets mounted and I can browse it just fine (or I can play with it in Digikam or whatever). It all works good.

So what gives with my pen drive?

I can mount it from the command line manually if I want, after I figure out whether it is currently sda or sdb (with only the 1 device in the 1 usb port?). Of course, then it is read-only to everyone but root. I don't want to be having to mount and umount it manually every time I use it, though. I like Suse because of its user-friendliness and excellent collection of GUI tools.

I have also tinkered with fstab a little bit, but that doesn't work well because it isn't always the same device, especially when I use a hub. I also never got read-write privileges for normal users that way.

The Yast runlevel editor reports that autofs does not start automatically (at any runlevel). If I try to enable it at runlevel 5 or start it manually I get the message:

Code:
/etc/init.d/autofs start returned 6 (program is not configured):
Starting service automounter ("files nis" does not provide any mounts)..skipped
USB Viewer reports:

Code:
JUMPDRIVE SECURE
Manufacturer: LEXAR MEDIA
Serial Number: 106A6607165815071104
Speed: 12Mb/s (full)
USB Version:  2.00
Device Class: 00(>ifc )
Device Subclass: 00
Device Protocol: 00
Maximum Default Endpoint Size: 64
Number of Configurations: 1
Vendor Id: 05dc
Product Id: a400
Revision Number: 30.00

Config Number: 1
	Number of Interfaces: 1
	Attributes: 80
	MaxPower Needed: 100mA

	Interface Number: 0
		Name: usb-storage
		Alternate Number: 0
		Class: 08(stor.) 
		Sub Class: 6
		Protocol: 50
		Number of Endpoints: 2

			Endpoint Address: 81
			Direction: in
			Attribute: 2
			Type: Bulk
			Max Packet Size: 64
			Interval: 0ms

			Endpoint Address: 02
			Direction: out
			Attribute: 2
			Type: Bulk
			Max Packet Size: 64
			Interval: 0ms
Like I said, it used to work perfectly. Any hints on how I can get it back?

TIA,

J
 
Old 05-25-2006, 09:29 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
There could be various reasons why it doesn't work:

- autofs has nothing to do with this. Automouting is performed by subfs/submount in SUSE.
- check the config files of suseplugger and the KDE automounter (both in ~/.kde/share/config) if you may defined a default behavior for this device. Sorry, but I am not at Linux right now, so I can't provide the names.
- check 'dmesg' after you plugged the device in for error messages
- did you install any hal related updates recently? Maybe you need to revert the update or look for even newer ones.
- in case you don't get automount to work, you may mount through /etc/fstab. The varying device files are not easy to fix, but the read-only problem is easy: add the option umask=000 to /etc/fstab and get write permissions for the mountpoints (chmod/chown).

Here's another thread that dealt with this problem: http://www.linuxquestions.org/questi...d.php?t=433671

Last edited by abisko00; 05-25-2006 at 09:41 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Usb Pen Drive vivekthemind Linux - Hardware 4 09-30-2005 05:09 AM
Fedora Core 3 / USB Pen Drive Automount clickster Fedora 2 12-31-2004 06:16 AM
USB Pen Drive fuoi2 Linux - Newbie 10 09-08-2004 08:03 AM
USB Pen Drive on 2.6.x LST Linux - Hardware 1 05-02-2004 10:25 PM
USB Pen Drive rlculver Linux - Hardware 1 11-08-2003 09:30 AM


All times are GMT -5. The time now is 06:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration