LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-27-2004, 08:21 PM   #1
DAChristen29
Member
 
Registered: Dec 2002
Location: Johnstown, Co
Distribution: Mint (debian edition)
Posts: 541

Rep: Reputation: 30
USB drive not showing up


whenever i plugged in my usb drive, the little icon used to show up in the "my computer" icom or on the desktop. for some reason, its not showing up anymore, and to mount the drive i have to manually do to /media and do a "mount /media/flash". how do i fix it so it shows up in my computer and automounts when plugged in?
 
Old 10-27-2004, 09:09 PM   #2
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
Go in turtorials

Go in the tutorials / hardware section and look up the guide I wrote recently about external USB and firewire drives. It covers pretty much the whole thing and there is a link to a very quick no nonsense guide to the config file fstab.

Your automounting is done in that file. That is where you have to modify your entries.

Also, I had a similar problem not to long ago with my ext. drive and I found ou after much fiddling around that it had simply been partly disconnected when I had moved my case for maintenance. The little firewire plug just moved a little bit and the connection was lost. I had to plug it in firmly and reboot for it to get detected again.

Personnaly I don't automount external drives because they are a bit less reliable. USB an firewire services don't always get loaded when needed during the Linux boot sequence and so external drives don't alway get detected properly. (Actually this was much worse in Windows than it is in Linux, hahahaha!)

I just mount them after boot manually and I reboot so rarely that my automatic backups have no problems executing themselves. If I forget one time it's no big deal and my backup scipt (Witch I wrote myself) warns me that It could not write to the disk, so I get reminded to mount it.
 
Old 10-28-2004, 12:52 PM   #3
DAChristen29
Member
 
Registered: Dec 2002
Location: Johnstown, Co
Distribution: Mint (debian edition)
Posts: 541

Original Poster
Rep: Reputation: 30
its a usb flash drive, not an actual hard drive. should that make a difference?


---edit---
i read the tutorial. no icon appears on my desktop, so i basically have to manually browse to the location in konqueror.

Last edited by DAChristen29; 10-28-2004 at 04:49 PM.
 
Old 10-28-2004, 04:50 PM   #4
El Basto
Member
 
Registered: Jun 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.2, Slackware
Posts: 76

Rep: Reputation: 15
I got tired of messing with automount. I just disabled it and mount the flash drive manually every time I want to use it.
Put this in your /etc/fstab
Code:
# Use if USB flash drive is connected
/dev/sda1            /home/userName/flash      auto       noauto,user,rw,exec,sync,gid=users,umask=0002 0 0
Then when you want to use it, as root type mount /dev/sda1

It's a little more of a hassle, but I find it more reliable.

And don't forget to unmount before removal... umount /dev/sda1
 
Old 10-28-2004, 05:14 PM   #5
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
I agree

This approach is more reliable.

But me , I have an icon on my desktop linked to the external drive device and I just right click and choose "mount".
 
Old 10-28-2004, 06:32 PM   #6
El Basto
Member
 
Registered: Jun 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.2, Slackware
Posts: 76

Rep: Reputation: 15
Oh wow, I never thought about that.

Geez, that was too easy.

Thanks for the tip!
 
Old 10-29-2004, 09:59 AM   #7
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
Quote:
Originally posted by El Basto
I got tired of messing with automount. I just disabled it and mount the flash drive manually every time I want to use it.
Put this in your /etc/fstab
Code:
# Use if USB flash drive is connected
/dev/sda1            /home/userName/flash      auto       noauto,user,rw,exec,sync,gid=users,umask=0002 0 0
Then when you want to use it, as root type mount /dev/sda1

It's a little more of a hassle, but I find it more reliable.

And don't forget to unmount before removal... umount /dev/sda1

But can you ACCESS this drive as a USER rather than ROOT --- Mine will only let me access the drive as ROOT and even as ROOT I can't change the permissions ????? (SUSE 9.1) -- and if you disable hotplug it won't work at all (/dev/sda1 is NOT a block device)

(My device is an actual USB external 250GB maxtor HD drive with an NTFS file system on it).

Thanks

Last edited by 1kyle; 10-29-2004 at 10:00 AM.
 
Old 10-29-2004, 12:24 PM   #8
El Basto
Member
 
Registered: Jun 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.2, Slackware
Posts: 76

Rep: Reputation: 15
If you want to mount it manually ( mount /dev/sda1 ) then you have to be root. But if you create a device on your desktop as Steel_J suggested, when you RightClick => mount it will mount it to the directory specified in /etc/fstab, and will allow normal users to access it. (assuming you have fstab set up the way I showed)
 
Old 10-29-2004, 11:58 PM   #9
DAChristen29
Member
 
Registered: Dec 2002
Location: Johnstown, Co
Distribution: Mint (debian edition)
Posts: 541

Original Poster
Rep: Reputation: 30
i found the problem. in KDE< i had to go to the dekstop settings, clikc on "device icons" tab, and there's some checkboxes by umounted/mounted Hard drive partitions and drives. the USB drive was unchecked, which is strange, because when i first booted up, i remember checking all of those options.
 
Old 10-30-2004, 02:04 AM   #10
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
Well there you go..but...

...this is specific to your Linux distribution.

On mine it is not needed.

But you can be sure I will keep it in mind for future troubleshootings.

Thanks for reporting your solution. So many people post asking help but never bother to tell us when they find the solution.
 
Old 10-30-2004, 01:09 PM   #11
DAChristen29
Member
 
Registered: Dec 2002
Location: Johnstown, Co
Distribution: Mint (debian edition)
Posts: 541

Original Poster
Rep: Reputation: 30
yeah, if any one of my posts goes unsolved, its because i havent found a solution, or nobody else bothers to reply. i try to give something back to the LQ community. this is a place for help.

i found this is neede for slackware 10 but not mandrake 10. i think kde should have those checkboxes on by default. its also a problem in suse 9.0, because i always plugged in my drive and nothing shoed up, yet it was mounted in /media/flash, but no desktop icon.
 
Old 10-30-2004, 10:02 PM   #12
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
Ya and..

..I also found out that Hotplug is not on by default in Mandrake 10. You have to go in Services to enable it on boot.

Checked it because of your post so it serves us both.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
External hard drive not showing up? newtwolinux Linux - Newbie 3 05-16-2005 10:49 AM
250GB drive only showing 127GB tbartolucci Linux - Hardware 1 08-17-2004 09:31 AM
hard drive not showing h0p3sf411 Mandriva 13 03-15-2004 02:23 PM
Files not showing up in mounted drive JCDenton Linux - Newbie 9 08-01-2003 11:17 PM
20G hard drive only showing up as 4G... BrianK Linux - Hardware 10 01-27-2003 07:14 PM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration