LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 08-09-2006, 09:30 PM   #1
Balarabay1
Member
 
Registered: Feb 2006
Location: Florida
Distribution: SUSE 11.0/x86 KDE
Posts: 334

Rep: Reputation: 30
Updated Network Manager - Now Firefox stuck in OFFLINE MODE!


I tell ya, it does not pay to upgrade packages on your system when it is working good. I upgraded Network Manager with Smart, now whenever Firefox starts up, Its set in Offline mode. How do you permanently get it off that mode? I can click on the offline mode, then Firefox works, but next time I boot up, or restart Firefox, It goes right back to Offline Mode! I'd put bac the version I had, but when I go to Yast Software Management, it does not show it as being available. Can't win! Thanks for any/all help.
 
Old 08-10-2006, 02:37 PM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
This is just a wild guess, but have a look at the firefox config (type "about:config" in the URL line), then search for an entry called "network.online" and try to set it to true if this is not the case. Then restart. Good luck!
 
1 members found this post helpful.
Old 08-11-2006, 12:45 AM   #3
Balarabay1
Member
 
Registered: Feb 2006
Location: Florida
Distribution: SUSE 11.0/x86 KDE
Posts: 334

Original Poster
Rep: Reputation: 30
I tried it.....no luck...:-(

I got rid of Network Manager...LOL..Now everything is back to normal.
 
Old 08-11-2006, 01:31 PM   #4
osbie
Member
 
Registered: Jul 2004
Location: Los Angeles (the Great Cultural Wasteland)
Distribution: SuSe 10.2
Posts: 151

Rep: Reputation: 30
Wow! I'd get rid of FF before Knetworkmanager! Just import bookmarks into Opera. call it a day.
 
Old 11-05-2008, 06:28 PM   #5
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
Quote:
Originally Posted by osbie View Post
Wow! I'd get rid of FF before Knetworkmanager! Just import bookmarks into Opera. call it a day.
That isn't what the request for help was.

I had the same problem with FF. Removing NM fixed the problem also and since NM also broke my network removing it was a better option.

Kent
 
Old 02-04-2009, 06:02 PM   #6
NVRAM
LQ Newbie
 
Registered: Oct 2004
Location: Western USA
Distribution: Fedora,Suse,Redhat,Puppy,etc.
Posts: 13

Rep: Reputation: 1
Or see: http://kb.mozillazine.org/Toolkit.ne...anager.disable

In short, use about:config to set toolkit.networkmanager.disable to true, it should disable FF's dependency on NM.
 
Old 03-25-2009, 03:38 PM   #7
tinymark
LQ Newbie
 
Registered: Mar 2009
Posts: 8

Rep: Reputation: 0
I just open a terminal and type "service NetworkManager restart". It works for me.
 
Old 03-25-2009, 05:18 PM   #8
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
You guys are replying to a three year old thread
 
Old 03-25-2009, 07:23 PM   #9
NVRAM
LQ Newbie
 
Registered: Oct 2004
Location: Western USA
Distribution: Fedora,Suse,Redhat,Puppy,etc.
Posts: 13

Rep: Reputation: 1
Quote:
Originally Posted by BruceCadieux View Post
You guys are replying to a three year old thread
So are you :-)

I wasn't posting for the OP but for others who end up here like I did.

I tried searching multiple times for a solution, and found about 20 threads on various forums with the same problem but no solution (for my situation). When I did find this info, I decided to add it here.
 
Old 05-11-2009, 02:27 PM   #10
raywood
LQ Newbie
 
Registered: May 2009
Posts: 3

Rep: Reputation: 0
Just because a post is three years old doesn't mean it's no longer able to screw things up.

I tried the advice, "just open a terminal and type 'service NetworkManager restart'." This made matters worse. Not only am I in offline mode, but I can't get back into online mode. The File > Work Offline option is no longer checked, and regardless of whether I check it or not, Firefox says it is still in offline mode. Now what?
 
Old 05-12-2009, 06:28 PM   #11
raywood
LQ Newbie
 
Registered: May 2009
Posts: 3

Rep: Reputation: 0
Yoo-hoo!

Any ideas?
 
Old 05-13-2009, 08:21 PM   #12
tinymark
LQ Newbie
 
Registered: Mar 2009
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by raywood View Post
Any ideas?
Since I posted I have changed the way I do the restart. I restart network first (service network restart) and follow it with a restart of the NetworkManager (service NetworkManager restart). My o/s is Fedora 10.
 
Old 05-14-2009, 08:42 PM   #13
raywood
LQ Newbie
 
Registered: May 2009
Posts: 3

Rep: Reputation: 0
Talking

Problem went away when I did this:

http://ubuntuforums.org/showpost.php...5&postcount=17
 
Old 10-25-2010, 10:38 AM   #14
R. Douglas Barberi
LQ Newbie
 
Registered: Oct 2010
Distribution: Ubuntu Lucid
Posts: 2

Rep: Reputation: 0
Thank you!

I am SO happy you guys did reply to this old thread!

Going to about:config and setting toolkit.networkmanager.disable to true worked for me. I have Network Manager disabled on my Lucid Ubuntu system--I have everything set in /etc/network/interfaces (you know, the old-school way). The nm icon sits in my tray with a red [X] in it. Go figure.

Thanks again guys!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox 1.5 always loads in 'Work offline' mode giffbd Linux - Software 7 12-13-2010 09:13 PM
mozilla-firefox offline bong.mau Linux - General 2 06-09-2006 09:43 AM
Fedora core 2.6.10.1.771_FC2 updated kernel gets stuck at boot! spaceman27 Linux - Newbie 8 04-14-2005 10:47 PM
Fedora core 2.6.10.1.771_FC2. updated kernel gets stuck at boot spaceman27 Linux - Newbie 1 04-06-2005 04:15 PM
updated Fedora core 2.6.10.1.771_FC2. gets stuck at boot! spaceman27 Linux - General 1 04-06-2005 05:23 AM


All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration