LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 07-28-2006, 04:24 AM   #1
AGazzaz
Member
 
Registered: Nov 2005
Location: Egypt
Distribution: Fedora 17 KDE
Posts: 381

Rep: Reputation: 31
Unlock mounted NTFS partitions


long ago i have installed suse 10.0 eval on a hard disk which consists of 4 fat32 partitions and 1 NTFS portition every thing went so easy as it never happened before

2 weeks ago i was installing the same linux from the same CDS on another computer but 4 NTFS partitions and 1 Fat32 partition i had the fat drive mounted and the rest Locked and i can not access them except as root from console or konquerer super user mode

i get the message
Code:
You do not have enough permissions to read file:///windows/C
i have tried to change the permisions on these mounted folder but no luck

i know that this issue has been discussed before several times BUT no one has said he solved it
probably switched to another distro as i was going to do or already did with fedora
 
Old 07-28-2006, 05:37 AM   #2
erikvdh
LQ Newbie
 
Registered: Jul 2006
Posts: 8

Rep: Reputation: 0
how does the entry in /etc/fstab look like?

something like that:

"/dev/hda1 /nt ntfs ro,noauto 0 0" ?
 
Old 07-28-2006, 07:32 AM   #3
AGazzaz
Member
 
Registered: Nov 2005
Location: Egypt
Distribution: Fedora 17 KDE
Posts: 381

Original Poster
Rep: Reputation: 31
The content of the fstab file
Code:
/dev/hda10           /                    reiserfs   acl,user_xattr        1 1
/dev/hda9            swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/cdrom           /media/cdrom         subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
none                 /subdomain       subdomainfs noauto         0 0
/dev/cdrom2          /media/cdrom2        subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hda8            /windows/g           vfat       defaults              0 0
/dev/hda1            /windows/C           ntfs       defaults              0 0
/dev/hda10           /                    reiserfs   acl,user_xattr        1 1
/dev/hda9            swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/cdrom           /media/cdrom         subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
none                 /subdomain       subdomainfs noauto         0 0
/dev/cdrom2          /media/cdrom2        subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hda8            /windows/g           vfat       defaults              0 0
/dev/hda1            /windows/C           ntfs       defaults              0 0
I hope it helps
 
Old 07-28-2006, 08:11 AM   #4
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
As root
$ cd /windows

Now change the mount point C permissions to dr-xr-xr-x using chmod or konqueror or nautilus...
Change this permissions BEFORE mounting "C" drive.

Last edited by biophysics; 07-28-2006 at 08:13 AM.
 
Old 07-30-2006, 07:13 AM   #5
AGazzaz
Member
 
Registered: Nov 2005
Location: Egypt
Distribution: Fedora 17 KDE
Posts: 381

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by biophysics
As root
$ cd /windows

Now change the mount point C permissions to dr-xr-xr-x using chmod or konqueror or nautilus...
Change this permissions BEFORE mounting "C" drive.
i am sorry for the late feedback
but i can not do as you told me
actually i do not know what to do

the permissions in for the windows folder http://www.boomspeed.com/darkknight/snapshot3.jpg

would you please tell me what to change
 
Old 07-31-2006, 10:06 AM   #6
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
1. Un mount C and G if you have mounted it as root. Un mount it now.
2. The fstab that you have pasted in the first post contains everything in double. Please delete the second occurance of all entries in fstab
3. In the "darknight/snapshot3.jpg" enable (tick mark) - "Apply changes to all subfolders and their contents" - Put Tick mark
3. Change the last two lines of your /etc/fstab to the following
Code:
/dev/hda1            /windows/C           ntfs       noauto,ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda8            /windows/g           vfat       noauto,users,rw,umask=0 0 0 0 0
4. Please double check if you want to use "g" drive or "G" drive. Since you are using "C" drive I recommend you follow one standard - namely - "G" drive
5. now reboot the machine
6. As NORMAL user you can type $ mount /windows/C ...
7. Please report if it is working

Last edited by biophysics; 07-31-2006 at 10:07 AM.
 
Old 07-31-2006, 03:04 PM   #7
AGazzaz
Member
 
Registered: Nov 2005
Location: Egypt
Distribution: Fedora 17 KDE
Posts: 381

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by biophysics
6. As NORMAL user you can type $ mount /windows/C ...
Code:
everybody@linux:/windows> mount ntfs /dev/hda1 windows/C
mount: only root can do that
everybody@linux:/windows> mount vfat /dev/hda8 windows/G
mount: only root can do that
thank you very much for your help it is mostly appreciated

i did not switch to root because you normal in capital letters to draw my attention and i did not want to mess any thing up so please tell me what to do now

btw i tried to create a folder in the /windows directory using mkdir and it did not work

another thing i would like to draw your attention to is (SuSE partitioner)

http://www.boomspeed.com/darkknight/snapshot5.jpg
[the font is terrible yes and i am trying to figure out why]
as i mentioned before this is my second suse and i mounted my drives from the partitioner
what is that astrick beside "windows/G" for example and is there a way that it can help as it helped in the past

thank you again for your help
 
Old 08-03-2006, 08:07 AM   #8
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
Code:
everybody@linux:/windows> mount ntfs /dev/hda1 windows/C
mount: only root can do that
everybody@linux:/windows> mount vfat /dev/hda8 windows/G
mount: only root can do that
1. It looks like you have not updated your /etc/fstab
2. can you post your /etc/fstab?
3. if you are NORMAL user then type only

$ mount /windows/G
$ mount /windows/C


You should NOT give any options except mount point.
If you are NORMAL user - Do not give any thing like "ntfs, /dev...." - these are invalid for normail user.


Quote:
i did not switch to root because you normal in capital letters to draw my attention and i did not want to mess any thing up so please tell me what to do now

btw i tried to create a folder in the /windows directory using mkdir and it did not work
do the directory creation C, G inside /windows as root. Afterwards, logout and YOU can mount it as normal user

Quote:
another thing i would like to draw your attention to is (SuSE partitioner)

http://www.boomspeed.com/darkknight/snapshot5.jpg
[the font is terrible yes and i am trying to figure out why]
as i mentioned before this is my second suse and i mounted my drives from the partitioner
what is that astrick beside "windows/G" for example and is there a way that it can help as it helped in the past
Dont touch partitions please...
 
Old 08-05-2006, 08:32 AM   #9
AGazzaz
Member
 
Registered: Nov 2005
Location: Egypt
Distribution: Fedora 17 KDE
Posts: 381

Original Poster
Rep: Reputation: 31
Thumbs up

Thank you very much biophysics
now I have my drives all mounted and running properly just by following the steps you provided

as for the fstab file
Code:
/dev/hda10           /                    reiserfs   acl,user_xattr        1 1
/dev/hda9            swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/cdrom           /media/cdrom         subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
none                 /subdomain       subdomainfs noauto         0 0
/dev/cdrom2          /media/cdrom2        subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hda1            /windows/C           ntfs       noauto,ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda5            /windows/D           ntfs       noauto,ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda6            /windows/E           ntfs       noauto,ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda7            /windows/F           ntfs       noauto,ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda8            /windows/G           vfat       noauto,users,rw,umask=0 0 0 0 0
just in case anybody needed it

thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 3 FC3 and mounted NTFS partitions rmflagg Fedora 9 12-22-2004 11:42 AM
unlock ntfs alaios Linux - General 2 10-22-2004 04:39 AM
partitions not mounted at boot jackren Debian 1 03-20-2004 07:59 PM
how to unlock mounted win-partition for normal users? fernandoo Linux - Newbie 1 10-29-2003 01:30 PM
Setting premissions for mounted ntfs partitions RHL 9 killer_bunny Linux - Newbie 1 10-22-2003 05:55 AM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration