LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-22-2009, 06:27 AM   #1
pointo1d
LQ Newbie
 
Registered: May 2008
Posts: 4

Rep: Reputation: 0
Undecided rpm package backward compatibility between 10.* & 11.*


Hi all,

Due to circumstances beyond my control, I'm stuck with a server installed with 10.3, but have a requirement to install an new (to the server) application that requires a newer version i.e. utilising LZMA compression, of the rpm package.

I'd like to think that the newer rpm tools could manage both bz2 and lzma compressed packages but, what I can't find anywhere is a statement of the backward compatibility, if any, of the newer package i.e. I'm worried that, if I upgrade the rpm package, I will no longer be able to install 'old', bz2 based packages containing the legacy application.

Any help &/or advice greatly appreciated.

TIA
 
Old 12-23-2009, 04:19 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
I'm just guessing that you're talking about OpenSuSE, judging by the changes, bzip2 is still supported but not the default compression method:


Quote:
+- switch payload default to lzma -2
...
-Requires: popt-devel zlib-devel bzip2 libbz2-devel
+Requires: popt-devel zlib-devel bzip2 libbz2-devel lzma-alpha-devel
Ref: http://lists.opensuse.org/opensuse-c.../msg01081.html

cheers
 
Old 12-25-2009, 01:19 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,678

Rep: Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546Reputation: 2546
The choices you have, are the two "lzma backported"
rpm 4.4.x SRC.RPMS for Suse 11 or 11.1

The src.rpm 4.7.1 from Suse 11.2 cannot be used :
( my opinion .. ( it compiles OK )) but too many
applications / inter dependencies depends on 4.4 .

I have tried for two days to rebuild the SRC Rpm's
.. or just compile 4.4's against (lib)lzma :
.. No luck on Suse 10.3 .
.....

Last edited by knudfl; 12-26-2009 at 11:01 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
backward compatibility in kernels + custom kernels + more queries mmp_3341 Linux - Kernel 1 04-12-2007 07:28 AM
drawbacks of backward compatibility in *NIX kloss General 2 01-22-2006 07:20 PM
Graphics, AGP and backward compatibility bigjohn Linux - Hardware 7 08-05-2005 05:17 AM
Cars, computers and backward compatibility vdemuth Linux - General 2 10-22-2004 11:23 AM
Backward compatibility lenucks General 4 06-27-2004 02:34 AM


All times are GMT -5. The time now is 05:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration