LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-22-2006, 02:46 PM   #1
sharkus
Member
 
Registered: Aug 2006
Distribution: openSUSE 10.3
Posts: 63

Rep: Reputation: 15
unable to turn off auto mounting feature


Hello, I am trying to write a program that will mount a USB mounted device into a set location using the system() command in C/C++. However, suse will automatically mount this device in /media/usbdisk1 or something along those lines. I already edited the fstab file. I also checked around for autofs and automount and found they are not even on the machine. Is there some way I can turn off this automount feature or circumvent it?
 
Old 08-22-2006, 03:26 PM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Which SUSE version?
9.3: http://en.opensuse.org/SDB:Conventio...stead_of_subfs
9.1: http://en.opensuse.org/SDB:9.1:_Conv...stead_of_subfs
10.0: In /usr/share/hal/fdi/policy/10osvendor, in all files change all lines with "should_mount" from "true" to "false"
or
Create /usr/share/hal/fdi/policy/20thirdparty/nomount_usb_disk.fdi with the following content:
Code:
<?xml version"1.0" encoding"ISO-8859-1"?> <!-- -*- SGML -*- -->
<!-- This .fdi file prevent automount for external harddisk. -->
<deviceinfo version"0.2">
<device>
<match key"storage.bus" string"usb">
<match key"storage.drive_type" string"disk">
<match key"storage.policy.should_mount" bool"true">
<merge key"storage.policy.should_mount" type"bool">false</merge>
</match>
</match>
</match>
</device>
</deviceinfo>
Haven't tried the 10.0 methods. These hints are from a german SUSE forum www.linux-club.de

Can't help with 10.1 (yet).
There might be an option to blacklist certain devices.

Last edited by abisko00; 08-22-2006 at 03:38 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to turn off auto mount in suse on embedded board sharkus Linux - Kernel 3 11-27-2007 11:24 AM
Problems with screen resolution, auto-mounting hda1, unable to save file meiya Debian 1 01-09-2006 09:57 AM
Unable to use the Lock-Screen feature Waerner Ubuntu 4 08-01-2005 04:02 PM
Auto-refresh feature ppuru LQ Suggestions & Feedback 1 08-12-2004 08:16 AM
turn off auto-login XDM eduac Linux - Software 2 12-24-2003 10:07 AM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration