LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-05-2005, 07:27 PM   #1
symb0lism
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Rep: Reputation: 0
unable to connect to internet


Hello,

I'm a linux newbie. After installing SuSE 9.2 Eval sucessfuly, I tried to connect to the internet with it. It does not allow me to do so. My computer dual-boots with windows XP and SuSE 9.2. I have a cable modem and a router. I'm not entirely sure I set the network card under YaST correctly.


Thanks.
 
Old 02-05-2005, 08:11 PM   #2
bruno buys
Senior Member
 
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
As root, do
ifconfig

This will tell you if you have an IP, and how suse calls your eth card, which most likely will be eth0.
If you donīt have an IP, try

ifup eth0
and see if it grabs an IP.

If you already have one, try to ping google (64.233.187.104)
First with the name:
ping www.google.com
If you can ping google by the name, you are set. If not, try with the IP:
ping 64.233.187.104

If you can ping google by the IP but not by the name, you need a DNS server set up.
Good luck, and keep us posted.
 
Old 02-05-2005, 08:52 PM   #3
symb0lism
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Original Poster
Rep: Reputation: 0
It says there is no configuration on eth0 or eth1, eth1 is where the ethernet card that I want to use is set on.
 
Old 02-05-2005, 09:30 PM   #4
HenchmenResourc
Member
 
Registered: Mar 2004
Location: SLC, Utah
Distribution: OpenSUSE 12.2
Posts: 246

Rep: Reputation: 30
Judging by your last response I'm guessing that you have two ethernet cards, if this is the case are they both built into your mtother board?

If they are they may be bridged (I think this is the right term) if thats the case you may have to use the one set as eth0 and not the one set as eth1.
 
Old 02-06-2005, 12:21 AM   #5
symb0lism
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Original Poster
Rep: Reputation: 0
how can I change it? THe motherboard one is defective and I've never been able to successfuly use it.

Thanks.

Last edited by symb0lism; 02-06-2005 at 01:19 PM.
 
Old 02-08-2005, 04:56 AM   #6
kingterr0r
Member
 
Registered: Aug 2004
Location: New York
Distribution: SuSE 9.1 Pro
Posts: 32

Rep: Reputation: 15
In the BIOS setup, make sure the the Onboard LAN Interface is enabled.
 
Old 02-08-2005, 11:39 PM   #7
symb0lism
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Got it working!

I actually had to turn OFF the onboard lan interface.
 
Old 02-09-2005, 06:56 AM   #8
kingterr0r
Member
 
Registered: Aug 2004
Location: New York
Distribution: SuSE 9.1 Pro
Posts: 32

Rep: Reputation: 15
Thats good, have fun now!
 
Old 06-17-2006, 07:24 AM   #9
shankarnarayan
LQ Newbie
 
Registered: Jun 2006
Posts: 1

Rep: Reputation: 0
unable to connect to internet throught linux suse

When connected to the browser it always displays unknown
host error. Please solve the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to connect to internet ashwin_cse Fedora 9 07-30-2007 10:39 AM
Unable to connect to the Internet Melanieb Linux - Newbie 1 08-15-2005 06:52 PM
Unable to connect to the internet bear2x Linux - Networking 6 07-22-2005 09:42 AM
unable to connect to internet cedar Linux - Networking 2 11-20-2004 04:20 PM
Unable to connect to the internet xxvm1 Mandriva 24 09-22-2004 09:59 PM


All times are GMT -5. The time now is 10:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration