LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 11-04-2004, 01:18 AM   #1
John Dory
LQ Newbie
 
Registered: Jul 2004
Location: Sydney, Australia
Distribution: Suse 10.1 KDE
Posts: 13

Rep: Reputation: 0
Touchpad mouse does not work after upgrading from SuSe9.1 to Suse 9.2


I have just done a fresh install of SuSe 9.2 on my Toshiba laptop. I previously had 9.1 installed.

One big problem I have is that the internal touchpad mouse no longer works. The mouse pointer jumps around the screen like crazy and seems to sit in the corners. Clicking the mouse seems to do nothing.

If I plug in an external USB mouse, the external mouse works perfectly, plug and play.

I've tried different "Mouse Models" in YAST. None seem to make any difference. In previous versions "PS2 mouse" seemed to work for the touchpad.

I've found mouse support varies between each release of SuSe. Suse 9.1 worked perfectly; I could switch between touchpad and USB mouse seamlessly. Releases before that had various problems but never this bad.

Anyone else had the same problem after upgrading to SuSe 9.2?

My setup:
Toshiba Satellite 2410
Suse 9.2.
 
Old 11-04-2004, 06:28 AM   #2
ratcheson
LQ Newbie
 
Registered: Jul 2004
Location: Texas
Distribution: suse9.3
Posts: 18

Rep: Reputation: 0
While I havent upgraded to 9.2, I had a similar problem upgrading kernels in 9.1. My solution was to go into level 3 with init 3,
and they type sax2 to get that started. From there I found the mouse and selected synaptics touchpad. Follow the instructions to save and exit then restart X and that was it.

When you first exit SAX the touchpad will still not be useable until you restart X.

Hope that gets you up.
ra
 
Old 11-05-2004, 01:55 AM   #3
John Dory
LQ Newbie
 
Registered: Jul 2004
Location: Sydney, Australia
Distribution: Suse 10.1 KDE
Posts: 13

Original Poster
Rep: Reputation: 0
No luck I'm afraid

Thanks for that. Unfortunately it doesn't seem to have changed the behaviour of the mouse.
I've tried your suggestion (synaptic touchpad) and also some of the other similar options. The touchpad behaves the same.

Interestingly, when I go back into Sax after restarting the X server and finding it doesn't work, the previous mouse setting is still there, rather than the new mouse I selected. So maybe I am doing something wrong while choosing my mouse in SAX.

It seems a bit odd that there are two different places to select the mouse type, Yast and Sax. What is the difference? Do both settings have to be correct?
 
Old 11-07-2004, 01:25 PM   #4
eurgain
LQ Newbie
 
Registered: Nov 2004
Location: North Wales, UK
Distribution: SUSE 9.2
Posts: 1

Rep: Reputation: 0
Hi, John

I also had problems with my touchpad on a Dell I8600 in 9,2 after its having been configured properly in previous S[Uu]SEs. Basically, they seem to have broken SaX, so you will have to exit /etc/X11/xorg.conf manually.

Here is what I came up with after digging around. Lost laptops use either touchpads made by Synaptics or Alps. These can operate in an emulation mode in which they emulate a standard PS/2 mouse. Alternatively, they operate in native mode, which allows them to provide special features such as button emulation and edge scrolling.

If the kernel driver in PS/2 mode, the user-space software (such as X) just thinks it is talking to a standard mouse on the PS/2 port, so no problems there. If the kernel driver is in native mode, the user-space side needs to know that it is talking to a touchpad.

In 9.2, what it seems to me has happened is that native mode has been enabled in the kernel, but SaX still specifies a PS/2 driver in X. Here is what worked for me.

1. Become root, and cd to /etc/X11
2. Make a copy of xorg.conf, so it it all goes fubar you can get back whence you came.
3. Use your favourite editor to edit xorg.conf and make the following changes:
a. In the section "Module" add a line:
Load "synaptics"
b. Add a whole new section, that looks like this:
Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[9]"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "120"
Option "RightEdge" "830"
Option "TopEdge" "120"
Option "BottomEdge" "650"
Option "FingerLow" "14"
Option "FingerHigh" "15"
Option "MaxTapTime" "180"
Option "MaxTapMove" "110"
Option "EmulateMidButtonTime" "75"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "20"
Option "MinSpeed" "0.2"
Option "MaxSpeed" "0.5"
Option "AccelFactor" "0.01"
Option "EdgeMotionMinSpeed" "15"
Option "EdgeMotionMaxSpeed" "15"
Option "UpDownScrolling" "1"
Option "CircularScrolling" "1"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
EndSection
c. In the "Server Layout" section, change
InputDevice "Mouse[1]" "CorePointer"
to
InputDevice "Mouse[9]" "CorePointer"
4. Re-start X.

Note that this works for the Alps touchpad. You will know if you have one of these if doing:
> dmesg | grep -i alps
gives some output.

If you have s Synaptics touchpad, the recommended default settings are:
Section "InputDevice"
Identifier "Mouse[9]"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.06"
Option "MaxSpeed" "0.12"
Option "AccelFactor" "0.0010"
Option "SHMConfig" "on"
# Option "Repeater" "/dev/ps2mouse"
EndSection

Of course, all of the options may need fine-tuning to your computer and personal preferences.

The main place to look for more information on the driver and its options is at
http://w1.894.telia.com/~u89404340/touchpad/
Download and unpack the source - you won't need to install it - it is already in place in 9.2, but you will find the README and INSTALL files explain the options in detail.

Once you have sorted your xorg.conf file, make a copy of it because SaX may overwrite it!

HTH
A

Last edited by eurgain; 11-07-2004 at 02:20 PM.
 
Old 11-11-2004, 12:22 AM   #5
John Dory
LQ Newbie
 
Registered: Jul 2004
Location: Sydney, Australia
Distribution: Suse 10.1 KDE
Posts: 13

Original Poster
Rep: Reputation: 0
No luck.

No luck. I edited a file called X86Org.conf or something similar that was symlinked to by xorg.conf.

When I restarted X, the USB mouse was not working at all and the touchpad still had the same problem.

I tried a couple of other things but then I couldn't get X to start at all. So I restored the old file.

There might be a typo in your post; the alps section starts like this:

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[9]"
Option "Device" "/dev/psaux"

whereas the synaptics section looks like this:

Section "InputDevice"
Identifier "Mouse[9]"
Driver "synaptics"
Option "Device" "/dev/psaux"

I have no idea if the different order makes any difference; I will check tonight.

Thanks.
 
Old 11-11-2004, 01:23 AM   #6
da_zombie
Member
 
Registered: Aug 2003
Location: timbuktou
Distribution: suse 9.1, Debian Sarge
Posts: 69

Rep: Reputation: 15
try by adding "psmouse.proto=imps" w/o quotes at the grub prompt prior boot...it works for me on suse 9.1 compaq/synaptics.
 
Old 11-15-2004, 08:41 PM   #7
possingk
LQ Newbie
 
Registered: Dec 2003
Location: Pennsylvania
Distribution: SUSE 9.1, 9.0
Posts: 4

Rep: Reputation: 0
eurgain,
Just wanted to thank you for your help. My wife and I were having troubles with our dell touchpads, and your fix did the trick. That is why using Linux is so great, the people who help.

Thanks again,
Keith Possinger
 
Old 12-09-2004, 12:06 AM   #8
standbypowerguy
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
Synaptics Touchpad & USB Mice in SuSE 9.2

Just upgraded my HP zd7000 laptop to SuSE 9.2. At first, the touchpad worked, but only in generic PS/2 mode, with no scroll bar support. Hardware detection recognized the wireless USB mouse attached to my port replicator, but it wouldn't work, even after Yast "configured" it. After editing the XF86Config file by hand, I've got both pointers working correctly. Here are snippets of the relevant sections for those who are interested:

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[0]"
Option "Device" "/dev/input/mice"
Option "Protocol" "imps/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[1]"
Option "Device" "/dev/psaux"
Option "Name" "SynPS/2 Synaptics TouchPad"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[0]" "AlwaysCore"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection
 
Old 12-13-2004, 11:51 PM   #9
rr1mand0
LQ Newbie
 
Registered: Dec 2004
Posts: 2

Rep: Reputation: 0
Hi John,
I'm experiencing the same problem on a Toshiba Satellite 2405. Have you been able to fix the problem yet? If so, would you mind posting what you did to get it to work (including the contents of your xorg.conf file). I've tried everything suggested here and the mouse still keeps dancing around on the screen.

Thanks
Raymund
 
Old 02-04-2005, 02:23 PM   #10
John Dory
LQ Newbie
 
Registered: Jul 2004
Location: Sydney, Australia
Distribution: Suse 10.1 KDE
Posts: 13

Original Poster
Rep: Reputation: 0
Finally got it working

Thanks to "da_zombie" for his solution. I simply had to add "psmouse.proto=imps" to the boot line.

To make this permanent, I backed up the file /boot/grub/menu.lst

Then in Yast, went to System->Boot loader configuration->Edit configuration files

and added the setting to the default boot configuration like this:

kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 vga=0x314 selinux=0 splash=silent resume=/dev/hda5 psmouse.proto=imps desktop elevator=as showopts

btw I am not a Linux expert, so I don't know how dangerous it is playing with this file!

Thanks to everyone who posted replies. I finally have my mouse working again!
 
Old 03-04-2005, 08:18 PM   #11
Lunar
Member
 
Registered: Feb 2005
Location: Texas, USA
Distribution: openSuSE
Posts: 76

Rep: Reputation: 3
alps touchpad crazy with suse 9.2 update

Thanks,
I too have been going nuts over this wild and crazy touchpad mouse pointer action. I literally had put my 9.0 (suse) DVD back in the drive when I found da_zombie's post. I was about to wipe out all my programs and config just to get rid of the 9.2 thouchpad problem... WOW..
I've tried all the other things I could find.. edit this, edit that, start in lev3 run sax2, edit some more...
This simple line of text saved me from a: blowing away my current install and b: throughing this laptop out the second floor window...LOL...

Thanks da_Zombie!
Thanks Linux Questions!
Landis.

<edit... 5 mins later>
p.s., when I went back to the laptop yast2 had found the alps hardware. It asked if I wanted to configure it. In config (yast) the mouse is still not listed.. Why have yast find the mouse if it is not going to have the dirvers? Just let sax handle it. Any ways. I chose not to save (aborted) and all is still fine.
Also, if we are having this problem you'ld (at least I) would think SuSe would fix it... guess not.
Thanks again.

Quote:
Originally posted by da_zombie
try by adding "psmouse.proto=imps" w/o quotes at the grub prompt prior boot...it works for me on suse 9.1 compaq/synaptics.

Last edited by Lunar; 03-04-2005 at 08:27 PM.
 
Old 06-08-2005, 12:58 AM   #12
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 210

Rep: Reputation: 31
Novell Desktop 9 has the same problem!!!

Thank you da_zombie!

I was about to give up trying Novell Linux Desktop 9 (NLD 9), until I found this post

Mine is not a laptop, its a standard midrange desktop that happens to have a USB mouse. I was sure that the XFree configuration was correct and it didn't work.

adding that psmouse.proto=imps made my day.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
touchpad/mouse won't work in X 2.4.26 kernel synaptics/gpm issue? dns21 Slackware 4 10-15-2004 01:34 AM
IBM laptop & touchpad & TrackPoint - touchpad doesn't work! espinosa_cz Linux - Laptop and Netbook 1 08-20-2004 01:45 PM
problems getting touchpad and usb mouse to work kierse Slackware 10 06-30-2004 11:37 PM
suse 8.2 laptop mouse and touchpad not working newbiedrake Linux - Hardware 0 06-16-2004 11:15 PM
Touchpad mouse doesn't work with Dell X300 ghostmagic Linux - Laptop and Netbook 1 12-27-2003 11:04 AM


All times are GMT -5. The time now is 01:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration