LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   thin (not small) font on firefox (http://www.linuxquestions.org/questions/suse-novell-60/thin-not-small-font-on-firefox-824722/)

dokie80 08-07-2010 01:37 AM

thin (not small) font on firefox
 
hi, I just recently move from win 7 to opensuse, and still new on linux.
just wondering if there is solution for thin font on firefox.
I already search google for solution, the best solution so far is to lower screen resolution to 1024x768 (I prefer 1280x800).
other tempt I tried are:
1. install freetype2, but the setting in "about:config" page on firefox aren't there. already try to create new boolean, but no effect at all.
2. install dejavu font and use it on firefox, but the font is still thin.
3. set minimum font size to 18. easier to read, but too big and messing up with website layout.

currently I'm using:
-dejavu font, minimum font size 18
-allow web to use own font (enable)

any help? thanks in advance
here's screenshot: http://img812.imageshack.us/img812/8015/snapshot1.png

bathory 08-07-2010 05:03 AM

Hi,

In about:config, search for layout.css.dpi and set it to 96 (or a bigger value than the one you have now) to see if it helps.
Re: freetype, try this:
Code:

font.FreeType2.autohinted  true
font.FreeType2.enable  true


dokie80 08-08-2010 02:08 AM

@bathory: thanks for the reply.
1. what's the different between changing the value of layout.css.dpi and changing font size in firefox preference? I try it, and it makes fonts become bigger like changing the font size.
2. is there any setting in firefox to use bold fonts?
3. about freetype, I already add the entry manually, and it makes no difference at all.

currently I install user style addon for firefox, and use custom css for reguler web that I visit, like google (include gmail etc.) and facebook, I did try global css like "midnite surfing". It helps alot, but not all website looks good though.

bathory 08-08-2010 04:18 AM

Hi,

1. Take a look here for a detailed explanation.
2. I guess you can use a custom css style.
3. FF uses freetype2 for truetype fonts

Regards

dokie80 08-08-2010 11:36 PM

okay, actually I already set dpi to 120 on kde.
I think I will stick with css style solution.
thanks for ur time and explanation bathory :)

yazz 10-21-2010 05:57 AM

Quote:

Originally Posted by dokie80 (Post 4060328)
okay, actually I already set dpi to 120 on kde.
I think I will stick with css style solution.
thanks for ur time and explanation bathory :)

Okay, here is a method for firefox, its called "nosquint", addon you would have guessed it. It has worked for me and i think it would help you also. I think your problem has been solved now but still i would like to pinpoint this addon for short troubleshooting;

NoSquint allows you to adjust the text-only and full-page (both text and images) zoom levels as well as color settings both globally (for all sites) and per site. (copy-paste, sorry)
link:
https://addons.mozilla.org/en-US/firefox/addon/2592/


All times are GMT -5. The time now is 02:46 AM.