LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   System hang during installation/using the "shift" key how do you enable 64bit (http://www.linuxquestions.org/questions/suse-novell-60/system-hang-during-installation-using-the-shift-key-how-do-you-enable-64bit-266361/)

ZoZa 12-14-2004 01:37 PM

System hang during installation/using the "shift" key how do you enable 64bit
 
My system hangs during installation using SuSE 9.2 Pro. Looking through the SuSE website I discovered that pressing the shift key during bootup would work around this problem (some sort of hardware detection issue). This works and I am enable to install SuSE.

Now my problem; it only will install the 32bit version, and not the 64bit version that I want. I have searched but have yet discovered a way to manually enable the 64bit version. Does anyone know of how this is done?

Any suggestions would be greatly appreaciated.

jschiwal 12-15-2004 03:44 AM

I installed SuSE 9.1 Pro AMD64 version on my laptop. The 64 bit version is on the flip side of the DVD disk. You need the install disk that contains the 64 bit rpms.
Perhaps I misunderstood your question, and you just couldn't get the 64 bit install loading, in which case, perhaps more details on how it failed would be needed.

ZoZa 12-15-2004 11:28 AM

Sorry for being too curt in my post. Here is a more detailed discription of my situation.

SuSE 9.2 Pro does not come in seperate 32bit and 64bit DVDs (or sides of a DVD). It comes as a single set of single-sided DVDs (installation DVD + sources) that contain both the 32bit and 64bit versions. Normally the installation process detects your hardware and installs the most appropriate version.

During my normal installation the system hangs just after the kernel gets loaded (which is just after selecting to install linux).

Looking through the SuSE support database I came upon the following work around:

"Keep the Shift key pressed while booting. In this way, the rudimentary hardware detection of syslinux (the boot loader used on the CD/DVD) is suppressed."

Now I am able to complete the installation process manually, but it will only install the 32bit version of SuSE 9.2. I am not sure how to manually install the 64bit version of SuSE. Does anyone know of what option to pass during booting or something I can do (like make a new DVD with only the 64bit version)?

jschiwal 12-17-2004 05:17 AM

Is there any indication on why the installation program hangs.

The solution will probably involve entering a kernel boot parameter, such as 'noacpi', however I don't know which parameter you would need to use. Try googling for
'boot parameter suse 9.2' and add your computer model. Perhaps a web page will come up giving a parameter you could try.


All times are GMT -5. The time now is 08:22 PM.