LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Synaptics / touch pad typing with random cursor jumps --solution (http://www.linuxquestions.org/questions/suse-novell-60/synaptics-touch-pad-typing-with-random-cursor-jumps-solution-630461/)

1kyle 03-25-2008 07:54 AM

Synaptics / touch pad typing with random cursor jumps --solution
 
Hi all
Sometimes on some laptops when typing the cursor seems to have a mind of its own and jumps all over the place making your text input garbled.

This is often most noticeable when replying to or posting to Forums.

The simplest way to stop this is after your GUI starts is to start a little daemon in the background. You need to start the command as ROOT and only AFTER you are in KDE (or other GUI).

syndaemon -t -d

This will start the daemon in the background so you can exit the console.
What this does is disable the touchpad whilst you are typing and also prevent random scrolling etc.

Not all laptops have this behaviour but a lot do.

I'm surprised that people haven't had this problem before as googling didn't show up much / if any info on this and I can definitely say that this has happened to me on at least 5 different laptops.

I usually use a mouse even when on a laptop as I don't normally (or in fact HATE) using the touchpad so it might be the problem only occurs when a mouse is also plugged in.

Hopefully this will help some people from what can be a really irritating problem.

Cheers

-K


All times are GMT -5. The time now is 02:59 PM.