LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 04-19-2006, 09:40 PM   #1
cmtishler
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Rep: Reputation: 0
SUSE will not recognize any USB or FIREWIRE external HDD's or WiFi card...


Hello all,

I first would like to inform everyone that I am VERY new to SuSE Linux and Linux all together.. I am on day 3 of trying to get my wireless usb network adapter to work, failing miserably because of a suspected USB/Firewire issue?? I already installed ndiswrapper and all and installed all drivers but get the listing of the driver and says invalid driver! next to the driver version when typing in ndiswrapper -l.... The reason I came to this side is because whenever I plug in an external hard driver via USB or Firewire suse does nothing... Does not mount or display in computer or anything... The wierd part is that I have a USB Wireless mouse, Keyboard and Bluetooth dongle and they all work fine... so it's just the USB Wireless net adapter and external hard drives that are not working for some reason.... Here is a run down of the guts of my box:

MSI MS-6728 Motherboard P4
P4 3.4ghz HT processor
Intel 865PE Chipset
Nvidia 6800GT 256MB AGP 8x graphics card
2gb Pc3200 400mhz ram
1 S-ATA 200gb HDD Internal (maxtor)
1 ATA/133 160gb HDD Internal(maxtor)
1 USB/Firewire external hdd 80 GB
Audigy 2 ZS Platinum Pro Sound card
8 USB 2.0 ports
2 Firewire ports (built into Audigy 2ZS card)

I hope there is a solution to this ongoing battle that I am trying so hard to win!! Any help is greatly appreciated... I am a Windows XP Extreme Power user so I know a good amount about hardware ops just know very little about Linux and SUSE and the way they work lol..

thanks!!
 
Old 04-20-2006, 02:53 AM   #2
cmtishler
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Original Poster
Rep: Reputation: 0
update

Ok, lol here we go... I typed in 3 commands reccommended by another forum and this is what I got:

lsscsi:

[0:0:0:0] disk ATA Maxtor 6Y200M0 YAR5 /dev/sda
[2:0:0:0] disk Maxtor OneTouch 0201 /dev/sdb

lsusb

Bus 005 Device 004: ID 0d49:7010 Maxtor
bus 005 device 001: ID 0000:0000

That list goes further but I stopped here to notice the appearance of my Maxtor External HDD on bus 005 and also up on the lsscsi Maxtor OneTouch....

when I typed dmesg|tail I got this:

Vendor: Maxtor Model: OneTouch Rev: 0201
Type: Direct-Access ANSI SCSI revision: 00
SCSI device sdb: 160084992 512-byte hdwr sectors (81964 MB)
sdb: assuming drive cache: Write through
SCSI device sdb: 160084992 512-byte hdwr sectors (81964 MB)
sdb: assuming drive cache: Write through
sdb: sdb1
Attached scsi disk sdb at scsi2, channel 0, id 0, lun 0
Attached scsi generic sgl at scsi2, channel 0, id 0, lun 0, type 0
usb-storage: device scan complete


Now that last part lol I am LOST completely.. I am assuming that it is stating that my external HDD is there? I just don't understand how if SUSE says that it is supposed to recognize and mount all mobile hardware automatically why it would do this... Also now I am wondering what this could mean for my Wireless adapter card lol... Once again any help is greatly appreciated!!!

Thanks!
 
Old 04-20-2006, 02:54 AM   #3
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
EDIT: You just provided all the data, so my post was useless.

Have a look if your drive appears in /media. Otherwise, try manual mounting

mount -t vfat /dev/sdb1 /media/usbdisk -o users,umask=000

If this works, edit /etc/fstab and add a line like this to the end of the file:

/dev/sdb1 /media/usbdisk vfat users,umask=000 0 0

This will enable you to mount the drive e.g. from a desktop icon even if the automatic recognition doesn't work.

Last edited by abisko00; 04-20-2006 at 03:01 AM.
 
Old 04-20-2006, 03:03 AM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I did some editing due to our simulaneous post. You better reload/reread the above post.
 
Old 04-20-2006, 03:05 AM   #5
cmtishler
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Original Poster
Rep: Reputation: 0
some head way hopefully!!!

ok I just entered the command that you posted:

mount -t vfat /dev/sdb1 /media/usbdisk -o users,umask=000

gave me this:

mount: mount point /media/usbdisk does not exist

Last edited by cmtishler; 04-20-2006 at 03:15 AM.
 
Old 04-20-2006, 09:06 AM   #6
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
That's easy: create this mountpoint as root with:

mkdir /media/usbdisk

You may need to change its permissions with:

chown root:users /media/usbdisk
chmod 775 /media/usbdisk
 
Old 04-20-2006, 11:04 AM   #7
cmtishler
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Original Poster
Rep: Reputation: 0
filesystem

Ok well I made a dir and all and went to mount it and it said that it's the wrong fs type, bad option, bad superblock on dev/sdb1, missing codepage or other error... Here is my question on that though... Does the filesystem type on the external HDD HAVE to be FAT 32? I am running an internal S-ATA that is NTFS and linux is seeing it just fine so I don't understand why it won't see the external in an NTFS format as well, is there a special command to mount it as an NTFS rather then the vfat command?? I'll have to go over to the networking side again now also to get help on why my network wifi card still won't work.. Thanks!!
 
Old 04-20-2006, 12:35 PM   #8
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Sorry, I was just guessing your filesystem. If you are using an NTFS formated drive, you can replace vfat by ntfs, but you will be limited to read-access, as full ntfs write capability is not implemented in SUSE10. I heard rumours that it will be possible in 10.1, but I have no personal experience here.
 
Old 04-20-2006, 12:56 PM   #9
cmtishler
LQ Newbie
 
Registered: Apr 2006
Posts: 14

Original Poster
Rep: Reputation: 0
sweet, ok I got the drive mounted... cannot figure out how to edit that /etc/fstab area so that I can auto mount every time... Other then that, SUSE is now seeing my drive!! Thank you VERY much... Now to just get the Wireless network adapter working lol!!
 
Old 04-20-2006, 01:08 PM   #10
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
You can edit /etc/fstab as root (e.g. kdesu kwrite /etc/fstab). If I followed your information correctly, you need to add this:

/dev/sdb1 /media/usbdisk ntfs noauto,users,umask=000 0 0

to the end of this file. Make sure this is in one line. Now you can create a desktop icon (Right-click on the desktop -> Create New -> Link to Device -> Harddisk (or ZIP). In the "Device" section, search for your new fstab entry. One the device is attached, click the icon and it will be mounted automatically.
 
Old 04-21-2006, 07:49 AM   #11
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
UPDATE:

I just browsed some other SUSE forums and found a hint that may apply to your problem. Some hardware recognition trouble may be cause by an error in the hal package. The suggested fix was to recompile the hal rpm from its src.rpm (which should be available on the DVD-SRC.ISO or online from an opensuse repository). The command is
rpmbuild --rebuild hal-<version>.src.rpm

Maybe this will also fix your wireless problem.

Last edited by abisko00; 04-21-2006 at 07:50 AM.
 
Old 09-03-2006, 01:57 AM   #12
jferrero
LQ Newbie
 
Registered: Sep 2006
Posts: 1

Rep: Reputation: 0
Angry Maxtor One Touch

I have always been a Microsoft user since I got my first PC ages ago. I installed Ubuntu in my PC and I already had a Maxtor OneTouch II working previously on Windows XP.
Everything went just fine with the instalation. It recognized the external drive without apparent problems.
The thing is..... I can access it and read or play everything in it, but it appears as read only and I do not know of a way to change that.
Please keep in mind in your replies that I am a 3 days old Linux user!!!!!!!!
HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
Old 12-24-2006, 03:55 AM   #13
Kerel2000
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Rep: Reputation: 0
Hi all,

I'm trying to solve the same problem with a simple usb stick. when I try to mount I get:

mount: special device /dev/sd1 does not exist

I dont get it at all. when I put the stick in before booting I get the replace with bootable disk message but otherwise I cant find the stick anywhere on my system. My SD cardreader is working sweetly though if I put in a card a new device pops up and I can use it no problem. (btw once this is fixed I also have to get the wireless and ethernet card going)

as you can probably see I'm also quite new to linux. It took me 10 minutes to figure out the su command so that I could be root user in the console

Last edited by Kerel2000; 12-24-2006 at 03:58 AM.
 
Old 12-24-2006, 05:07 AM   #14
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
For the original suse post, you might want to take a look at running konqueror and entering "sysinfo:/" in the address bar. It can cause the system to be rescanned and you might be able to see your usb and firewire drives.
Udev and helper applications should be able to mount them without adding an entry in /etc/fstab. Do you have this entry in /etc/fstab:
Code:
usbfs   /proc/bus/usb   usbfs   noauto 0 0
For the firewire drive to be detected you may need to modprobe the ohci1394 and ieee1394 kernel modules.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: External USB or firewire drives Steel_J LinuxAnswers Discussion 30 03-05-2012 01:46 PM
External USB/Firewire DVD not detecting properly with Suse 9.2 Marshalle Linux - Laptop and Netbook 2 03-13-2005 05:35 PM
firewire or usb 2.0 for external hdd jfall Linux - Hardware 1 02-24-2005 03:38 AM
Which WiFi (PCMCIA or USB) card should I buy for SuSE 9.0? Funksaw Linux - Laptop and Netbook 3 10-11-2004 08:06 AM
External Firewire or USB 2.0 ? reefer77 Linux - Hardware 1 04-17-2004 07:43 AM


All times are GMT -5. The time now is 09:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration